You are not logged in.

#1 2020-01-09 10:19:50

pauledd
Member
Registered: 2019-12-14
Posts: 28

[SOLVED] Pulseaudio profile constantly changes in standby

Hi

I currently changed from gentoo to arch so that I am a arch-NOOB smile

Problem:
As soon as screen goes into standby issued by kde energy management and is then waked up again my audio profile changes
from (headphone output (desired))
https://p-bg.de/pics/pulseaudio_problem1.png
to (Monitor speaker (not desired))
https://p-bg.de/pics/pulseaudio_problem2.png

and that is VERY annoying.
How can I make pulseaudio, which obviously automatically changes profile if ANY change was detected, to not change the
profile if it detects HDMI again after returning from screen blanking?

I tried to create/copy the default default.pa to my ~./config/pulse directory and just added this one line in the hope that this would work by specifying a default Profile, but it didn't work...

default.pa:

...
### Make some devices default
set-default-sink alsa_output.pci-0000_00_1f.3.iec958-stereo
#set-default-source input
...

Any ideas how to solve that?

Last edited by pauledd (2020-01-09 13:14:00)

Offline

#2 2020-01-09 11:06:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,486

Re: [SOLVED] Pulseaudio profile constantly changes in standby

There will be a profile change blacklist (or on checking probably just for the module-switch-on-connect module... hmm) in the next release, in the meantime you can simply disable automatic profile switching by commenting/removing

load-module module-switch-on-port-available

in that default.pa

Also please change these images to links or thumbnails: https://wiki.archlinux.org/index.php/Co … s_and_code

Last edited by V1del (2020-01-09 11:06:45)

Offline

#3 2020-01-09 13:13:16

pauledd
Member
Registered: 2019-12-14
Posts: 28

Re: [SOLVED] Pulseaudio profile constantly changes in standby

Thanks, that solved the problem.

Offline

Board footer

Powered by FluxBB