You are not logged in.

#1 2020-01-09 12:22:19

user28371
Member
Registered: 2018-12-07
Posts: 8

[SOLVED] VS Code not starting up

Hi, today I've turned on my computer, and despite it working yesterday VS Code won't start.
I can't see any rm, or chmods or anything like that in history, so I don't think I've deleted anything I should not have...

$ code --verbose
Unable to create argv.json configuration file in /usr/data/argv.json, falling back to defaults (Error: EACCES: permission denied, open '/usr/data/argv.json')
[1627:0109/131806.211039:ERROR:sandbox_linux.cc(369)] InitializeSandbox() called with multiple threads in process gpu-process.
[main 2020-01-09T12:18:06.214Z] Error: ENOENT: no such file or directory, mkdir
[main 2020-01-09T12:18:06.215Z] Lifecycle#kill()
$ sudo pacman -Qi code
Name            : code
Version         : 1.41.1-1
Description     : The Open Source build of Visual Studio Code (vscode) editor
Architecture    : x86_64
URL             : https://github.com/microsoft/vscode
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : electron6  libsecret  libx11  libxkbfile  ripgrep
Optional Deps   : bash-completion: Bash completions
                  zsh-completions: ZSH completitons
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 65,78 MiB
Packager        : Filipe Laíns <lains@archlinux.org>
Build Date      : Pá 20. prosince 2019, 11:57:30 CET
Install Date    : Čt 9. ledna 2020, 10:46:23 CET
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

I've tried reinstalling, just in case, but nothing; restart, nothing; downgrade, nothing...

Any help? Thanks.

Last edited by user28371 (2020-03-15 00:10:49)

Offline

#2 2020-01-09 12:48:22

user28371
Member
Registered: 2018-12-07
Posts: 8

Re: [SOLVED] VS Code not starting up

Using code-insiders from aur works for now, but I'd like the real version from package manager.

Offline

#3 2020-01-09 14:27:14

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,489

Re: [SOLVED] VS Code not starting up

Unable to create argv.json configuration file in /usr/data/argv.json, falling back to defaults (Error: EACCES: permission denied, open '/usr/data/argv.json')

neither pacman -F nor pkgfile can find a argv.json file, also /usr/data/ is not a standard directory and not used at all in the code pacakge.

Maybe the file comes from some 3rd party package, post

$ pacman -Qo /usr/data/argv.json

output.

Last edited by Lone_Wolf (2020-01-09 14:27:51)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#4 2020-01-09 14:45:24

user28371
Member
Registered: 2018-12-07
Posts: 8

Re: [SOLVED] VS Code not starting up

$ pacman -Qo /usr/data/argv.json
error: No package owns /usr/data/argv.json

I've noticed that Zeek/Bro from AUR had a few files there, though.

The file it's probably looking for is ~/.vscode-oss/argv.json, which does exist and looks ok.

I see a lot of "help, vscode not starting up," but never a solution...
I've even found the same question on stack overflow from 7 months ago.

I guess I should close this question. File it under " just vscode/microsoft/electron things..."

Offline

#5 2020-02-10 19:15:37

stepovic
Member
Registered: 2016-05-09
Posts: 3

Re: [SOLVED] VS Code not starting up

In case you're still interested in finding a solution: Have you tried removing /usr/data? I once had that folder as well, filled with an extension folder and an argv.json file. After removing /usr/data starting code-oss worked. Seems like I tried running it with sudo, so the files where created in /usr and since then code tried to load the config from there.

I used visual-studio-code-bin (from the AUR) previously. Re-using the config from ~/.vscode (as I moved it to ~/.vscode-oss) wasn't an issue at all.

Offline

#6 2020-03-15 00:09:02

user28371
Member
Registered: 2018-12-07
Posts: 8

Re: [SOLVED] VS Code not starting up

stepovic wrote:

In case you're still interested in finding a solution: Have you tried removing /usr/data? I once had that folder as well, filled with an extension folder and an argv.json file. After removing /usr/data starting code-oss worked. Seems like I tried running it with sudo, so the files where created in /usr and since then code tried to load the config from there.

I used visual-studio-code-bin (from the AUR) previously. Re-using the config from ~/.vscode (as I moved it to ~/.vscode-oss) wasn't an issue at all.


Oh, wow! Yeah, solved!

Thank you very much smile

Offline

Board footer

Powered by FluxBB