You are not logged in.

#1 2020-01-12 18:27:23

d_fajardo
Member
Registered: 2017-07-28
Posts: 570

[Solved] Unable to install dwave-ocean-sdk python package

I am trying to install the dwave-ocean-sdk pyhon package. I created a an env with PyCharm and tried to add package but PyCharm threw me this error:

ERROR: Could not find a version that satisfies the requirement ortools<7.0.0,>=6.6.4659 (from penaltymodel-mip<0.3.0,>=0.2.0; extra == "mip"->dwavebinarycsp[mip]<0.1.0,>=0.0.9; (platform_machine == "x86_64" or platform_machine == "amd64" or platform_machine == "AMD64") and python_version != "3.4"->dwave-ocean-sdk) (from versions: none)
ERROR: No matching distribution found for ortools<7.0.0,>=6.6.4659 (from penaltymodel-mip<0.3.0,>=0.2.0; extra == "mip"->dwavebinarycsp[mip]<0.1.0,>=0.0.9; (platform_machine == "x86_64" or platform_machine == "amd64" or platform_machine == "AMD64") and python_version != "3.4"->dwave-ocean-sdk)

Does this suggest I need python3.4?
So I installed python3.4 from AUR and tried with that interpreter in PyCharm but still fails.
Can anyone please enlighten me on how to install this package?

EDIT: I tried pip --user but that fail as well, but of course it is using the current python.
How does one temporarily revert to python3.4 (installed)?

Last edited by d_fajardo (2020-01-12 21:07:06)

Offline

#2 2020-01-12 21:06:50

d_fajardo
Member
Registered: 2017-07-28
Posts: 570

Re: [Solved] Unable to install dwave-ocean-sdk python package

Never mind. I found the solution. The problem was dwave requires ortools but support for ortools in 3.8 is not implemented yet.
So I installed python3.7 (uninstalled my 3.4) and installed ortools and dwave-ocean-sdk didn't have any issues in installation.
I must say pipenv helped.

Offline

Board footer

Powered by FluxBB