You are not logged in.

#1 2020-01-14 21:10:16

dzeju
Member
Registered: 2020-01-14
Posts: 5

[SOLVED] KDE Plasma widgets not detecting time and date

Hello there,

I'm on freshly installed arch with Plasma and I don't know why widgets can't display any date or time

https://i.postimg.cc/J7YGXgCx/clock.png

when I look at system settings time and date looks just fine

I couldn't find anything about this on google so maybe someone here would have a solution?

moderator edit -- replaced oversized image with link.
Pasting pictures and code

Last edited by dzeju (2020-01-16 08:04:54)

Offline

#2 2020-01-14 22:32:51

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,382

Re: [SOLVED] KDE Plasma widgets not detecting time and date

Welcome to the boards what's your output for

localectl
locale -a
locale

post that in [ code ] tags.

Offline

#3 2020-01-14 22:43:03

dzeju
Member
Registered: 2020-01-14
Posts: 5

Re: [SOLVED] KDE Plasma widgets not detecting time and date

Thank you for answer!

localectl:

   
  System Locale: LANG=pl_PL.UTF-8
       VC Keymap: n/a
       X11 Layout: n/a

locale -a:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX

locale:

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=

Offline

#4 2020-01-14 22:52:20

duhstrasen
Member
Registered: 2020-01-14
Posts: 3

Re: [SOLVED] KDE Plasma widgets not detecting time and date

Same problem here.

localectl

System Locale: LANG=C
      VC Keymap: n/a
      X11 Layout: n/a

locale -a

C
POSIX
en_US.utf8

locale

LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=

Offline

#5 2020-01-14 23:02:15

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,382

Re: [SOLVED] KDE Plasma widgets not detecting time and date

@djezu you don't have the PL locale generated: https://wiki.archlinux.org/index.php/Lo … ng_locales

@duhastren you have the locale generated but not properly set up: https://wiki.archlinux.org/index.php/Lo … tem_locale

Offline

#6 2020-01-14 23:12:36

duhstrasen
Member
Registered: 2020-01-14
Posts: 3

Re: [SOLVED] KDE Plasma widgets not detecting time and date

@V1del thank you. it worked.

Offline

#7 2020-01-14 23:38:48

dzeju
Member
Registered: 2020-01-14
Posts: 5

Re: [SOLVED] KDE Plasma widgets not detecting time and date

@V1del generated, still no result hmm

Offline

#8 2020-01-15 00:50:25

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,382

Re: [SOLVED] KDE Plasma widgets not detecting time and date

Repost these outputs. Also you will likely need to restart your programs/plasma/KDE for this to take effect after generating. Also you should probably by principle generate en_US.utf8 as well, as it isn't guaranteed that applications have lang packs for PL. everything should have en_US so it's always a good idea to have these as well.

Last edited by V1del (2020-01-15 12:36:02)

Offline

#9 2020-01-15 14:19:38

dzeju
Member
Registered: 2020-01-14
Posts: 5

Re: [SOLVED] KDE Plasma widgets not detecting time and date

added US and restarted with no effect

localectl:

   System Locale: LANG=pl_PL.UTF-8
       VC Keymap: n/a
      X11 Layout: n/a

locale -a:

C
en_US.utf8
pl_PL.utf8
POSIX

locale:

LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=

Offline

#10 2020-01-15 19:25:21

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,382

Re: [SOLVED] KDE Plasma widgets not detecting time and date

timedatectl

did you set your timezone?

Offline

#11 2020-01-15 19:39:36

dzeju
Member
Registered: 2020-01-14
Posts: 5

Re: [SOLVED] KDE Plasma widgets not detecting time and date

I have timezone set up via NetworkManager
https://wiki.archlinux.org/index.php/Sy … _a_network

output of timedatectl:

               Local time: śro 2020-01-15 20:35:02 UTC
           Universal time: śro 2020-01-15 20:35:02 UTC
                 RTC time: śro 2020-01-15 20:35:01
                Time zone: n/a (UTC, +0000)
System clock synchronized: no
              NTP service: inactive
          RTC in local TZ: no

EDIT:
Yea I just noticed it didnt set timezone...
Fixed that with

timedatectl set-timezone Europe/Warsaw

and now time and date works.

Thank you very much for your help!

Last edited by dzeju (2020-01-15 19:48:59)

Offline

#12 2020-01-15 23:22:51

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,965

Re: [SOLVED] KDE Plasma widgets not detecting time and date

Please remember to mark your thread [SOLVED] (edit the title of your first post).

How to Post

Offline

Board footer

Powered by FluxBB