You are not logged in.

#1 2020-01-15 18:12:29

trazalca
Member
Registered: 2012-01-19
Posts: 21

[Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

After pacman -Syu i have this error:

impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
:: l'installazione di protobuf (3.11.2-1) interrompe la dipendenza 'protobuf=3.11.1' richiesta da 

Someone has suggestions?
Thanks in advance

Last edited by trazalca (2020-01-15 19:35:25)

Offline

#2 2020-01-15 18:19:51

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,159
Website

Re: [Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

Looks like python2-protobuf just needs updating to reflect the new protobuf version, see the comment on the AUR package page.

Offline

#3 2020-01-15 18:20:07

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,989

Re: [Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

Please prepend LC_ALL=C to your pacman command so the output will be in English.

https://wiki.archlinux.org/index.php/Co … s_and_code

python2-protobuf is an AUR package. You need to update it.

Moving to AUR issues.

Offline

#4 2020-01-15 18:21:11

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,332
Website

Re: [Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

It's your responsibility to manage AUR upgrades, not pacman's.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 2020-01-15 18:24:53

trazalca
Member
Registered: 2012-01-19
Posts: 21

Re: [Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

Sorry, didn't realize that was in AUR!
Thanks

Offline

#6 2020-01-15 18:31:30

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,989

Re: [Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

trazalca wrote:

Sorry, didn't realize that was in AUR!
Thanks

How did you install it in the first place?

Offline

#7 2020-01-15 18:38:59

trazalca
Member
Registered: 2012-01-19
Posts: 21

Re: [Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

2ManyDogs wrote:
trazalca wrote:

Sorry, didn't realize that was in AUR!
Thanks

How did you install it in the first place?

With yay, but don't know when and why. Readed in AUR Package Details that i'm not the only with this problem... may be i have only to wait, i hope!

Offline

#8 2020-01-15 18:55:14

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,989

Re: [Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

Wait for what? You have an outdated AUR package (python2-protobuf). You need to update it, or remove it if you don't know why you have it.

Offline

#9 2020-01-15 19:05:40

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,382
Website

Re: [Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

Up until early December it was an official package, it's possible you installed it as a dependency of something else. Check with

pacman -Qi python2-protobuf

Remove it and anything that depends on it, if you don't need them any more -- python2 is EOL.

Also, please change your topic title to actually describe your issue.

Last edited by WorMzy (2020-01-15 19:09:17)


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Online

#10 2020-01-15 19:36:32

trazalca
Member
Registered: 2012-01-19
Posts: 21

Re: [Solved] protobuf (3.11.2-1) breaks dependency 'protobuf=3.11.1'

WorMzy wrote:

Up until early December it was an official package, it's possible you installed it as a dependency of something else. Check with

pacman -Qi python2-protobuf

Remove it and anything that depends on it, if you don't need them any more -- python2 is EOL.

Also, please change your topic title to actually describe your issue.

Ok, removed and did the job.
Thanks

Offline

Board footer

Powered by FluxBB