You are not logged in.

#1 2020-01-16 00:55:55

1ptb3b
Member
Registered: 2017-01-17
Posts: 73

How to quiet spammy ECC disabled logs [SOLVED]

My boot logs keep getting spammed by this message.

EDAC amd64: Node 0: DRAM ECC disabled.
EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
 Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
 (Note that use of the override may cause unknown side effects.)

I don't have ECC RAM. Who do I have to tell so they don't try to load the ECC module?

I already tried setting ecc_enable_override=0 in my kernel params, but it didn't do anything.

Last edited by 1ptb3b (2020-01-16 01:44:12)

Offline

#2 2020-01-16 01:05:18

loqs
Member
Registered: 2014-03-06
Posts: 13,875

Re: How to quiet spammy ECC disabled logs [SOLVED]

It will be removed with linux 5.5 https://git.kernel.org/pub/scm/linux/ke … 0f11f6314b

Offline

#3 2020-01-16 01:43:58

1ptb3b
Member
Registered: 2017-01-17
Posts: 73

Re: How to quiet spammy ECC disabled logs [SOLVED]

Faaaantastic!

Offline

#4 2020-01-20 01:10:51

WFV
Member
From: ☭USSA⛧⭒⭒⭒⭒
Registered: 2013-04-23
Posts: 281

Re: How to quiet spammy ECC disabled logs [SOLVED]

Don't know if this will work for you in the interim, try blacklisting via modprobe add

blacklist amd64_edac_mod

to /etc/modprobe.d/modprobe.conf

EDIT: kernel 5.5 doesn't stop the messages but reduces the information:

Jan 31 21:47:13 arch-pelago kernel: EDAC MC: Ver: 3.0.0
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: F15h detected (node 0).
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: Node 0: DRAM ECC disabled.
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: F15h detected (node 0).
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: Node 0: DRAM ECC disabled.
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: F15h detected (node 0).
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: Node 0: DRAM ECC disabled.
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: F15h detected (node 0).
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: Node 0: DRAM ECC disabled.
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: F15h detected (node 0).
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: Node 0: DRAM ECC disabled.
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: F15h detected (node 0).
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: Node 0: DRAM ECC disabled.
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: F15h detected (node 0).
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: Node 0: DRAM ECC disabled.
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: F15h detected (node 0).
Jan 31 21:47:14 arch-pelago kernel: EDAC amd64: Node 0: DRAM ECC disabled.
% uname -a 
Linux arch-pelago 5.5.0-arch1-1 #1 SMP PREEMPT Mon, 27 Jan 2020 21:22:06 +0000 x86_64 GNU/Linux

(this an older machine Asus M5A88-M; AMD-FX8350), restore blacklisting removes the boot message.

Last edited by WFV (2020-02-01 06:23:34)


∞ hard times make the strong, the strong make good times, good times make the weak, the weak make hard times ∞

Offline

Board footer

Powered by FluxBB