You are not logged in.

#1 2020-01-24 01:42:47

beohoff
Member
Registered: 2014-11-29
Posts: 15

Black Screen After Install Splash Screen with Live Disk

Hey I've got a:

Intel Core i9-9920X
ASUS ROG STRIX X299-E
Nvidia GPU 760 (don't remember the brand)
2666 MHz DDR4 RAM
Samsung E 500GB 970EVO NVME M.2 SSD

I'm trying to install using a live usb. I'm using the 20-01-01 image. Currently, after the splash screen where I can select different options, when I select the install from live cd, the screen instantly goes to black.

I've tried adding nomodeset to the kernel command line, but I have the same issue. also tried `nomodeset nouveau.modeset=0`, still didn't work.

Offline

#2 2020-01-24 01:56:58

beohoff
Member
Registered: 2014-11-29
Posts: 15

Re: Black Screen After Install Splash Screen with Live Disk

Secure boot and fast boot have been turned off.

I tried a Ubuntu image, but it freezes on the loading screen, similar to the black screen experienced after loading.

There's no internal GPU on this board (I believe), so don't think I can use that.

Offline

#3 2020-01-24 04:10:41

beohoff
Member
Registered: 2014-11-29
Posts: 15

Re: Black Screen After Install Splash Screen with Live Disk

I was able to run a memory test from the Ubuntu live cd. It passed. In the Ubuntu live cd, after setting nomodset and I think acpi off, I got a zlib failure and a Squashfs error bad data error. I'm not sure if this is related to the errors that I'm seeing with arch Linux, but I'm hoping to get any type of Linux working first, and then work backwards from there.

Last edited by beohoff (2020-01-24 04:12:09)

Offline

#4 2020-01-24 11:48:21

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,712

Re: Black Screen After Install Splash Screen with Live Disk

That sounds like your USB is borked. What do you use to write the image, can you check another usb stick?

Offline

#5 2020-01-24 13:12:03

beohoff
Member
Registered: 2014-11-29
Posts: 15

Re: Black Screen After Install Splash Screen with Live Disk

I used dd.

sudo dd bs=4M if=Downloads/archlinux-2020.01.01-x86_64.iso of=/dev/sdb conv=fdatasync status=progress

I was able to confirm one of the usb sticks that I was using (the one that had the Ubuntu image on it) was bad. Threw it away. I reflashed the good usb with the arch linux 20-01-01 image. I then tested booting into the live cd on my laptop, which worked. However, trying to boot into the system that is spec'd above, using `nomodeset nouveau.modeset=0` still ended up with a black screen.

I also verified that the md5sums on the arch linux image match the server image.

Last edited by beohoff (2020-01-24 13:18:44)

Offline

#6 2020-01-24 13:31:49

loqs
Member
Registered: 2014-03-06
Posts: 9,823

Re: Black Screen After Install Splash Screen with Live Disk

Does adding the follow options make a difference:

acpi=off iommu=off init_on_alloc=off mitigations=off earlyprintk=efi ignore_loglevel

Offline

#7 2020-01-24 14:12:13

beohoff
Member
Registered: 2014-11-29
Posts: 15

Re: Black Screen After Install Splash Screen with Live Disk

Hey it boots now! I'll try reinstalling later today.

Before you commented, I was able to install Ubuntu this morning with the acpi=off command and update the Nvidia drivers.

Even after updating the drivers, I can't boot into Ubuntu without going into Grub and setting the `acpi=off` kernel parameter. I'll update you after installing Arch, but I'm guessing that  it will have similar issues?

Offline

#8 2020-01-25 17:06:17

beohoff
Member
Registered: 2014-11-29
Posts: 15

Re: Black Screen After Install Splash Screen with Live Disk

I was able to successfully install arch! I only had to use the acpi=off kernel parameter to get everything working.

However, I am not successfully able to boot into my new install unless I add that parameter. My boot will freeze without the kernel parameter acpi=off.

Open to ideas on how to fix or things that I'm missing.

Offline

#9 2020-01-25 18:41:28

beohoff
Member
Registered: 2014-11-29
Posts: 15

Re: Black Screen After Install Splash Screen with Live Disk

I tried following this list: https://wiki.ubuntu.com/DebuggingACPI

Specifically I tried the following kernel parameters

- acpi=ht
- pci=noacpi
- acpi=noirq
- pnpacpi=off
- noapic
- nolapic

No luck, can't get past "Loading Initial Ramdisk"

Offline

#10 2020-01-25 20:46:19

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,712

Re: Black Screen After Install Splash Screen with Live Disk

Check if there's an update for your UEFI firmware available.

Offline

#11 2020-01-26 03:37:52

beohoff
Member
Registered: 2014-11-29
Posts: 15

Re: Black Screen After Install Splash Screen with Live Disk

Updating the motherboard firmware fixed the issue. If I can mark this solved I will? Otherwise please mark it solved for me.

Offline

#12 2020-01-26 11:28:40

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,712

Re: Black Screen After Install Splash Screen with Live Disk

Yes please do, by editing the title in the first post of the thread.

Offline

Board footer

Powered by FluxBB