You are not logged in.

#1 2020-02-03 14:45:30

DeadLink404
Member
Registered: 2017-11-24
Posts: 38

[Solved] systemd-tmpfiles hook fails to execute with smt disabled.

During my last update the pacman hook /usr/share/libalpm/hooks/30-systemd-tmpfiles.hook failed.

Something along the line of:

(3/5) Creating temporary files...
Error: Command failed to execute correctly

The hook with that description /usr/share/libalpm/hooks/30-systemd-tmpfiles.hook contains

 "Exec =  /usr/share/libalpm/scripts/systemd-hook tmpfiles"  

And that leads to:

    tmpfiles)  /usr/bin/systemd-tmpfiles --create ;;

So I executed /usr/bin/systemd-tmpfiles --create myself and I got this:

Failed to write file "/sys/devices/system/cpu/cpufreq/policy6/energy_performance_preference": Invalid argument
Failed to write file "/sys/devices/system/cpu/cpufreq/policy4/energy_performance_preference": Invalid argument
Failed to write file "/sys/devices/system/cpu/cpufreq/policy7/energy_performance_preference": Invalid argument
Failed to write file "/sys/devices/system/cpu/cpufreq/policy5/energy_performance_preference": Invalid argument

I have an 8-core machine but I boot with nosmt. After turning smt back on with `sudo tee /sys/devices/system/cpu/smt/control <<< on` the command executed properly.

I opened an issue upstream

Edit:
This appears to be pebkac.
I had a file /etc/tmpfiles.d/energy_performance_preference.conf with

w /sys/devices/system/cpu/cpufreq/policy?/energy_performance_preference - - - - power

How do you make it so this only matches the files it can access?
Accesing policy[5-7] only fails with smt disabled, ala:

cat: /sys/devices/system/cpu/cpufreq/policy7/energy_performance_preference: No such device or address

Last edited by DeadLink404 (2020-02-03 16:03:51)

Offline

Board footer

Powered by FluxBB