You are not logged in.

#1 2020-02-05 19:08:51

ipyakuza
Member
Registered: 2013-06-24
Posts: 16

[SOLVED] projectm with pulseaudio not working

Hello to all, I've got an up to date install of arch on my Dell XPS 7590 laptop using alsa + pulseaudio (all which work great with browsers/Youtube, MPD, VLC, etc).  Using pavucontrol I can clearly see all the applications and sinks.  When I run projectM (with projectm-pulseaudio package) it doesn't seem to respond to any audio activity.  I can press M and get into the settings menu, SETTINGS -> PULSE AUDIO SETTINGS  and choose the specific sink to play off of but there is no activity in projectm.  I can verify in pavucontrol in the recording tab it's active and verify its linked to the same sink my music player (mpd) or firefox (youtube) is playing audio through yet nothing.  Any thoughts on where I should look or settings to try?  Below are my /etc/pulse/default.pa (which I believe is still stock (don't recall making any changes to this) and my projectm configs:

#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
#load-module module-udev-detect 
load-module module-udev-detect tsched=0
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
load-module module-dbus-protocol
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GSettings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gsettings.so
.nofail
load-module module-gsettings
.fail
.endif


### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input

qprojectM-pulseaudio.conf:

 
[General]
pulseAudioDeviceName=alsa_output.pci-0000_00_1f.3.analog-stereo.monitor
tryFirstAvailablePlaybackMonitor=false

qprojectM.conf:

[General]
FullscreenOnStartup=false
MenuOnStartup=false
MouseHideOnTimeout=5
PlaylistFile=/usr/share/projectM/presets
playlistDockLocation=0
playlistDocked=true
playlistPath=/home/ipyakuza
playlistPos=@Point(0 18)
playlistWindowSize=@Size(315 505)
pos=@Point(856 380)

Last edited by ipyakuza (2020-02-05 20:38:18)

Offline

#2 2020-02-05 19:16:54

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,673

Re: [SOLVED] projectm with pulseaudio not working

Post during this setup

pacmd list-sinks
pacmd list-sink-inputs
pacmd list-sources
pacmd list-source-outputs

FWIW I've tested this and it immediately worked without me doing anything in particular.

Last edited by V1del (2020-02-05 19:32:36)

Online

#3 2020-02-05 19:28:07

ipyakuza
Member
Registered: 2013-06-24
Posts: 16

Re: [SOLVED] projectm with pulseaudio not working

pacmd list-sinks

2 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 100.88 ms
	max request: 17 KiB
	max rewind: 17 KiB
	monitor source: 1
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 2
	linked by: 5
	fixed latency: 99.95 ms
	card: 1 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC3266 Analog"
		alsa.id = "ALC3266 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xed518000 irq 179"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a348"
		device.product.name = "Cannon Lake PCH cAVS"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "17632"
		device.buffering.fragment_size = "4408"
		device.access_mode = "mmap"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		alsa.mixer_name = "Realtek ALC3266"
		alsa.components = "HDA:10ec0298,10280905,00100103 HDA:8086280b,80860101,00100000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"
	active port: <analog-output-headphones>
    index: 3
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.equalizer>
	driver: <module-equalizer-sink.c>
	flags: HW_MUTE_CTRL LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 1000
	volume: front-left: 65536 / 100%,   front-right: 65536 / 100%
	        balance 0.00
	base volume: 65536 / 100%
	volume steps: 65537
	muted: no
	current latency: 201.14 ms
	max request: 62 KiB
	max rewind: 34 KiB
	monitor source: 4
	sample spec: float32le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 4
	fixed latency: 99.95 ms
	module: 29
	properties:
		device.master_device = "alsa_output.pci-0000_00_1f.3.analog-stereo"
		device.class = "filter"
		device.description = "FFT based equalizer on Built-in Audio Analog Stereo"
		device.icon_name = "audio-card"
[ipyakuza@hakkaisan ~]$ pacmd list-sink-inputs
3 sink input(s) available.
    index: 25
	driver: <module-equalizer-sink.c>
	flags: START_CORKED 
	state: RUNNING
	sink: 0 <alsa_output.pci-0000_00_1f.3.analog-stereo>
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 72.20 ms
	requested latency: n/a
	sample spec: float32le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	resample method: copy
	module: 29
	properties:
		media.name = "Equalized Stream"
		media.role = "filter"
		module-stream-restore.id = "sink-input-by-media-role:filter"
    index: 27
	driver: <protocol-native.c>
	flags: 
	state: RUNNING
	sink: 3 <alsa_output.pci-0000_00_1f.3.analog-stereo.equalizer>
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 250.00 ms
	requested latency: 99.95 ms
	sample spec: s24-32le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	resample method: copy
	module: 13
	client: 1 <Music Player Daemon>
	properties:
		media.name = "Pulse Audio Device"
		application.name = "Music Player Daemon"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		media.role = "music"
		application.icon_name = "mpd"
		application.process.id = "731"
		application.process.user = "ipyakuza"
		application.process.host = "hakkaisan"
		application.process.binary = "mpd"
		application.language = "C"
		application.process.machine_id = "41e3a0c2754549559edb2cb5d9e10a9d"
		module-stream-restore.id = "sink-input-by-media-role:music"
    index: 159
	driver: <protocol-native.c>
	flags: START_CORKED 
	state: RUNNING
	sink: 0 <alsa_output.pci-0000_00_1f.3.analog-stereo>
	volume: front-left: 0 /   0% / -inf dB,   front-right: 0 /   0% / -inf dB
	        balance 0.00
	muted: no
	current latency: 128.75 ms
	requested latency: 99.95 ms
	sample spec: float32le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	resample method: speex-float-1
	module: 13
	client: 14 <Firefox>
	properties:
		media.name = "AudioStream"
		application.name = "Firefox"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.process.id = "3321"
		application.process.user = "ipyakuza"
		application.process.host = "hakkaisan"
		application.process.binary = "firefox"
		application.language = "C"
		window.x11.display = ":0"
		application.process.machine_id = "41e3a0c2754549559edb2cb5d9e10a9d"
		application.process.session_id = "3"
		application.icon_name = "firefox"
		module-stream-restore.id = "sink-input-by-application-name:Firefox"
[ipyakuza@hakkaisan ~]$ pacmd list-sources
3 source(s) available.
  * index: 0
	name: <alsa_input.usb-046d_HD_Pro_Webcam_C920_80FDA8BF-02.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 9049
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 9619 /  15% / -50.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.15 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 32000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	fixed latency: 99.94 ms
	card: 0 <alsa_card.usb-046d_HD_Pro_Webcam_C920_80FDA8BF-02>
	module: 6
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "USB Audio"
		alsa.id = "USB Audio"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "HD Pro Webcam C920"
		alsa.long_card_name = "HD Pro Webcam C920 at usb-0000:00:14.0-2.2, high speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:00:14.0-usb-0:2.2:1.2"
		sysfs.path = "/devices/pci0000:00/0000:00:14.0/usb1/1-2/1-2.2/1-2.2:1.2/sound/card1"
		udev.id = "usb-046d_HD_Pro_Webcam_C920_80FDA8BF-02"
		device.bus = "usb"
		device.vendor.id = "046d"
		device.vendor.name = "Logitech, Inc."
		device.product.id = "082d"
		device.product.name = "HD Pro Webcam C920"
		device.serial = "046d_HD_Pro_Webcam_C920_80FDA8BF"
		device.form_factor = "webcam"
		device.string = "front:1"
		device.buffering.buffer_size = "12792"
		device.buffering.fragment_size = "3196"
		device.access_mode = "mmap"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "HD Pro Webcam C920 Analog Stereo"
		alsa.mixer_name = "USB Mixer"
		alsa.components = "USB046d:082d"
		module-udev-detect.discovered = "1"
		device.icon_name = "camera-web-usb"
	ports:
		analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
	active port: <analog-input-mic>
    index: 1
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 1030
	volume: front-left: 66535 / 102% / 0.39 dB,   front-right: 66535 / 102% / 0.39 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: yes
	current latency: 0.00 ms
	max rewind: 17 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 3
	linked by: 3
	fixed latency: 99.95 ms
	monitor_of: 0
	card: 1 <alsa_card.pci-0000_00_1f.3>
	module: 7
	properties:
		device.description = "Monitor of Built-in Audio Analog Stereo"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xed518000 irq 179"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "a348"
		device.product.name = "Cannon Lake PCH cAVS"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
    index: 4
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.equalizer.monitor>
	driver: <module-equalizer-sink.c>
	flags: DECIBEL_VOLUME LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 1000
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: yes
	current latency: 0.00 ms
	max rewind: 34 KiB
	sample spec: float32le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 3
	linked by: 3
	fixed latency: 99.95 ms
	monitor_of: 3
	module: 29
	properties:
		device.description = "Monitor of FFT based equalizer on Built-in Audio Analog Stereo"
		device.class = "monitor"
		device.icon_name = "audio-input-microphone"
[ipyakuza@hakkaisan ~]$ pacmd list-source-outputs
7 source output(s) available.
    index: 0
	driver: <protocol-native.c>
	flags: DONT_MOVE 
	state: RUNNING
	source: 0 <alsa_input.usb-046d_HD_Pro_Webcam_C920_80FDA8BF-02.analog-stereo>
	volume: mono: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 0.00 ms
	requested latency: 99.94 ms
	sample spec: float32le 1ch 25Hz
	channel map: mono
	             Mono
	resample method: peaks
	owner module: 13
	client: 10 <PulseAudio Volume Control>
	properties:
		media.name = "Peak detect"
		application.name = "PulseAudio Volume Control"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.id = "org.PulseAudio.pavucontrol"
		application.icon_name = "audio-card"
		application.version = "4.0"
		application.process.id = "1842"
		application.process.user = "ipyakuza"
		application.process.host = "hakkaisan"
		application.process.binary = "pavucontrol"
		application.language = "C"
		window.x11.display = ":0"
		application.process.machine_id = "41e3a0c2754549559edb2cb5d9e10a9d"
		application.process.session_id = "3"
		module-stream-restore.id = "source-output-by-application-id:org.PulseAudio.pavucontrol"
    index: 1
	driver: <protocol-native.c>
	flags: DONT_MOVE 
	state: RUNNING
	source: 1 <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	volume: mono: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 87.71 ms
	requested latency: 99.95 ms
	sample spec: float32le 1ch 25Hz
	channel map: mono
	             Mono
	resample method: peaks
	owner module: 13
	client: 10 <PulseAudio Volume Control>
	properties:
		media.name = "Peak detect"
		application.name = "PulseAudio Volume Control"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.id = "org.PulseAudio.pavucontrol"
		application.icon_name = "audio-card"
		application.version = "4.0"
		application.process.id = "1842"
		application.process.user = "ipyakuza"
		application.process.host = "hakkaisan"
		application.process.binary = "pavucontrol"
		application.language = "C"
		window.x11.display = ":0"
		application.process.machine_id = "41e3a0c2754549559edb2cb5d9e10a9d"
		application.process.session_id = "3"
		module-stream-restore.id = "source-output-by-application-id:org.PulseAudio.pavucontrol"
    index: 31
	driver: <protocol-native.c>
	flags: DONT_MOVE 
	state: RUNNING
	source: 1 <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	volume: mono: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 87.89 ms
	requested latency: 99.95 ms
	sample spec: float32le 1ch 25Hz
	channel map: mono
	             Mono
	resample method: peaks
	owner module: 13
	client: 10 <PulseAudio Volume Control>
	direct on input: 25
	properties:
		media.name = "Peak detect"
		application.name = "PulseAudio Volume Control"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.id = "org.PulseAudio.pavucontrol"
		application.icon_name = "audio-card"
		application.version = "4.0"
		application.process.id = "1842"
		application.process.user = "ipyakuza"
		application.process.host = "hakkaisan"
		application.process.binary = "pavucontrol"
		application.language = "C"
		window.x11.display = ":0"
		application.process.machine_id = "41e3a0c2754549559edb2cb5d9e10a9d"
		application.process.session_id = "3"
		module-stream-restore.id = "source-output-by-application-id:org.PulseAudio.pavucontrol"
    index: 32
	driver: <protocol-native.c>
	flags: DONT_MOVE 
	state: RUNNING
	source: 4 <alsa_output.pci-0000_00_1f.3.analog-stereo.equalizer.monitor>
	volume: mono: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 76.53 ms
	requested latency: 99.95 ms
	sample spec: float32le 1ch 25Hz
	channel map: mono
	             Mono
	resample method: peaks
	owner module: 13
	client: 10 <PulseAudio Volume Control>
	properties:
		media.name = "Peak detect"
		application.name = "PulseAudio Volume Control"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.id = "org.PulseAudio.pavucontrol"
		application.icon_name = "audio-card"
		application.version = "4.0"
		application.process.id = "1842"
		application.process.user = "ipyakuza"
		application.process.host = "hakkaisan"
		application.process.binary = "pavucontrol"
		application.language = "C"
		window.x11.display = ":0"
		application.process.machine_id = "41e3a0c2754549559edb2cb5d9e10a9d"
		application.process.session_id = "3"
		module-stream-restore.id = "source-output-by-application-id:org.PulseAudio.pavucontrol"
    index: 35
	driver: <protocol-native.c>
	flags: DONT_MOVE 
	state: RUNNING
	source: 4 <alsa_output.pci-0000_00_1f.3.analog-stereo.equalizer.monitor>
	volume: mono: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 76.53 ms
	requested latency: 99.95 ms
	sample spec: float32le 1ch 25Hz
	channel map: mono
	             Mono
	resample method: peaks
	owner module: 13
	client: 10 <PulseAudio Volume Control>
	direct on input: 27
	properties:
		media.name = "Peak detect"
		application.name = "PulseAudio Volume Control"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.id = "org.PulseAudio.pavucontrol"
		application.icon_name = "audio-card"
		application.version = "4.0"
		application.process.id = "1842"
		application.process.user = "ipyakuza"
		application.process.host = "hakkaisan"
		application.process.binary = "pavucontrol"
		application.language = "C"
		window.x11.display = ":0"
		application.process.machine_id = "41e3a0c2754549559edb2cb5d9e10a9d"
		application.process.session_id = "3"
		module-stream-restore.id = "source-output-by-application-id:org.PulseAudio.pavucontrol"
    index: 170
	driver: <protocol-native.c>
	flags: 
	state: RUNNING
	source: 4 <alsa_output.pci-0000_00_1f.3.analog-stereo.equalizer.monitor>
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 76.53 ms
	requested latency: 99.95 ms
	sample spec: float32le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	resample method: (null)
	owner module: 13
	client: 35 <projectM>
	properties:
		media.name = "projectM"
		application.name = "projectM"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.process.id = "165835"
		application.process.user = "ipyakuza"
		application.process.host = "hakkaisan"
		application.process.binary = "projectM-pulseaudio"
		application.language = "C"
		window.x11.display = ":0"
		application.process.machine_id = "41e3a0c2754549559edb2cb5d9e10a9d"
		application.process.session_id = "3"
		application.icon_name = "prjm16-transparent"
		module-stream-restore.id = "source-output-by-application-name:projectM"
    index: 177
	driver: <protocol-native.c>
	flags: DONT_MOVE 
	state: RUNNING
	source: 1 <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	volume: mono: 65536 / 100% / 0.00 dB
	        balance 0.00
	muted: no
	current latency: 88.07 ms
	requested latency: 99.95 ms
	sample spec: float32le 1ch 25Hz
	channel map: mono
	             Mono
	resample method: peaks
	owner module: 13
	client: 10 <PulseAudio Volume Control>
	direct on input: 162
	properties:
		media.name = "Peak detect"
		application.name = "PulseAudio Volume Control"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.id = "org.PulseAudio.pavucontrol"
		application.icon_name = "audio-card"
		application.version = "4.0"
		application.process.id = "1842"
		application.process.user = "ipyakuza"
		application.process.host = "hakkaisan"
		application.process.binary = "pavucontrol"
		application.language = "C"
		window.x11.display = ":0"
		application.process.machine_id = "41e3a0c2754549559edb2cb5d9e10a9d"
		application.process.session_id = "3"
		module-stream-restore.id = "source-output-by-application-id:org.PulseAudio.pavucontrol"

Offline

#4 2020-02-05 19:38:20

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,673

Re: [SOLVED] projectm with pulseaudio not working

index: 1
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 1030
	volume: front-left: 66535 / 102% / 0.39 dB,   front-right: 66535 / 102% / 0.39 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: yes

And there we have it ™

pacmd set-source-mute alsa_output.pci-0000_00_1f.3.analog-stereo.monitor off
pacmd set-source-mute alsa_output.pci-0000_00_1f.3.analog-stereo.equalizer.monitor off

If you want to double check this in pavucontrol you have to enable showing monitor streams in the dropdown on the output devices tab.

Last edited by V1del (2020-02-05 19:42:19)

Online

#5 2020-02-05 20:37:55

ipyakuza
Member
Registered: 2013-06-24
Posts: 16

Re: [SOLVED] projectm with pulseaudio not working

Bingo this was it.  I actually had it on my equalizer monitor and once I set it to off (verified in pavucontrol) everything worked.  With multiple tabs inputs/ouputs and the added layer of an equalizer monitor that created a problem making sure both mpd and projectM were on the same one (and all unmuted).  Thanks for the help!

Offline

Board footer

Powered by FluxBB