You are not logged in.

#1 2020-02-08 09:36:49

Registered: 2007-02-23
Posts: 34

[SOLVED] HP Zbook w locked BIOS. Install archlinux, but how?

Some douchbag at work left me with my HP ZBook bios locked (HP ZBook 17 G1)

I can think of 2 options to install arch.

1) From another PC:

- SSD - usb adapter - other PC
- partition SSD
- install arch
- SDD goes back into my laptop

I tried that with grub and 1 bootable BIOS partition /dev/sda1 (no swap, no uefi).
But I'm receiving "device '/dev/sda2' not found" at boot time.
No idea why this happens (labels or UUIDs, doesn't matter. both fail to boot)

2) Install the live arch iso on the SSD

- SSD - usb adapter - other PC
- dd latest arch iso onto the SSD
- back into the laptop

I can now boot the machine into the live environment.
Next, install arch permanently using the live environment.
Partitions /dev/sda1 and /dev/sda2 came with the environment.

So I went ahead, created  /dev/sda3 and ran a check on the partition table as you can see here ->
There were warnings/errors (partition 1 overlaps partition 2).
Not sure though, if I should safely ignore these warnings.
Because later, when I'd want to turn the disk space currently occupied by those partitions (/dev/sda1 and /dev/sda2) into a single swap partition, then the warnings shouldn't matter, right?

I think I might be on the right path here, I just need a little bit help.

Thanks a lot!


Option #) didn't work. went with #1: … oned_disks … tion_table

EFI MBR, first partition must carry the boot flag, then syslinux, then x server, kde plasma
(dont forget to adjust the partition labels in /etc/fstab and syslinux.cfg accordingly. e.g. /dev/sdh should become /dev/sda
before reinstalling the SSD drive back)

one thing that isn't quite righ yett: only the fallback image works. I think a bunch of modules are missing
in the normal image. I haven't figured out which exactly or how to fix the module detection routine for mkinitcpio.
but that's the problem that is causing the boot to fail very early with "device '/dev/sda2' not found", that I mentioned above.

Last edited by goodboy (2020-02-08 22:54:37)


Board footer

Powered by FluxBB