You are not logged in.

#1 2020-02-09 18:13:24

BuddhiArch
Member
Registered: 2020-02-09
Posts: 31

I can't set up my audio system to work [SOLVED]

Hi, all. I'm new to Arch.
I have been trying to solve this problem for three days now.

I have read the topics about ALSA, PulseAudio, and Driver Installation, front to end. I have installed pavucontrol, and some others, but none of them resolved my problem.

For drivers,

pacman -Ss xf85-video 
extra/xf86-video-intel 1:2.99.917+899+gf66d3954-1 (xorg-drivers) [installed]
    X.org Intel i810/i830/i915/945G/G965+ video drivers
extra/xf86-video-nouveau 1.0.16-1 (xorg-drivers) [installed]
    Open Source 3D acceleration driver for nVidia cards

I have installed nvidia-beta, and it said removed nvidia previous driver. The recommended for my system is nvidia-lts or nvidia-beta (GTX 1050 is ''Pascal'' family on the nvidia's table).
But, it says it is still using nvidia, not nvidia-beta.

Command

 lspci -v 

gives:

01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 3 GB Max-Q] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Dell GP107M [GeForce GTX 1050 3 GB Max-Q]
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at a2000000 (32-bit, non-prefetchable) [size=16M]
        Memory at 90000000 (64-bit, prefetchable) [size=256M]
        Memory at a0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 4000 [size=128]
        Expansion ROM at a3000000 [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia

And, my sound says Capabilities: acess denied

Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
        Flags: bus master, fast devsel, latency 0, IRQ 17
        Memory at a3080000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel

And,

lspci | grep -e VGA -e 3D
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 3 GB Max-Q] (rev a1)

Here is my alsa-info.sh:
http://alsa-project.org/db/?f=06fcd5ceb … 4c3da73501



My computer is of Dell's new series G3 15, i5 - 9300, GTX 1050.
I have not found information about previous problems with this machine architecture, in
https://wiki.archlinux.org/index.php/Laptop/Dell

When I had Ubuntu, I frequently had to command the audio system to reaload, so it works. It seemed like the HDMI card would not be recognized, and it went to default routes, then it worked.

pulseaudio -k && sudo alsa force-reload

Last edited by BuddhiArch (2020-02-09 23:20:07)


"Perhaps your fox can perform that trick, but that is not the manner of Zen. My miracle is that when I feel hungry I eat, and when I feel thirsty I drink."

Offline

#2 2020-02-09 18:54:40

BuddhiArch
Member
Registered: 2020-02-09
Posts: 31

Re: I can't set up my audio system to work [SOLVED]

Pavucontrol  says my Input Device AND Output Devices is GP107GL High Definition Audio Controller Digital Stereo (HDMI).

When I put a video to play, it shows the sound is going up and down, but no audio comes out.

I don't know what should be my output device, or how to configure it.


"Perhaps your fox can perform that trick, but that is not the manner of Zen. My miracle is that when I feel hungry I eat, and when I feel thirsty I drink."

Offline

#3 2020-02-09 20:40:17

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,475

Re: I can't set up my audio system to work [SOLVED]

Where do all these audio configurations come from? Why did you do them? There's a lot of config for a system that has apparently not worked yet, I suggest you remove most of those. Are you sure you want audio out of the Nvidia card, and not rather the onboard sound card? Remove nvidia-beta and use the in repo nvidia package. There's no difference version wise but you have to be aware of more stuff that isn't necessary with the repo packages.

Please use [ code ] [ /code ] tags without spaces to post outputs.

On to what I suspect your actual problem to be. You have issues loading the proper firmware for the onboard audio card and it is not enumerated properly, something you could try is e.g. /etc/modprobe.d/hda_fix.conf

options snd_hda_intel dmic_detect=0

and reboot and recheck whether the internal card is properly loaded.

Offline

#4 2020-02-09 21:11:55

BuddhiArch
Member
Registered: 2020-02-09
Posts: 31

Re: I can't set up my audio system to work [SOLVED]

Dude, you are amazing. Thank you, for solving my problem. I was felling so obnoxious for I didn't have sound, and could not solve it.

It worked.

Hmm... Now, about where the audio configurations came from, mostly, from all the sites I searched an answer for a specific thing, that I didn't know would work for me. Although, I hoped so.

[Starting to go off topic]
I would like to know more about the difference of an audio coming out of the Nvidia card, or the onboard - would that change the performance of the computer somehow?

I have set nvidia-lts to be my driver now, too. So, It's not running on nvidia-beta anymore. As you recommended.

[Going further off]
Do you have any recommendations of book and manual readings to understand more about Linux architecturing, so to suit computer?
Specifically, I would like to build my Arch to make my computer to run Funcional Programming languages faster. I program Common Lisp, Clojure(script), Julia, and some Python.
My memory is formatted on XFS, right now, for example.

Last edited by BuddhiArch (2020-02-09 21:23:38)


"Perhaps your fox can perform that trick, but that is not the manner of Zen. My miracle is that when I feel hungry I eat, and when I feel thirsty I drink."

Offline

#5 2020-02-09 21:30:49

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,475

Re: I can't set up my audio system to work [SOLVED]

It's not about performance, audio out of the nvidia card only works if you have a monitor with built in speakers hooked to one of the  external screen outputs of the laptop and you want audio out of that.

I strongly suggest you get rid of these configurations, they will have no relevant impact as long as you use applications that have pulse support, but should you wander across something still relying on ALSA you will likely have issues making it play along with the proper pulse setup, and install pulseaudio-alsa instead.

That config option was expected to have stabilized with the 5.5 kernels, apparently it's still not quite ready, but if the kernel parameter works that should be fine.

If you are happy with this solution, please mark the thread as [SOLVED] by editing the title in your first post: https://wiki.archlinux.org/index.php/Co … ow_to_post

Offline

#6 2020-02-09 23:27:14

BuddhiArch
Member
Registered: 2020-02-09
Posts: 31

Re: I can't set up my audio system to work [SOLVED]

So, are you recommending me to delete the content on:

/etc/asound.conf
~/.asoundrc

Just to be sure?

Edit:

I have moved them into a form not readable, e.g., .txt,

mv /etc/asound.conf  /etc/asound_problematic_conf.text
mv ~/.asoundrc ~/problematic_dot_asoundrc.text

and rebooted. The audio is still functioning as intended. So, I believe that is, indeed, what you meant.

Thanks for the help.

Last edited by BuddhiArch (2020-02-09 23:51:14)


"Perhaps your fox can perform that trick, but that is not the manner of Zen. My miracle is that when I feel hungry I eat, and when I feel thirsty I drink."

Offline

Board footer

Powered by FluxBB