You are not logged in.

#1 2020-02-09 21:30:17

pitti
Member
Registered: 2020-02-09
Posts: 3

no USB hotplug in battery mode

I have an USB hotplug problem with my ThinkPad T495s.

As long as the power supply is plugged in, the USB hotplug works fine.  The system recognizes every USB device I plug in.

If I have disconnected the power supply from the ThinkPad, the USB hotplug does not work anymore.  The USB devices that were previously recognized are now no longer recognized.

To find out what could be the cause, I listed on the USB bus for the events according to the kernel documentation (usbmon.txt).  I could see a difference between battery and power mode.
In the power mode I saw the events immediately when i plugged in or removed an USB device.  In battery mode I saw nothing no events, whether I plugged in or removed an USB device.

If I plugged in a device in battery mode and subsequently plugged in the power supply, I immediately saw the events and the USB device was detected.

Does anyone have any idea?

Thanks!

Offline

#2 2020-02-09 21:32:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,495

Re: no USB hotplug in battery mode

Do you use a power saving daemon that enables USB autosuspend on battery? What happens if you disable said daemons config to not enable USB autosuspend?

Online

#3 2020-02-09 22:18:40

pitti
Member
Registered: 2020-02-09
Posts: 3

Re: no USB hotplug in battery mode

There is no power saving daemon running on my arch linux and there are also no autosuspend options from wiki set.
I have verified the setting under sys does not change between battery and power.

Offline

#4 2020-02-10 21:10:11

pitti
Member
Registered: 2020-02-09
Posts: 3

Re: no USB hotplug in battery mode

"solved"
I have disabled the autosuspend via module option.
@V1del thank you very much for your hint.

Does it make sense to inform the kernel developers about it?

Offline

#5 2020-06-27 14:08:00

zaphodias
Member
Registered: 2020-06-27
Posts: 2

Re: no USB hotplug in battery mode

pitti wrote:

"solved"
I have disabled the autosuspend via module option.
@V1del thank you very much for your hint.

Does it make sense to inform the kernel developers about it?

Hi pitti. I own the same laptop and facing the same problem.
Can you help me understand how did you solve it? Does your solution have "side effects"?

Thanks.

Offline

Board footer

Powered by FluxBB