You are not logged in.

#1 2020-02-11 16:31:49

justdanyul
Member
Registered: 2011-09-29
Posts: 88

KDE Plasma 5.17 and nvidia proprietary drivers

Hi all,

I'm seeing really sluggish performance on KDE Plasma 5.17, Kernel 5.5.2 and Nvidia 440.59-6 when opening applications through the application launcher. Basically, when opening applications using the application launcher, after I click on an application to open, the application launcher applies its close-transition in an incredibly choppy manner. I've got plasma rendering set to opengl and I have verified that the nvidia driver have loaded.

I been googling around, and apparently there are issues with KWIN and official nvidia drivers. Do any of you good people have experience running KDE on proprietary nvidia drivers (from what i can tell from searching the internets, nouveau have its share of issues as well, so that doesn't seem like a solution either), and if so, are there any solutions?

Last edited by justdanyul (2020-02-11 16:59:25)

Offline

#2 2020-02-11 18:18:57

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,925

Re: KDE Plasma 5.17 and nvidia proprietary drivers

They never played very well to me.
While i'm waiting to finally get an AMD gpu, I'm stuck with xrender kwin's compositor backend and use forcefullcompositionpipeline when i want vsync on the desktop.
If you have an intel gpu too, you could try to use it instead, and rely on nvidia just for gpu intensive tasks.
They say recent driver finally supports a sane way to start nvidia apps on intel screen, but i never tried.

Last edited by kokoko3k (2020-02-11 18:23:41)

Offline

#3 2020-02-11 20:00:57

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,713

Re: KDE Plasma 5.17 and nvidia proprietary drivers

Worksforme(tm) There have been issues that have mostly been fixed, what's your output for

qdbus org.kde.KWin /KWin org.kde.KWin.supportInformation #Needs qt5-tools
glxinfo -B #Needs mesa-demos

Something you should do regardless, if you aren't on SLI, is enabling modesetting via e.g. /etc/modprobe.d/nvidia.conf

options nvidia_drm modeset=1

which will fix a few things.

Something I've seen and recommended to people (though I haven't needed to use it myself) is to enable TripleBuffering on the nvidia driver: Make a xorg snippet like /etc/X11/xorg.conf.d/10-nvidia-buffer-fix.conf with the content

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option  "TripleBuffer" "on"
EndSection

Last edited by V1del (2020-02-12 08:25:09)

Online

#4 2020-02-11 20:28:54

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 712

Re: KDE Plasma 5.17 and nvidia proprietary drivers

Try using kwin-lowlatency from AUR too, might help.

Offline

#5 2020-02-13 21:21:39

Volle
Member
From: Stuttgart, Germany
Registered: 2013-12-05
Posts: 48

Re: KDE Plasma 5.17 and nvidia proprietary drivers

justdanyul wrote:

I've got plasma rendering set to opengl and....

I just removed all of my plasma configs (wanted to clean out old stuff) and did face the exact same problem.
when I set rendering to xrender everything is smooth so I'll stay on that for now...

I will try the other suggestions but I haven't got much hope

Offline

#6 2020-02-15 12:41:42

justdanyul
Member
Registered: 2011-09-29
Posts: 88

Re: KDE Plasma 5.17 and nvidia proprietary drivers

V1del wrote:

Worksforme(tm) There have been issues that have mostly been fixed, what's your output for

qdbus org.kde.KWin /KWin org.kde.KWin.supportInformation #Needs qt5-tools
glxinfo -B #Needs mesa-demos

Something you should do regardless, if you aren't on SLI, is enabling modesetting via e.g. /etc/modprobe.d/nvidia.conf

options nvidia_drm modeset=1

which will fix a few things.

Something I've seen and recommended to people (though I haven't needed to use it myself) is to enable TripleBuffering on the nvidia driver: Make a xorg snippet like /etc/X11/xorg.conf.d/10-nvidia-buffer-fix.conf with the content

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option  "TripleBuffer" "on"
EndSection

Hi there, thanks for your post.

I've added the modeset=1 and enabled triple buffering as per the above, and the problem still persists. Here is the output of my the qdbus org.kde.KWin command you asked for

KWin Support Information:
The following information should be used when requesting support on e.g. https://forum.kde.org.
It provides information about the currently running instance, which options are used,
what OpenGL driver and which effects are running.
Please post the information provided underneath this introductory text to a paste bin service
like https://paste.kde.org instead of pasting into support threads.

==========================

Version
=======
KWin version: 5.18.0
Qt Version: 5.14.1
Qt compile version: 5.14.1
XCB compile version: 1.13.1

Operation Mode: X11 only

Build Options
=============
KWIN_BUILD_DECORATIONS: yes
KWIN_BUILD_TABBOX: yes
KWIN_BUILD_ACTIVITIES: yes
HAVE_DRM: yes
HAVE_GBM: yes
HAVE_EGL_STREAMS: yes
HAVE_X11_XCB: yes
HAVE_EPOXY_GLX: yes
HAVE_WAYLAND_EGL: yes

X11
===
Vendor: The X.Org Foundation
Vendor Release: 12007000
Protocol Version/Revision: 11/0
SHAPE: yes; Version: 0x11
RANDR: yes; Version: 0x14
DAMAGE: yes; Version: 0x11
Composite: yes; Version: 0x4
RENDER: yes; Version: 0xb
XFIXES: yes; Version: 0x50
SYNC: yes; Version: 0x31
GLX: yes; Version: 0x0

Decoration
==========
Plugin: org.kde.kwin.aurorae
Theme: __aurorae__svg__McMojave
Plugin recommends border size: No
Blur: 1
onAllDesktopsAvailable: false
alphaChannelSupported: true
closeOnDoubleClickOnMenu: false
decorationButtonsLeft: 0, 2
decorationButtonsRight: 6, 3, 4, 5
borderSize: 3
gridUnit: 10
font: Noto Sans,10,-1,5,50,0,0,0,0,0,Regular
smallSpacing: 2
largeSpacing: 10

Platform
==========
Name: KWin::X11StandalonePlatform

Options
=======
focusPolicy: 0
nextFocusPrefersMouse: false
clickRaise: true
autoRaise: false
autoRaiseInterval: 0
delayFocusInterval: 0
shadeHover: false
shadeHoverInterval: 250
separateScreenFocus: false
placement: 4
focusPolicyIsReasonable: true
borderSnapZone: 10
windowSnapZone: 10
centerSnapZone: 0
snapOnlyWhenOverlapping: false
rollOverDesktops: true
focusStealingPreventionLevel: 1
operationTitlebarDblClick: 5000
operationMaxButtonLeftClick: 5000
operationMaxButtonMiddleClick: 5015
operationMaxButtonRightClick: 5014
commandActiveTitlebar1: 0
commandActiveTitlebar2: 28
commandActiveTitlebar3: 2
commandInactiveTitlebar1: 4
commandInactiveTitlebar2: 28
commandInactiveTitlebar3: 2
commandWindow1: 7
commandWindow2: 8
commandWindow3: 8
commandWindowWheel: 28
commandAll1: 10
commandAll2: 3
commandAll3: 14
keyCmdAllModKey: 16777251
showGeometryTip: false
condensedTitle: false
electricBorderMaximize: true
electricBorderTiling: true
electricBorderCornerRatio: 0.25
borderlessMaximizedWindows: false
killPingTimeout: 5000
hideUtilityWindowsForInactive: true
compositingMode: 1
useCompositing: true
hiddenPreviews: 1
glSmoothScale: 1
xrenderSmoothScale: false
maxFpsInterval: 16666666
refreshRate: 0
vBlankTime: 6000000
glStrictBinding: false
glStrictBindingFollowsDriver: true
glCoreProfile: true
glPreferBufferSwap: 99
glPlatformInterface: 1
windowsBlockCompositing: true

Screen Edges
============
desktopSwitching: false
desktopSwitchingMovingClients: false
cursorPushBackDistance: 1x1
timeThreshold: 150
reActivateThreshold: 350
actionTopLeft: 0
actionTop: 0
actionTopRight: 0
actionRight: 0
actionBottomRight: 0
actionBottom: 0
actionBottomLeft: 0
actionLeft: 0

Screens
=======
Multi-Head: no
Active screen follows mouse:  no
Number of Screens: 1

Screen 0:
---------
Name: DP-4
Geometry: 0,0,5120x1440
Scale: 1
Refresh Rate: 59.976


Compositing
===========
Compositing is active
Compositing Type: OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 1070 Ti/PCIe/SSE2
OpenGL version string: 3.1.0 NVIDIA 440.59
OpenGL platform interface: GLX
OpenGL shading language version string: 1.40 NVIDIA via Cg compiler
Driver: NVIDIA
Driver version: 440.59
GPU class: Unknown
OpenGL version: 3.1
GLSL version: 1.40
X server version: 1.20.7
Linux kernel version: 5.5.3
Direct rendering: Requires strict binding: no
GLSL shaders:  yes
Texture NPOT support:  yes
Virtual Machine:  no
OpenGL 2 Shaders are used
Painting blocks for vertical retrace:  yes

Loaded Effects:
---------------
zoom
kwin4_effect_login
slidingpopups
kwin4_effect_sessionquit
kwin4_effect_logout
slide
kwin4_effect_translucency
screenshot
kwin4_effect_windowaperture
desktopgrid
colorpicker
kwin4_effect_frozenapp
kwin4_effect_fadingpopups
kwin4_effect_morphingpopups
kwin4_effect_fade
kwin4_effect_squash
kwin4_effect_maximize
kwin4_effect_dialogparent
presentwindows
highlightwindow
blur
contrast
startupfeedback
screenedge
kscreen

Currently Active Effects:
-------------------------
blur
contrast

Effect Settings:
----------------
zoom:
zoomFactor: 1.2
mousePointer: 0
mouseTracking: 0
enableFocusTracking: false
followFocus: true
focusDelay: 350
moveFactor: 20
targetZoom: 1

kwin4_effect_login:
isActiveFullScreenEffect: false

slidingpopups:
slideInDuration: 150
slideOutDuration: 250

kwin4_effect_sessionquit:
isActiveFullScreenEffect: false

kwin4_effect_logout:
isActiveFullScreenEffect: false

slide:
duration: 500
horizontalGap: 45
verticalGap: 20
slideDocks: false
slideBackground: true

kwin4_effect_translucency:
isActiveFullScreenEffect: false

screenshot:

kwin4_effect_windowaperture:
isActiveFullScreenEffect: false

desktopgrid:
zoomDuration: 300
border: 10
desktopNameAlignment: 0
layoutMode: 0
customLayoutRows: 2
usePresentWindows: true

colorpicker:

kwin4_effect_frozenapp:
isActiveFullScreenEffect: false

kwin4_effect_fadingpopups:
isActiveFullScreenEffect: false

kwin4_effect_morphingpopups:
isActiveFullScreenEffect: false

kwin4_effect_fade:
isActiveFullScreenEffect: false

kwin4_effect_squash:
isActiveFullScreenEffect: false

kwin4_effect_maximize:
isActiveFullScreenEffect: false

kwin4_effect_dialogparent:
isActiveFullScreenEffect: false

presentwindows:
layoutMode: 0
showCaptions: true
showIcons: true
doNotCloseWindows: false
ignoreMinimized: false
accuracy: 20
fillGaps: true
fadeDuration: 150
showPanel: false
leftButtonWindow: 1
rightButtonWindow: 2
middleButtonWindow: 0
leftButtonDesktop: 2
middleButtonDesktop: 0
rightButtonDesktop: 0

highlightwindow:

blur:

contrast:

startupfeedback:
type: 1

screenedge:

kscreen:

Additionally, I tried, just for the fun of it, to use nouveau, this fixed the launcher lag. But, unfortunately I need CUDA, and also, KDE seems incredibly unstable under nouveau.

Offline

#7 2020-02-17 15:32:26

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,713

Re: KDE Plasma 5.17 and nvidia proprietary drivers

Looks from that outlook similar to mine (other than that I use breeze for the window decoration, but that shouldn't have an effect on plasma widgets), FWIW did you enable the FullCompositionPipeline people are talking about here? It should not be combined with an OpenGL setting in KWin as that leads to essentially twice the work.

Online

#8 2020-02-17 16:08:33

Xakep_SDK
Member
Registered: 2017-09-23
Posts: 42

Re: KDE Plasma 5.17 and nvidia proprietary drivers

You don't need any tearing workarounds with latest KDE, they fixed tearing bug in 5.15.x(it's KDE's fault)

1. Install fresh nvidia driver
2. Remove xorg config, it should work without it
3. In compositor settings, set OpenGL 3.1 and autodetection for vsync
You will not get any tearing at all.

You may install kwin-lowlatency and set vsync mechanism to none, it will drastically reduce latency and stutter

You don't need full compositing pipeline, or triple buffering, or opengl env. vars. Eveything shall work out of the box.

I'm on KDE 5.18, Nvidia 440.59

Offline

#9 2020-02-22 13:10:51

justdanyul
Member
Registered: 2011-09-29
Posts: 88

Re: KDE Plasma 5.17 and nvidia proprietary drivers

V1del wrote:

Looks from that outlook similar to mine (other than that I use breeze for the window decoration, but that shouldn't have an effect on plasma widgets), FWIW did you enable the FullCompositionPipeline people are talking about here? It should not be combined with an OpenGL setting in KWin as that leads to essentially twice the work.

Hi again, I tried both with and without the FullCompositionPipeline. It's not terribly dramatic tbh, I was just playing around with KDE. Seems like, on my box anyway, the effort needed to make it run decently is disproportionate to the "price", and generally, there seem to be lots of little kinks and bugs all over the place (themes partly applying until restart, some stuff just not installed, etc). I'm back booting into i3 again haha.

I'll give it a spin again in a few years, see if things have approved.

Thanks a lot for attempting to help though.

Last edited by justdanyul (2020-02-22 13:11:21)

Offline

Board footer

Powered by FluxBB