You are not logged in.

#1 2020-02-13 12:14:05

RobinSch
Member
Registered: 2020-02-13
Posts: 7

VNC Server not starting on mate arch linux (result = connection refuse

The log file of tigervnc server has this in it:

mate-session[1077]: WARNING: Could not make bus activated clients aware of DISPLAY=:1 environment variable: Could not connect: Connection refused
mate-session[1077]: WARNING: Could not make bus activated clients aware of MATE_DESKTOP_SESSION_ID=this-is-deprecated environment variable: Could not connect: Connection refused

(mate-session:1077): dconf-WARNING **: 10:08:58.516: failed to commit changes to dconf: Could not connect: Connection refused
mate-session[1077]: WARNING: Could not make bus activated clients aware of SESSION_MANAGER=local/RSG:@/tmp/.ICE-unix/1077,unix/RSG:/tmp/.ICE-unix/1077 environment variable: Could not connect: Connection refused

I tried multiple things like rebooting / editing the /usr/bin/vncserver file, but nothing fixed this. Googling for hours also gaved no result.

My xstartup file:

#!/bin/sh
unset DBUS_SESSION_BUS_ADDRESS

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
mate-session &

The problem is with dbus (see the line below) I believe.

unset DBUS_SESSION_BUS_ADDRESS

If I remove that line I get only this error.

mate-session[3099]: WARNING: Failed to acquire org.gnome.SessionManager

So how could I fix this?

Last edited by RobinSch (2020-02-13 12:15:57)

Offline

#2 2020-02-13 12:20:45

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,712

Re: VNC Server not starting on mate arch linux (result = connection refuse

Online

#3 2020-02-13 12:25:42

RobinSch
Member
Registered: 2020-02-13
Posts: 7

Re: VNC Server not starting on mate arch linux (result = connection refuse

How to use this for mate then because I haven't installed startxfce4 or smth ( Couldn't exec startxfce4: No such file or directory )

#!/bin/sh
exec dbus-launch startxfce4

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
mate-session &

Is my current startup file.

When I use exec dbus-launch mate-session I get those errors:

Failed to spawn gnome-keyring-daemon: Failed to execute child process “gnome-keyring-daemon” (No such file or directory)
mate-session[5811]: WARNING: Unable to find provider '' of required component 'dock'

(caja:5898): Gtk-WARNING **: 13:37:39.804: Failed to register client: GDBus.Error:org.gnome.SessionManager.AlreadyRegistered: Unable to register client
Initializing caja-image-converter extension
Failure: Module initialization failed
Initializing caja-open-terminal extension
Initializing caja-xattr-tags extension
no maximize: true
Cannot register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject

(nm-applet:5928): nm-applet-WARNING **: 13:37:39.950: An agent with this ID is already registered for this user.

(mate-volume-control-status-icon:5930): Gtk-WARNING **: 13:37:39.963: Negative content width -5 (allocation 1, extents 3x3) while allocating gadget (node image, owner GtkImage)

(mate-volume-control-status-icon:5930): Gtk-WARNING **: 13:37:39.963: Negative content height -5 (allocation 1, extents 3x3) while allocating gadget (node image, owner GtkImage)
Xlib:  extension "DPMS" missing on display ":1".

(nm-applet:5928): Gtk-WARNING **: 13:37:39.974: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 1

(nm-applet:5928): Gtk-WARNING **: 13:37:39.974: Negative content width -5 (allocation 1, extents 3x3) while allocating gadget (node image, owner GtkImage)

(nm-applet:5928): Gtk-WARNING **: 13:37:39.974: Negative content height -5 (allocation 1, extents 3x3) while allocating gadget (node image, owner GtkImage)

** (mate-settings-daemon:5867): WARNING **: 13:37:40.780: Could not execute xrdb -merge -quiet: Failed to execute child process “xrdb” (No such file or directory)

Last edited by RobinSch (2020-02-13 12:40:55)

Offline

#4 2020-02-13 13:10:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,715

Re: VNC Server not starting on mate arch linux (result = connection refuse

Try to stay closer to the listed example first :

#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
exec mate-session

Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2020-02-13 13:15:02

RobinSch
Member
Registered: 2020-02-13
Posts: 7

Re: VNC Server not starting on mate arch linux (result = connection refuse

Lone_Wolf wrote:

Try to stay closer to the listed example first :

#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
exec mate-session

Well unset DBUS gaved that error (according to the docs) and then I had to replace that line with exec dbus-launch startsxfec4 but as I used mate, that wouldn't work. So I changed it to mate-session.
So what am I missing then?

Offline

#6 2020-02-13 13:17:29

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,715

Re: VNC Server not starting on mate arch linux (result = connection refuse

Your first post didn't have unset SESSION_MANAGER before unsetting dbus .


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2020-02-13 13:19:00

RobinSch
Member
Registered: 2020-02-13
Posts: 7

Re: VNC Server not starting on mate arch linux (result = connection refuse

Lone_Wolf wrote:

Your first post didn't have unset SESSION_MANAGER before unsetting dbus .


Wait so it must be:

#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
exec mate-session

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
mate-session &

But that gaved:

mate-session[7750]: WARNING: Could not make bus activated clients aware of DISP>
mate-session[7750]: WARNING: Could not make bus activated clients aware of MATE>

(mate-session:7750): dconf-WARNING **: 14:19:51.538: failed to commit changes t>
mate-session[7750]: WARNING: Could not make bus activated clients aware of SESS>

And when I use

#!/bin/sh
unset SESSION_MANAGER
exec dbus-launch mate-session

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
mate-session 

I get:

Failed to spawn gnome-keyring-daemon: Failed to execute child process “gnome-keyring-daemon” (No such file or directory)
mate-session[4632]: WARNING: Unable to find provider '' of required component 'dock'

(caja:4721): Gtk-WARNING **: 07:24:04.435: Failed to register client: GDBus.Error:org.gnome.SessionManager.AlreadyRegistered: Unable to register client
Initializing caja-image-converter extension
Initializing caja-open-terminal extension
Initializing caja-xattr-tags extension

** (mate-settings-daemon:4688): WARNING **: 07:24:04.540: Could not execute xrdb -merge -quiet: Failed to execute child process “xrdb” (No such file or directory)
no maximize: true
Cannot register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject

(nm-applet:4759): nm-applet-WARNING **: 07:24:04.605: An agent with this ID is already registered for this user.
Xlib:  extension "DPMS" missing on display ":1".

Last edited by RobinSch (2020-02-14 06:25:08)

Offline

#8 2020-02-14 11:54:07

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,715

Re: VNC Server not starting on mate arch linux (result = connection refuse

Did some searching and reading , and now think this may be a permission issue.

posrt the output of

ls -l ~/.vnc/

In case your xstart file is located somewhere else, run ls -l on that location.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#9 2020-02-14 13:02:50

RobinSch
Member
Registered: 2020-02-13
Posts: 7

Re: VNC Server not starting on mate arch linux (result = connection refuse

Lone_Wolf wrote:

Did some searching and reading , and now think this may be a permission issue.

posrt the output of

ls -l ~/.vnc/

In case your xstart file is located somewhere else, run ls -l on that location.

total 28
-rw-r--r-- 1 robinschapendonk robinschapendonk  332 Feb 12 19:31 config
-rw-r--r-- 1 robinschapendonk robinschapendonk  480 Feb 12 19:32 default.tigervnc
-rw------- 1 robinschapendonk robinschapendonk    8 Feb 12 19:31 passwd
-rw-r--r-- 1 robinschapendonk robinschapendonk 1315 Feb 14 07:26 RSG:1.log
-rw-r--r-- 1 robinschapendonk robinschapendonk 1378 Feb 14 07:07 RSG:2.log
-rw-r--r-- 1 robinschapendonk robinschapendonk 1925 Feb 12 19:35 RSG:3.log
-rwxr-xr-x 1 robinschapendonk robinschapendonk  317 Feb 14 07:26 xstartup

Offline

#10 2020-02-16 14:20:32

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,715

Re: VNC Server not starting on mate arch linux (result = connection refuse

Looks ok to me, I'm beginning to think we need input of someone with more knowledge (than me) of vncserver .

Wiki list several methods to start a vnc server , which method are you using ?

Last edited by Lone_Wolf (2020-02-16 14:22:27)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#11 2020-02-16 14:35:53

RobinSch
Member
Registered: 2020-02-13
Posts: 7

Re: VNC Server not starting on mate arch linux (result = connection refuse

Lone_Wolf wrote:

Looks ok to me, I'm beginning to think we need input of someone with more knowledge (than me) of vncserver .

Wiki list several methods to start a vnc server , which method are you using ?

I just use

vncserver

to start it

Offline

#12 Yesterday 18:40:35

RobinSch
Member
Registered: 2020-02-13
Posts: 7

Re: VNC Server not starting on mate arch linux (result = connection refuse

 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5901
 vncext:      created VNC server for screen 0

This is when I use another DE ( gnome instead mate) (and change the mate-sessions to gnome-sessions ofcourse)

Offline

#13 Today 11:31:04

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,715

Re: VNC Server not starting on mate arch linux (result = connection refuse

starting gnome-session instead of mate-session works ?

Try testing with other DE/WM like openbox, cinnamon and xfce .


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB