You are not logged in.
Hi guys.
I did an update after a long time but after that I cannot run Syy successfully.
Can you help me with investigating such issues?
output:
> pacman -Syy --debug
(...)
debug: registering sync database 'archlinuxfr'
debug: database path for tree archlinuxfr set to /var/lib/pacman/sync/archlinuxfr.db
debug: setting usage of 15 for archlinuxfr repository
debug: adding new server URL to database 'archlinuxfr': http://repo.archlinux.fr/x86_64
:: Synchronizing package databases...
debug: running command: /usr/bin/curl -C - -f http://archlinux.mirrors.linux.ro/core/ … 64/core.db > /var/lib/pacman/sync/core.db.part
Warning: Binary output can mess up your terminal. Use "--output -" to tell
Warning: curl to output it to your terminal anyway, or consider "--output
Warning: <FILE>" to save to a file.
debug: XferCommand command returned non-zero status code (768)
debug: returning error 52 from _alpm_download : error invoking external downloader
debug: running command: /usr/bin/curl -C - -f http://mirrors.aggregate.org/archlinux/ … 64/core.db > /var/lib/pacman/sync/core.db.part
Warning: Binary output can mess up your terminal. Use "--output -" to tell
Warning: curl to output it to your terminal anyway, or consider "--output
Warning: <FILE>" to save to a file.
debug: XferCommand command returned non-zero status code (768)
debug: returning error 52 from _alpm_download : error invoking external downloader
debug: running command: /usr/bin/curl -C - -f http://mirror.xtom.com.hk/archlinux/cor … 64/core.db > /var/lib/pacman/sync/core.db.part
folder:
0215 22:09 [4252] [archlinux: pacman/sync]# la
total 6560
drwxrwxrwx 2 root root 4096 Feb 15 22:09 .
drwxr-xr-x 4 root root 4096 Feb 15 22:09 ..
-rw-r--r-- 1 root root 9054 Feb 15 20:05 archlinuxfr.db
-rw-r--r-- 1 root root 5012895 Feb 15 20:04 community.db
-rw-r--r-- 1 root root 0 Feb 15 20:04 community.db.sig.part
-rw-r--r-- 1 root root 0 Feb 15 20:03 core.db.sig.part
-rw-r--r-- 1 root root 1681136 Feb 15 20:04 extra.db
-rw-r--r-- 1 root root 0 Feb 15 20:04 extra.db.sig.part
Last edited by borko (2020-02-16 12:10:13)
Offline
Sounds like you have XferCommand set in pacman.conf. Why?
Offline
....good question
.
Nevertheless - I removed XferCommand line from pacman.conf and it worked like a charm.
Thx!
Offline
You should have no cause to run -Syy in any case. Not only is that a waste of bandwidth in most cases, it can lead to partial upgrades.
You should also get rid of the archlinuxfr repo, it is the source of nothing by problems.
In any case, please remember to mark your thread as solved by editing your first post and amending the topic title: https://wiki.archlinux.org/index.php/Co … ow_to_post (please read the entire page, especially the section about posting pictures and code).
Sakura:-
Mobo: MSI MAG X570S TORPEDO MAX // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD
Making lemonade from lemons since 2015.
Offline