You are not logged in.

#1 2020-02-20 02:12:18

jiv222
Member
Registered: 2019-01-14
Posts: 54

Help getting Dell XPS 15 9570 to use Nvidia GPU

Hello,

For a while now, I've been trying to get my Dell XPS 15 9570 to utilize the 1050Ti GPU inside of it.  I have tried all solutions offered in the XPS 9570, but none have worked.  On a prior install of Arch (about a year ago), I managed to get this solution to work perfectly, however either the driver or kernel updates since that time have caused it to not work at all.  I've also tried installing optimus-manager, but was unable to start X when setting the nvidia card as the default startup mode.

Here is everything I believe is or could be relevant to solving this.  In reality, I'd like the ability to turn the GPU completely off when not using it, but really just want to be able to utilize it in some form. I keep my laptop plugged in most of the day, so I'm not overly worried about battery life.  This is the most recent option I've tried, using PRIME, but receive the following errors

NVIDIA GLX Module  440.59  Thu Jan 30 01:05:38 UTC 2020
[    24.881] (II) NVIDIA: The X server supports PRIME Render Offload.
[    28.994] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[    28.994] (EE) NVIDIA(GPU-0):     check your system's kernel log for additional error
[    28.994] (EE) NVIDIA(GPU-0):     messages and refer to Chapter 8: Common Problems in the
[    28.994] (EE) NVIDIA(GPU-0):     README for additional information.
[    28.994] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[    28.994] (EE) NVIDIA(G0): Failing initialization of X screen

The full Xorg.0.log file is here: https://pastebin.com/rhgjhVKP

Additionally, this is the output of

nvidia-bug-report.sh

https://pastebin.com/BSWvc48c

Here is some additional info that may be important:

uname -r
5.4.19-1-lts
pacman -Q nvidia
nvidia-lts 1:440.59-5
pacman -Q linux-lts
linux-lts 5.4.19-1
pacman -Q | grep nvidia
nvidia-lts 1:440.59-5
nvidia-prime 1.0-1
nvidia-settings 440.59-1
nvidia-utils 440.59-1
opencl-nvidia 440.59-1
journalctl -b | grep nvidia

https://pastebin.com/7Lv2MyDY

I am using this Xorg conf file for nvidia:

/etc/X11/xorg.conf.d/20-nvidia.conf
Section "ServerLayout"
        Identifier      "layout"
        Screen          0 "iGPU"
        Option          "AllowNVIDIAGPUScreens"
EndSection

Section "Device"
        Identifier      "iGPU"
        Driver          "modesetting"
EndSection

Section "Screen"
        Identifier      "iGPU"
        Device          "iGPU"
EndSection

Section "Device"
        Identifier      "dGPU"
        Driver          "nvidia"
        BusID           "01:00.0"
        VendorName      "NVIDIA Corporation"
EndSection

Output of

prime-run glxinfo
name of display: :0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  39
  Current serial number in output stream:  40

Output of

 lspci | grep -E "(VGA|3D)"
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)

If anyone has any clue what's stopping my GPU from working, any help is greatly appreciated.  I feel like I've tried everything, so I figured posting here may be my last shot until some further updates or a new laptop.  At this point, I'm not even sure the GPU still works.  Thanks a lot for the help in advance.

Offline

#2 2020-02-20 09:38:27

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,991

Re: Help getting Dell XPS 15 9570 to use Nvidia GPU

Offline

Board footer

Powered by FluxBB