You are not logged in.

#1 2020-02-21 20:26:25

anadyr
Member
Registered: 2005-02-10
Posts: 225

[Solved] VBoxClient segfaults after upgrade to 6.1.4

Running Arch Linux as guest in Oracle Virtualbox, on a Windows 10 host. Version of Virtualbox is the latest 6.1.4.  All packages in the Arch linux guest are up to date.

Since the upgrade to virtualbox-guest-modules-arch-6.1.4 and virtualbox-guest-utils-6.1.4 VBoxClient segfaults every 7 seconds or so:

Output of dmesg:

[   25.647648] VBoxClient[631]: segfault at 968 ip 00007fd79d21a0bd sp 00007ffcf17b5d60 error 4 in libX11.so.6.3.0[7fd79d1ff000+89000]
[   32.245430] VBoxClient[826]: segfault at 968 ip 00007fd79d21a0bd sp 00007ffcf17b5d60 error 4 in libX11.so.6.3.0[7fd79d1ff000+89000]
[   39.508458] VBoxClient[860]: segfault at 968 ip 00007fd79d21a0bd sp 00007ffcf17b5d60 error 4 in libX11.so.6.3.0[7fd79d1ff000+89000]
[   46.144352] VBoxClient[887]: segfault at 968 ip 00007fd79d21a0bd sp 00007ffcf17b5d60 error 4 in libX11.so.6.3.0[7fd79d1ff000+89000]

Example coredump:

[user@../coredump]$ coredumpctl info 2066
           PID: 2066 (VBoxClient)
           UID: 1000 (user)
           GID: 100 (users)
        Signal: 11 (SEGV)
     Timestamp: Fri 2020-02-21 21:17:31 CET (11s ago)
  Command Line: /usr/bin/VBoxClient --vmsvga-x11
    Executable: /usr/bin/VBoxClient
Control Group: /user.slice/user-1000.slice/session-1.scope
          Unit: session-1.scope
         Slice: user-1000.slice
       Session: 1
     Owner UID: 1000 (user)
       Boot ID: 2aa45a620a674ca2879766767be47c40
    Machine ID: f73967160bca40b4a0f0aebbd599c7e0
      Hostname: archlinux
       Storage: /var/lib/systemd/coredump/core.VBoxClient.1000.2aa45a620a674ca2879766767be47c40.2066.1582316251000000000000.lz4
       Message: Process 2066 (VBoxClient) of user 1000 dumped core.
               
                Stack trace of thread 2066:
                #0  0x00007fd79d21a0bd XQueryExtension (libX11.so.6 + 0x370bd)
                #1  0x00007fd79d20d7e4 XInitExtension (libX11.so.6 + 0x2a7e4)
                #2  0x00007fd79d164dcf XextAddDisplay (libXext.so.6 + 0xddcf)
                #3  0x00007fd79d1d86b7 n/a (libXrandr.so.2 + 0x26b7)
                #4  0x00007fd79d1d8d41 XRRQueryExtension (libXrandr.so.2 + 0x2d41)
                #5  0x000055e306cf0438 n/a (VBoxClient + 0x40438)
                #6  0x000055e306cee766 n/a (VBoxClient + 0x3e766)
                #7  0x00007fd79cf79023 __libc_start_main (libc.so.6 + 0x27023)
                #8  0x000055e306cee9fe n/a (VBoxClient + 0x3e9fe)

There seems to be no functionalities missing, and X runs fine. But the hard drive is filling up with core dumps so I need to fix it. I have now downgraded to 6.1.2, and that version runs fine.

Some context: at boot the user automatically logs in & X starts. This has been running for years already. What I tried to fix it: reinstalling libx11 and libxrandr, but this did not help. I also tried to change the way VBoxClient starts. It is the command VBoxClient-all that runs either from .xinitrc, or directly from the Fluxbox startup-file. But there is no difference there either.

Any ideas?

Last edited by anadyr (2020-04-12 05:54:43)

Offline

#2 2020-02-21 21:24:37

anadyr
Member
Registered: 2005-02-10
Posts: 225

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

I did some further troubleshooting with virtualbox-guest-modules version 6.1.4. In the Virtualbox VM settings I tried changing the display driver. Here's my findings:

- VBoxVGA: current setting. Works OK in 6.1.2 but segfaults in version 6.1.4.
- VBoxSVGA, 3d acceleration disabled: same as above. OK in 6.1.2, segfaults in 6.1.4
- VBoxSVGA, 3d acceleration enabled: black screen after autologin. Not useable.
- VMSVGA: autologin works fine, but resolution remains in 640*480 (very tiny screen).

The resolution is hardcoded set to 1920*1080 in xorg.conf settings, so I find this last finding very strange.

/etc/X11/xorg.conf.d/10-resolution.conf

Section "Screen"
    Identifier             "Screen0"  #Collapse Monitor and Device section to Screen section
    Device                 "Device0"
    Monitor                "Monitor0"
    DefaultDepth           24 #Choose the depth (16||24)
    SubSection             "Display"
        Depth              24
        Modes              "1920x1080" #Choose the resolution
    EndSubSection
EndSection

Last edited by anadyr (2020-02-21 21:38:59)

Offline

#3 2020-02-23 06:18:06

bhrgunatha
Member
Registered: 2009-12-16
Posts: 88

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

Something seems wrong with VBoxClient.
No segfaults here but I've lost shared clipboard functionality.
I run VBoxClient --clipboard from zsh's .zprofile and it just stops working after some random amount of time. Even if I ionvoke it from the command line and also with VBoxClient -b --clipboard. 

Since both guest and host are Arch I don't want to have to rollback the kernel to test 6.1.2 (which was working for me.)

Offline

#4 2020-02-23 19:28:38

pm3840
Member
Registered: 2013-12-16
Posts: 16

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

Same here the segment fault issue and at one time the systemd dump filled my hdd cause there were too many 256k(if I remember correctly) dump files like 10/min.

I've recently lost "shared clipboard" as well. The usual monthly 'pacman -Syu' becomes daily but situation remains the same.

The 'vmsvga' never works for me however I am surprised to find that it works in Debian(manual install guest addition of virtualbox included iso). I've checked 'dmesg' 'journalctl -r' '/var/log/Xorg.0.log' but find no clue there.

Edit:
Currently on vbox 6.1.4, guest 6.1.4 and vboxvga and there's no coredump. Dual screen works fine. Clipboard sharing is not working.
vbox 6.1.4, guest 6.1.4 and vmsvga, dual screens don't work, screen autosize doesn't work. Clipboard sharing is not working.

Last edited by pm3840 (2020-02-23 19:43:56)

Offline

#5 2020-02-23 22:45:08

gearhead
Member
Registered: 2018-03-24
Posts: 30

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

I cannot boot a 64 bit client. I have a image that I cannot boot and also cannot boot the current Feb 2020 Arch ISO. I get the image selection (Grub?)  page then it looks like it will boot then I get a seg fault. All I can see is:
RIP: 0010:_raw_spin_lock_0x1a/0x30 and some other stuff in the trace. It will launch a WinXP image (32 bit) but it launches really slow compared to my Intel Laptop here running Ubuntu or my Win10 at work.

This is an Asus AMD Ryzen Motherboard,(Prime X370-PRO), BIOS is 4011 4/19/2028 and is the latest version. 16Gb ram, Nvidia GTX960/PCi/SSE2 with Arch 64 bit running. Kernel is 5.4.20-1-lts . I do have the amd-ucode package installed.

I get this warning at boot but think it is nothing to worry about:
ACPI BIOS Warning (bug): Optional FADT field Pm2ControlBlock has valid Length but zero Address: 0x0000000000000000/0x1 (20190816/tbfadt-615).

I have no other functional issues that I am aware of, I just cannot boot any 64 bot vbox images or ISOs in vbox.

Offline

#6 2020-02-24 10:29:25

anadyr
Member
Registered: 2005-02-10
Posts: 225

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

I have also closely followed the wiki for setting the framebuffer resolution in Arch guests. But unfortunately no success there.

Unlike PM3840 I cannot get version 6.1.4 to run without segfaults with display driver vboxvga

Offline

#7 2020-02-25 20:53:17

anadyr
Member
Registered: 2005-02-10
Posts: 225

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

What I did now is to comment out the faulty line in the /usr/bin/VBoxClient-all script:

# /usr/bin/VBoxClient --vmsvga-x11  # In case VMSVGA emulation is enabled

The latest version 6.1.4 is now working OK with display drivers VBoxVGA and VBoxSVGA. However, I am somewhat hesitant to mark this thread as solved because this is not a real solution. A new version of the Virtualbox guest additions will undo this manual change again.

Offline

#8 2020-02-26 15:44:32

pm3840
Member
Registered: 2013-12-16
Posts: 16

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

Another kernel and guest-addition update but issues remain.
And I just realize that "--vmsvga-x11" instance causes coredump with VBoxVGA.
And I just want to report that With VMSVGA one xrandr process hangs in like [defunct] status.

Offline

#9 2020-02-27 02:07:58

SDR
Member
Registered: 2016-03-03
Posts: 5

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

Same issues here with the lost clipboard, dual screens and core dumps etc. with 6.1.4 (updated in host, guest and OVM VB Extension pack ).

Config:  all updated Arch(i3-wm) on Arch(kde) with NVIDIA card and drivers on the host (which were the prime suspect then).

Also since the end of Jan and kernel 5.5.2, the visual studio code in the VM started to have freezes and severe lags causing the host freezes as well.
The only way out was alt+ctl+f2 to kill the VM.

Offline

#10 2020-03-01 04:38:47

pm3840
Member
Registered: 2013-12-16
Posts: 16

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

Clipboard issue is related to guest-addition according to https://forums.virtualbox.org/viewtopic.php?f=3&t=96957. 6.1.2 guest works with even 6.1.4 host.

Offline

#11 2020-03-10 07:15:25

nl6720
Wiki Admin
Registered: 2016-07-02
Posts: 244

Re: [Solved] VBoxClient segfaults after upgrade to 6.1.4

virtualbox-guest-utils 6.1.4-3 fixed the clipboard issue. https://git.archlinux.org/svntogit/comm … a1789866b1

Offline

Board footer

Powered by FluxBB