You are not logged in.

#1 2020-02-26 22:01:59

fubarhouse
Member
Registered: 2020-02-26
Posts: 9

[REQUEST] pygmy-go

Hello! It's my first post here, but I'll do a more formal greeting elsewhere soon.

I would like to request my PKGBUILD files be added to AUR for a little app I wrote called pygmy.
The repository name is pygmy-go and it's a rewrite for pygmy.
- The one I am requesting: https://github.com/fubarhouse/pygmy-go

Unrelated fun fact, this application is a replacement for this one - which is not on AUR:
- https://github.com/amazeeio/pygmy

The files for building the application I am requesting can be found here under `pygmy/PKGBUILD` and `pygmy-git/PKGBUILD`:
- https://github.com/fubarhouse/pygmy-go.pkgbuild

I want to get some readmes done in the meantime, make it a bit nicer to browse on github.

Could somebody please advise me on how I can continue now that this one is submitted?
The wiki doesn't advise much between submission and the aur repository being created.

Offline

#2 2020-02-27 11:28:30

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,818

Re: [REQUEST] pygmy-go

All that's needed to get new things in the aur is to create the repository in aur , then push PKGBUILD and .SRCINFO (those 2 are mandatory afaik) plus other needed files to that aur repo.

I've looked at https://github.com/fubarhouse/pygmy-go. … y/PKGBUILD and it needs changes before it is submitted.

Two minor issues :

- remove lines with empty variables like options=()

- You list MIT as license, but don't install the license file.
https://wiki.archlinux.org/index.php/PKGBUILD#license for details.


One major issue

- your package() function uses sudo and puts stuff in folders makepkg / PKGBUILDs are not allowed to touch at all.
This indicates you don't understand yet how makepkg does things.

Read https://wiki.archlinux.org/index.php/Creating_packages and https://wiki.archlinux.org/index.php/Go … guidelines.

Welcome to the forum, you made a good first impresssion.

Last edited by Lone_Wolf (2020-02-27 11:29:37)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2020-02-27 11:32:41

fubarhouse
Member
Registered: 2020-02-26
Posts: 9

Re: [REQUEST] pygmy-go

Lone_Wolf,

Thanks for the feedback, I appreciate it! I'll have it fixed up asap. smile

Offline

#4 2020-02-27 22:06:04

fubarhouse
Member
Registered: 2020-02-26
Posts: 9

Re: [REQUEST] pygmy-go

Lone_Wolf,

Everything appears to be in order now...

Offline

#5 2020-02-27 22:57:59

loqs
Member
Registered: 2014-03-06
Posts: 10,072

Re: [REQUEST] pygmy-go

Checking pygmy-go-0.1.0-1-any.pkg.tar.zst
pygmy-go E: ELF file ('usr/bin/pygmy-go') found in an 'any' package.
pygmy-go W: ELF file ('usr/bin/pygmy-go') lacks FULL RELRO, check LDFLAGS.
pygmy-go W: ELF file ('usr/bin/pygmy-go') lacks PIE.
pygmy-go E: Dependency glibc detected and not included (libraries ['usr/lib/libpthread.so.0', 'usr/lib/libc.so.6'] needed in files ['usr/bin/pygmy-go'])

go produces arch specific binaries which in this instance is linked to a library provided by glibc.
You can fix the RELRO / PIE issue by changing the makedepends go to go-pie,  there are known issues where go-pie generates broken executables so may not be viable.

Offline

#6 2020-02-27 23:03:46

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,510
Website

Re: [REQUEST] pygmy-go

pygmy-git's PKGBUILD needs a pkgver function: https://wiki.archlinux.org/index.php/VC … )_function


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#7 2020-02-28 02:09:08

fubarhouse
Member
Registered: 2020-02-26
Posts: 9

Re: [REQUEST] pygmy-go

Interesting... I didn't come across that error in my testing loqs - but I have changed the dependency.

I've also added a pkgver function to the pygmy-git PKGBUILD file WorMzy - thanks for the wiki link. It was the first time I've seen that wiki entry.

Last edited by fubarhouse (2020-02-28 02:09:19)

Offline

#8 2020-02-28 04:15:24

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,139

Re: [REQUEST] pygmy-go

loqs wrote:
Checking pygmy-go-0.1.0-1-any.pkg.tar.zst
pygmy-go E: ELF file ('usr/bin/pygmy-go') found in an 'any' package.
pygmy-go W: ELF file ('usr/bin/pygmy-go') lacks FULL RELRO, check LDFLAGS.
pygmy-go W: ELF file ('usr/bin/pygmy-go') lacks PIE.
pygmy-go E: Dependency glibc detected and not included (libraries ['usr/lib/libpthread.so.0', 'usr/lib/libc.so.6'] needed in files ['usr/bin/pygmy-go'])

go produces arch specific binaries which in this instance is linked to a library provided by glibc.
You can fix the RELRO / PIE issue by changing the makedepends go to go-pie,  there are known issues where go-pie generates broken executables so may not be viable.

The vast majority of packages in archlinux "depend on" glibc's libc.so, but I hardly think it conveys useful information to make about 8,000 packages depend on "glibc". You cannot have a system, period, without some form of libc, and it's explicitly in the base metapackage.

namcap reports it as an error because namcap is very primitive, and doesn't have context awareness.


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#9 2020-02-29 14:24:29

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,818

Re: [REQUEST] pygmy-go

- arch=(any) is not applicable when ELF files are produced,  see https://wiki.archlinux.org/index.php/PKGBUILD#arch

- pkgver() runs before build() and is usually put higher in the PKGBUILD then build() function.
(this is purely cosmetic though)

- the git PKGBUILD should use pygmy-go-git as pkgname and conflict with pygmy-go to prevent clashes.
Usually -git versions also provide the non-git package.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#10 2020-03-01 10:57:51

fubarhouse
Member
Registered: 2020-02-26
Posts: 9

Re: [REQUEST] pygmy-go

Lone_Wolf,

All three concerns have been addressed smile

Last edited by fubarhouse (2020-03-01 10:58:14)

Offline

#11 2020-03-01 13:28:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,818

Re: [REQUEST] pygmy-go

Not entirely, you didn't add provides / conflicts .
check https://wiki.archlinux.org/index.php/VC … Guidelines

Reading those GuIdelines should also make you realise you're missing a makedepend.

One other thing thing

# Maintainer: Karl Hepworth <karl.hepworth@gmail.com>

You don't have to use your real name / email address ,  most aur maintainers use their aur username and email with which they registered.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#12 2020-03-02 04:19:59

fubarhouse
Member
Registered: 2020-02-26
Posts: 9

Re: [REQUEST] pygmy-go

Lone_Wolf,

I've had another look... I've updated the maintainer details and added the conflicts value - among other things.
I've also added some CI tests, a Dockerfile and a build script which has helped identify a couple of syntax errors I made.

Offline

#13 2020-03-02 13:24:19

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,818

Re: [REQUEST] pygmy-go

Seems I should be clearer about vcs / non-vcs packages and provides/conflicts .

Common policy on archlinux is to treat stable versions build from source as standard and make variants responsible for not causing issues with the standard.

In pygmy-go PKGBUILD you don't need/want any provides= or conflicts= .

For pygmy-go-git you definitely need a conflicts=(pygmy-go) .
Incase you want people to be able to switch between pygmo-go and pygmy-go-git without having to rebuild stuff, you should also add provides=(pygmy-go)

Last edited by Lone_Wolf (2020-03-02 13:24:47)


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#14 2020-03-03 10:06:20

fubarhouse
Member
Registered: 2020-02-26
Posts: 9

Re: [REQUEST] pygmy-go

I've made those adjustments.


* https://github.com/fubarhouse/pygmy-go. … 51ff38e8de
* https://github.com/fubarhouse/pygmy-go. … 25d27825cc

I wanted to thank you for your patience as this is my first one, and I've only just realized that this would have been better placed in the "creating and modifying packages" forum.

Even so, I've learnt more through this process so far than I set out to, so thank you again.

Offline

Board footer

Powered by FluxBB