You are not logged in.

#1 2020-03-02 19:16:53

dreamypunk
Member
Registered: 2020-03-02
Posts: 2

Grub tribulations

Grub tribulations
I am on a pc booting from a live environment on a USB . I am attempting to install arch on an nvme ssd. I am running an amd cpu. I have an ASUS rog impact VIII motherboard that’s UEFI operable.

I partition and format the drive using fdisk as a gpt table with the following attributes:

nvme0n1p1 512M EFI type

nvme0n1p2 930G ext 4

I then run the following commands:

mount /dev/nvme0n1p2 /mnt

mkdir /mnt/boot

mkdir /mnt/boot/EFI

mount /dev/nvme0n1p1 /mnt/boot/EFI

lsblk returns the correct mount points I pacstrap the system on /mnt with the following packages:

base base-devel linux linux-firmware vim

I generate the fstab

genfstab -U /mnt >> /mnt/etc/fstab

The file reflects the correct confoguration.

I leave the installer environment on the USB

arch-chroot /mnt

Set my zone info, locales, hostmame etc

Pacman -S grub efibootmgr

grub-install —target=x86_64-efi —efi-directory=/boot/EFI —boot loader-Id=GRUB

Could not prepare Boot variable: no such file or directory. grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

I tried googling. Nothing has yielded an understandable solution

Offline

#2 2020-03-02 20:11:14

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,209
Website

Re: Grub tribulations

dreamypunk wrote:
Could not prepare Boot variable: no such file or directory. grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

Looks like you're not booted in UEFI mode. Does /sys/firmware/efi exist?

Secure boot and CSM ("Legacy" mode) need to be disabled and UEFI mode should be enabled in the firmware ("BIOS") options for your motherboard.

If you are booted in UEFI mode then add the --removable option to the grub-install command.

Offline

Board footer

Powered by FluxBB