You are not logged in.

#1 2020-03-06 12:07:19

rsolva
Member
Registered: 2015-03-18
Posts: 19

Internal microphone unavaliable when headphoenes plugged in (E495)

Laptop: Lenovo ThinkPad E495
WM: i3

When I plug in any headphone, PulseAudio (pavucontrol) automatically switches to the Input Device to a non-existing headphone microphone, and the internal mic is listed as "unplugged". Manually switching back to the internal microphone reveals that there is no signal. The internal mic works fine before plugin in my headphones and after unplugging it again.

My initial thoughts is that PulseAudio assumes any headphone plugged in has a mic for some reason. What I don't get is why it "unplugs" the internal microphone (as if that even was possible). I have checked if the alsamixer could force another behavior, but nothing I have tried has worked.

Not sure how helpful it is, but here is the output of pactl info:

Server String: /run/user/1000/pulse/native
Library Protocol Version: 33
Server Protocol Version: 33
Is Local: yes
Client Index: 343
Tile Size: 65472
User Name: ****
Host Name: ****
Server Name: pulseaudio
Server Version: 13.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_05_00.6.analog-stereo
Default Source: alsa_input.pci-0000_05_00.6.analog-stereo

Offline

#2 2020-03-06 12:22:56

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,888

Re: Internal microphone unavaliable when headphoenes plugged in (E495)

Could be a HW limitation, is this a combo jack (combined headphone and mic?). Does this work on plain ALSA? Windows? If not you might have a chance to change the pin logic with hdajackretask.

FWIW pactl  info is pretty useless regardless

arecord -l
amixer -c$cardindex nr of relevant card from arecord$
pacmd list-cards
pacmd list-sources

would help more

Offline

#3 2020-03-06 15:12:43

rsolva
Member
Registered: 2015-03-18
Posts: 19

Re: Internal microphone unavaliable when headphoenes plugged in (E495)

I guess it is a combo-jack, as there is no dedicated jack for input, but I'm not sure. Outputs:

$ arecord -l
card 1: Generic_1 [HD-Audio Generic], device 0: CX8070 Analog [CX8070 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ amixer -c1
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 74
  Mono: Playback 50 [68%] [-24.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 74 [100%] [0.00dB] [on]
  Front Right: Playback 74 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 0 [0%] [-74.00dB] [off]
  Front Right: Playback 0 [0%] [-74.00dB] [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 253 [99%] [-0.40dB]
  Front Right: Playback 253 [99%] [-0.40dB]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Mic Mute-LED Mode',0
  Capabilities: enum
  Items: 'On' 'Off' 'Follow Capture' 'Follow Mute'
  Item0: 'Follow Mute'
Simple mixer control 'Beep',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 7
  Mono: Playback 3 [43%] [-16.00dB] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 80
  Front Left: Capture 75 [94%] [1.00dB] [on]
  Front Right: Capture 75 [94%] [1.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]

$ pacmd list-cards
2 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_05_00.1>
	driver: <module-alsa-card.c>
	owner module: 6
	properties:
		alsa.card = "0"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xd05c8000 irq 72"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:05:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:05:00.1/sound/card0"
		device.bus = "pci"
		device.vendor.id = "1002"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
		device.product.id = "15de"
		device.product.name = "Raven/Raven2/Fenghuang HDMI/DP Audio Controller"
		device.string = "0"
		device.description = "Raven/Raven2/Fenghuang HDMI/DP Audio Controller"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
		output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
		output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
		output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
		output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no)
		output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <off>
	ports:
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
    index: 1
	name: <alsa_card.pci-0000_05_00.6>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xd05c0000 irq 74"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:05:00.6"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:05:00.6/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.product.id = "15e3"
		device.product.name = "Family 17h (Models 10h-1fh) HD Audio Controller"
		device.string = "1"
		device.description = "Family 17h (Models 10h-1fh) HD Audio Controller"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Analog Stereo Input (priority 65, available: unknown)
		output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: unknown)
		off: Off (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_05_00.6.analog-stereo/#0: Family 17h (Models 10h-1fh) HD Audio Controller Analog Stereo
	sources:
		alsa_output.pci-0000_05_00.6.analog-stereo.monitor/#0: Monitor of Family 17h (Models 10h-1fh) HD Audio Controller Analog Stereo
		alsa_input.pci-0000_05_00.6.analog-stereo/#1: Family 17h (Models 10h-1fh) HD Audio Controller Analog Stereo
	ports:
		analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"

$ pacmd list-sources
2 source(s) available.
    index: 0
	name: <alsa_output.pci-0000_05_00.6.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY 
	state: IDLE
	suspend cause: (none)
	priority: 1030
	volume: front-left: 51104 /  78% / -6.48 dB,   front-right: 51104 /  78% / -6.48 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: yes
	current latency: 0.00 ms
	max rewind: 18 KiB
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	fixed latency: 100.00 ms
	monitor_of: 0
	card: 1 <alsa_card.pci-0000_05_00.6>
	module: 7
	properties:
		device.description = "Monitor of Family 17h (Models 10h-1fh) HD Audio Controller Analog Stereo"
		device.class = "monitor"
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xd05c0000 irq 74"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:05:00.6"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:05:00.6/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.product.id = "15e3"
		device.product.name = "Family 17h (Models 10h-1fh) HD Audio Controller"
		device.string = "1"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
  * index: 1
	name: <alsa_input.pci-0000_05_00.6.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
	state: SUSPENDED
	suspend cause: IDLE
	priority: 9039
	volume: front-left: 13588 /  21% / -41.00 dB,   front-right: 13588 /  21% / -41.00 dB
	        balance 0.00
	base volume: 13076 /  20% / -42.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 0
	fixed latency: 100.00 ms
	card: 1 <alsa_card.pci-0000_05_00.6>
	module: 7
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "CX8070 Analog"
		alsa.id = "CX8070 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "1"
		alsa.card_name = "HD-Audio Generic"
		alsa.long_card_name = "HD-Audio Generic at 0xd05c0000 irq 74"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:05:00.6"
		sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:05:00.6/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1022"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
		device.product.id = "15e3"
		device.product.name = "Family 17h (Models 10h-1fh) HD Audio Controller"
		device.string = "front:1"
		device.buffering.buffer_size = "19200"
		device.buffering.fragment_size = "3840"
		device.access_mode = "mmap"
		device.profile.name = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Family 17h (Models 10h-1fh) HD Audio Controller Analog Stereo"
		alsa.mixer_name = "Conexant CX8070"
		alsa.components = "HDA:14f11f86,17aa5124,00100100"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-input-microphone"
	active port: <analog-input-mic>

EDIT: The relevant part seems to be the following (output from when headphones are plugged in):

ports:
  analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: no)
    properties:
      device.icon_name = "audio-input-microphone"
  analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: yes)
    properties:
      device.icon_name = "audio-input-microphone"
  active port: <analog-input-mic>

Last edited by rsolva (2020-03-06 16:36:39)

Offline

#4 2020-04-01 10:12:53

shakedown1979
Member
Registered: 2020-04-01
Posts: 3

Re: Internal microphone unavaliable when headphoenes plugged in (E495)

V1del wrote:

If not you might have a chance to change the pin logic with hdajackretask.

I have the same problem on my Lenovo Thinkpad. I was able to use hdajackretast to work around the problem.

The workaround is to disable the external microphone. As root, open hdajackretask, select the Conexant codec, override "Black Mic, Right Side" (the non-internal mic) and set it to "Not connected".

Clicking "Apply now" did not work for me, but "Install boot override" did.

Cons: you'll forget you did this, then wonder why your external mic won't work. To re-enable it you need to use hdajackretask again, and reboot.

Last edited by shakedown1979 (2020-04-01 10:13:48)

Offline

Board footer

Powered by FluxBB