You are not logged in.

#1 2020-03-09 14:01:08

7596ff
Member
Registered: 2018-10-23
Posts: 7
Website

Timeout was reached while starting nautilus or evince

A recent sync updated some packages. When opening either `nautilus` or `evince`, startup time is very slow. I started `evince` with `G_MESSAGES_DEBUG=all`:

[cassie@houndoom ~]$ G_MESSAGES_DEBUG=all evince
(evince:4090): GLib-GIO-DEBUG: 09:57:38.196: _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ‘gio-vfs’
(evince:4090): GLib-DEBUG: 09:57:38.219: unsetenv() is not thread-safe and should not be used after threads are created
(evince:4090): Gtk-DEBUG: 09:57:38.219: Connecting to session manager
(evince:4090): Gtk-DEBUG: 09:57:38.220: Failed to get the GNOME session proxy: The name org.gnome.SessionManager is not owned
(evince:4090): Gtk-DEBUG: 09:57:38.220: Failed to get the Xfce session proxy: The name org.xfce.SessionManager is not owned
(evince:4090): Gtk-DEBUG: 09:58:03.236: Failed to get an inhibit portal proxy: Error calling StartServiceByName for org.freedesktop.portal.Desktop: Timeout was reached
(evince:4090): GLib-GIO-DEBUG: 09:58:03.309: _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
(evince:4090): dconf-DEBUG: 09:58:03.309: watch_fast: "/org/gnome/evince/" (establishing: 0, active: 0)
(evince:4090): dconf-DEBUG: 09:58:03.309: watch_established: "/org/gnome/evince/" (establishing: 1)
(evince:4090): dconf-DEBUG: 09:58:03.326: watch_fast: "/org/gnome/evince/default/" (establishing: 0, active: 0)
(evince:4090): dconf-DEBUG: 09:58:03.327: watch_established: "/org/gnome/evince/default/" (establishing: 1)
(evince:4090): dconf-DEBUG: 09:58:03.400: watch_fast: "/org/gnome/desktop/thumbnailers/" (establishing: 0, active: 0)
(evince:4090): dconf-DEBUG: 09:58:03.400: watch_established: "/org/gnome/desktop/thumbnailers/" (establishing: 1)

As you can see by the timestamps, this is the line that it hangs on:

(evince:4090): Gtk-DEBUG: 09:58:03.236: Failed to get an inhibit portal proxy: Error calling StartServiceByName for org.freedesktop.portal.Desktop: Timeout was reached

I am not smart enough to debug this on my own. Thank you for reading my post.

Offline

#2 2020-06-29 13:19:27

Wmog
Member
Registered: 2017-09-13
Posts: 10

Re: Timeout was reached while starting nautilus or evince

I have had exactly the same problem after having installed flatpak with its dependencies:

appstream-glib-0.7.17-1  gcab-1.4-1  gnome-keyring-1:3.36.0-1  libstemmer-0+713-2  ostree-2020.3-2  pipewire-0.3.6-1  sbc-1.4-2  xdg-dbus-proxy-0.1.2-2 xdg-desktop-portal-1.7.2-1  xdg-desktop-portal-gtk-1.7.1-1  flatpak-1.7.2-1

Here the logs of evince with G_MESSAGES_DEBUG=all evince:

(evince:10910): GLib-GIO-DEBUG: 14:42:05.256: _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ‘gio-vfs’
(evince:10910): GLib-DEBUG: 14:42:05.268: unsetenv() is not thread-safe and should not be used after threads are created
(evince:10910): Gtk-DEBUG: 14:42:05.268: Connecting to session manager
(evince:10910): Gtk-DEBUG: 14:42:05.268: Failed to get the GNOME session proxy: The name org.gnome.SessionManager is not owned
(evince:10910): Gtk-DEBUG: 14:42:05.268: Failed to get the Xfce session proxy: The name org.xfce.SessionManager is not owned
(evince:10910): Gtk-DEBUG: 14:42:05.269: Failed to get an inhibit portal proxy: The name org.freedesktop.portal.Desktop is not owned
(evince:10910): GLib-GIO-DEBUG: 14:42:05.298: _g_io_module_get_default: Found default implementation dconf (DConfSettingsBackend) for ‘gsettings-backend’
(evince:10910): dconf-DEBUG: 14:42:05.298: watch_fast: "/org/gnome/evince/" (establishing: 0, active: 0)
(evince:10910): dconf-DEBUG: 14:42:05.298: watch_established: "/org/gnome/evince/" (establishing: 1)
(evince:10910): dconf-DEBUG: 14:42:05.307: watch_fast: "/org/gnome/evince/default/" (establishing: 0, active: 0)
(evince:10910): dconf-DEBUG: 14:42:05.307: watch_established: "/org/gnome/evince/default/" (establishing: 1)
(evince:10910): dconf-DEBUG: 14:42:05.378: watch_fast: "/org/gnome/desktop/thumbnailers/" (establishing: 0, active: 0)
(evince:10910): dconf-DEBUG: 14:42:05.378: watch_established: "/org/gnome/desktop/thumbnailers/" (establishing: 1)
(evince:10910): dconf-DEBUG: 14:42:06.570: unwatch_fast: "/org/gnome/evince/" (active: 1, establishing: 0)
(evince:10910): dconf-DEBUG: 14:42:06.570: unwatch_fast: "/org/gnome/evince/default/" (active: 1, establishing: 0)
(evince:10910): dconf-DEBUG: 14:42:06.592: unwatch_fast: "/org/gnome/desktop/thumbnailers/" (active: 1, establishing: 0)
(evince:10910): dconf-DEBUG: 14:42:06.615: sync

I really would like to use flatpak and evince together on my system. Also, I use Awesome WM and GNOME is not installed on my system. How can I fix this problem please?

Thank you in advance.

Last edited by Wmog (2020-06-29 13:22:06)

Offline

#3 2020-06-29 14:53:27

seth
Member
Registered: 2012-09-03
Posts: 15,300

Re: Timeout was reached while starting nautilus or evince

Typical cause is a broken session (see the xinitrc link in my signature) but there's also https://bugs.archlinux.org/task/65748

What's the status of the portal services? Anything suspicious in coredumpctl?

Offline

Board footer

Powered by FluxBB