You are not logged in.

#1 2020-03-13 16:54:31

gray85
Member
Registered: 2010-11-27
Posts: 14

[SOLVED] Problems after upgrade to systemd 245

Have upgraded systemd from 244.3-1 to 245-3 and got problems after a reboot:
1. NetworkManager sees wifi networks but won't connect - "not authorized to control networking"
2. Can't do "systemctl reboot":

Failed to set wall message, ignoring: Interactive authentication required.
Failed to reboot system via logind: Interactive authentication required.
Failed to start reboot.target: Interactive authentication required.
See system logs and 'systemctl status reboot.target' for details.

3. Can't start Terminator (terminal emulator):

    bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NotSupported: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead

Downgrading back to 244.3-1 solves the problems.

I tried to google around and search the wiki - didn't helped.

Anyone else having these problem?

Last edited by gray85 (2020-03-18 09:04:23)

Offline

#2 2020-03-13 17:13:58

ratcheer
Member
Registered: 2011-10-09
Posts: 712

Re: [SOLVED] Problems after upgrade to systemd 245

It sounds like it might be related to the issue I'm having: https://bbs.archlinux.org/viewtopic.php … 3#p1891693

Offline

#3 2020-03-13 18:32:18

gray85
Member
Registered: 2010-11-27
Posts: 14

Re: [SOLVED] Problems after upgrade to systemd 245

ratcheer, thanks!

I have found a cause: I have a non standard username (useradd --badname) starting with number. There are no problems for standard usernames.

What should I do next? Or should I?

I mean I have a bug. Yes I have a non standard username, but I have a bug.

Last edited by gray85 (2020-03-13 19:00:44)

Offline

#4 2020-03-13 20:28:55

ratcheer
Member
Registered: 2011-10-09
Posts: 712

Re: [SOLVED] Problems after upgrade to systemd 245

IDK. I'm still looking for help with my issue, too.

Offline

#5 2020-03-13 21:58:54

loqs
Member
Registered: 2014-03-06
Posts: 10,046

Re: [SOLVED] Problems after upgrade to systemd 245

gray85 wrote:

I have found a cause: I have a non standard username (useradd --badname) starting with number. There are no problems for standard usernames.

What should I do next? Or should I?

I mean I have a bug. Yes I have a non standard username, but I have a bug.

Report the issue at https://github.com/systemd/systemd/issues
Edit:
See https://bugs.archlinux.org/task/65825

Please post the journal from a boot with the parameter systemd.log_level=debug after failing to login with a bad username.  This log will be very long so you will probably have to use a pastebin.

Last edited by loqs (2020-03-14 16:27:37)

Offline

#6 2020-03-18 09:03:56

gray85
Member
Registered: 2010-11-27
Posts: 14

Re: [SOLVED] Problems after upgrade to systemd 245

loqs, THANK YOU!

I'll wait for the systemd team to decide would they accept such usernames or not.

Last edited by gray85 (2020-03-18 09:04:53)

Offline

Board footer

Powered by FluxBB