You are not logged in.

#1 2020-03-15 07:15:44

tinhtruong
Member
From: Australia
Registered: 2008-12-18
Posts: 117

webkit2gtk-2.28.0-1-x86_64 was pernamently removed from the mirrors?

When I tried to upgrade my Arch box after 2 month or so not touching it, I've got some errors. Here is the full terminal output:

sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (163) adwaita-icon-theme-3.36.0-1  alsa-topology-conf-1.2.2-2  arduino-builder-1.5.2-2  at-spi2-atk-2.34.2-1  at-spi2-core-2.36.0-1  avahi-0.8+15+ge8a3dd0-1  blueman-2.1.2-1  ca-certificates-mozilla-3.51-1  ceph-14.2.8-1
               ceph-libs-14.2.8-1  chromium-80.0.3987.132-2  clutter-1.26.4-1  cogl-1.22.6-1  cryptsetup-2.3.1-1  cups-filters-1.27.2-1  curl-7.69.1-1  docker-1:19.03.7-1  electron-8.1.1-1  evince-3.36.0-1  evolution-3.36.0-1
               evolution-data-server-3.36.0-1  firefox-74.0-2  fish-3.1.0-2  folks-0.14-1  freetype2-2.10.1-2  fribidi-1.0.9-1  gcr-3.36-1  geoclue-2.5.6-1  geocode-glib-3.26.2-1  glib-networking-2.64.0-1  glib2-2.64.1-1
               glusterfs-1:7.3-1  gnome-bluetooth-3.34.1-1  gnome-calculator-3.36.0-1  gnome-desktop-1:3.36.0-1  gnome-keyring-1:3.36.0-1  gnome-online-accounts-3.36.0-1  gnome-screenshot-3.36.0-1  go-2:1.14-1
               gobject-introspection-runtime-1.64.0-1  gsettings-desktop-schemas-3.36.0-1  gthumb-3.9.1-1  gtksourceview4-4.6.0-1  guake-3.7.0-1  gvfs-1.44.0-1  hugo-0.67.0-1  iana-etc-20200311-1  icu-65.1-3  imagemagick-7.0.10.0-1
               kmod-27-1  libcap-2.33-1  libcryptui-3.12.2+55+ged3b12af-1  libcurl-compat-7.69.1-1  libdbusmenu-glib-16.04.0-4  libdbusmenu-gtk2-16.04.0-4  libdbusmenu-gtk3-16.04.0-4  libevdev-1.9.0-1  libgdata-0.17.12-1  libgee-0.20.3-2
               libglvnd-1.3.1-1  libgphoto2-2.5.24-1  libgweather-3.36.0-1  libinput-1.15.3-1  libkeybinder3-0.3.2-3  liblouis-3.13.0-1  libnm-1.22.10-1  libnma-1.8.28-1  libnotify-0.7.9-1  libp11-kit-0.23.20-3  libphonenumber-8.11.5-1
               libproxy-0.4.15+33+g454a499-1  libreoffice-fresh-6.4.1-3  librsvg-2:2.48.0-1  libseccomp-2.4.2-1  libsoup-2.70.0-1  libsynctex-2019.51075-7  libuv-1.35.0-1  libvirt-glib-3.0.0-1  libxcb-1.14-1  linux-5.5.8.arch1-1
               linux-firmware-20200224.efcfa03-1  linux-headers-5.5.8.arch1-1  logrotate-3.16.0-1  lua-5.3.5-3  lua52-5.2.4-5  man-db-2.9.1-1  meson-0.53.2-1  mkcert-1.4.1-3  mkinitcpio-27-3  network-manager-applet-1.16.0-1
               networkmanager-1.22.10-1  networkmanager-openvpn-1.8.12-1  nm-connection-editor-1.16.0-1  nodejs-13.11.0-1  nss-3.51-1  ntfs-3g-2017.3.23-4  osinfo-db-20200214-1  p11-kit-0.23.20-3  papirus-icon-theme-20200301-1
               pciutils-3.6.4-1  perl-alien-build-2.12-1  perl-alien-libxml2-0.14-1  perl-timedate-2.32-1  perl-xml-libxml-2.0203-1  phodav-2.4-1  poppler-0.86.1-1  poppler-glib-0.86.1-1  procps-ng-3.3.16-1  pygobject-devel-3.36.0-1
               python-3.8.2-1  python-attrs-19.3.0-4  python-click-7.1.1-1  python-cmd2-0.10.1-1  python-cryptography-2.8-2  python-decorator-4.4.2-1  python-gobject-3.36.0-1  python-importlib-metadata-1.5.0-1  python-packaging-20.3-1
               python-pycparser-2.20-1  python-pyrsistent-0.15.7-2  python-setuptools-1:45.3.0-1  python-urllib3-1.25.8-2  python-zipp-3.1.0-1  python2-attrs-19.3.0-4  python2-cheroot-8.3.0-1  python2-cryptography-2.8-2
               python2-dateutil-2.8.1-3  python2-gobject-3.36.0-1  python2-mako-1.1.2-1  python2-packaging-20.3-1  python2-pycparser-2.20-1  python2-urllib3-1.25.8-2  python2-werkzeug-1.0.0-2  qt5-base-5.14.1-3  qt5-webengine-5.14.1-2
               qt5-webkit-5.212.0alpha4-1  re2-1:20200303-1  runc-1.0.0rc10-2  sdl2-2.0.12-1  seahorse-1:3.36-1  shotwell-2:0.30.8-2  syncthing-1.3.4-2  systemd-245-3  systemd-libs-245-3  systemd-sysvcompat-245-3
               usbmuxd-1.1.0+69+g8a69f1a-1  vagrant-2.2.7-3  virtualbox-6.1.4-3  virtualbox-host-dkms-6.1.4-3  vte-common-0.60.0-1  vte3-0.60.0-1  wayland-protocols-1.20-1  webkit2gtk-2.28.0-1  wireshark-cli-3.2.2-1  wireshark-qt-3.2.2-1
               wpa_supplicant-2:2.9-7  xcb-proto-1.14-1  xfburn-0.6.2-1  xfce4-clipman-plugin-1.4.4-1  xfce4-power-manager-1.6.6-1  xfce4-whiskermenu-plugin-2.4.3-1  yarn-1.22.4-1  youtube-dl-2020.03.08-1

Total Download Size:     20.67 MiB
Total Installed Size:  4115.58 MiB
Net Upgrade Size:         2.93 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
error: failed retrieving file 'webkit2gtk-2.28.0-1-x86_64.pkg.tar.zst' from mirror.aarnet.edu.au : The requested URL returned error: 404
error: failed retrieving file 'webkit2gtk-2.28.0-1-x86_64.pkg.tar.zst' from archlinux.mirror.digitalpacific.com.au : The requested URL returned error: 404
error: failed retrieving file 'webkit2gtk-2.28.0-1-x86_64.pkg.tar.zst' from archlinux.mirror.digitalpacific.com.au : The requested URL returned error: 404
error: failed retrieving file 'webkit2gtk-2.28.0-1-x86_64.pkg.tar.zst' from ftp.iinet.net.au : The requested URL returned error: 404
error: failed retrieving file 'webkit2gtk-2.28.0-1-x86_64.pkg.tar.zst' from mirror.internode.on.net : The requested URL returned error: 404
error: failed retrieving file 'webkit2gtk-2.28.0-1-x86_64.pkg.tar.zst' from archlinux.melbourneitmirror.net : The requested URL returned error: 404
error: failed retrieving file 'webkit2gtk-2.28.0-1-x86_64.pkg.tar.zst' from syd.mirror.rackspace.com : The requested URL returned error: 404
error: failed retrieving file 'webkit2gtk-2.28.0-1-x86_64.pkg.tar.zst' from syd.mirror.rackspace.com : The requested URL returned error: 404
error: failed retrieving file 'webkit2gtk-2.28.0-1-x86_64.pkg.tar.zst' from ftp.swin.edu.au : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.

From my understanding, this package has been removed from those mirrors (and probably from other mirrors too).
So what are my options in this case?

Thanks in advance.
Cheers.

Offline

#2 2020-03-15 07:19:41

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,455
Website

Re: webkit2gtk-2.28.0-1-x86_64 was pernamently removed from the mirrors?

Find an up-to-date mirror:

┌─[Centurion ~]
└─╼ pkgsearch webkit2gtk
webkit2gtk 2.28.0-3 extra

Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2020-03-15 07:34:48

tinhtruong
Member
From: Australia
Registered: 2008-12-18
Posts: 117

Re: webkit2gtk-2.28.0-1-x86_64 was pernamently removed from the mirrors?

hi jasonwryan,

Thanks for your quick reply. After uncommenting all the mirrors in my mirrorlist file, it seems there's one mirror having the package.

Cheers.

Offline

#4 2020-03-15 17:03:00

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,134

Re: webkit2gtk-2.28.0-1-x86_64 was pernamently removed from the mirrors?

$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
[...]

Why is pacman reporting all databases are up to date, then failing with missing packages? Is your mirror broken?


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB