You are not logged in.

#1 2020-03-16 15:26:03

scippie
Member
Registered: 2019-06-07
Posts: 49

[SOLVED] grub-install; error: disk `md126,1` not found.

I am trying to reinstall my desktop pc. It had an old Arch installation but it was so messed up (and it probably even had corrupt disk data because of possible incorrect partition mappings with windows).
I decided to remove every other OS and just go for Arch as on my laptops.
Installing Arch has becoming easy for me (have done it lots of times now), so it should work fine, but this time, I am facing a problem and I can't figure it out.

Info: the system has an on board RAID sata hardware and I have always used it to put two 512GB SSD's (Samsung 840 PRO) in striped raid (raid0). This has always worked before, also on my Arch installation.
Next to it is a 1TB SSD (Samsung 860 PRO) outside of any raid volume.

I follow the installation steps from the wiki:
- The raid-volume is detected and mapped on /dev/md126
- I fdisk to it and make it a simple MBR system with only one partition (I don't need swap) starting at default and ending at default sectors
- I make the partition bootable, not sure if it is necessary
- I do the formatting to ext4, the mounting, the pacstrapping
- I install grub, intel-ucode and then I come to the step where I need to install grub:

# grub-install --target=i386-pc /dev/md126
Installing or i386-pc platform.
grub-install: error: disk `md126,1` not found.
and I can't continue my installation.

I found some info on raids that it might be necessary to just use grub-install on both of the physical disks in the raid (sda and sdb in my case) but that doesn't work either with the same error.

Help?

Edit: md126p1 does exist by the way. Where does this ',' come from anyway?

Last edited by scippie (2020-03-17 10:12:15)

Offline

#2 2020-03-17 10:12:02

scippie
Member
Registered: 2019-06-07
Posts: 49

Re: [SOLVED] grub-install; error: disk `md126,1` not found.

I found the problem. As a last resort, I took a Manjaro live usb and tried to install it.
It also gave errors and could not create partitions.
It seems that that was the problem with my previous installation all along. It had warned me about sector boundaries and things like that but I found places where they said that was ok.
It certainly explains all those odd problems I was having with that installation (which I didn't have on any other computer with Arch): network not starting, audio no longer playing, games starting sometimes and sometimes not, firefox changing color theme, ... the list goes on...
So, my RAID controller seems to be broken.
I disabled it in the BIOS, did an extensive test on all my SSD's and tried installing Manjaro again, and it worked perfectly.

Now I am going to read up on software RAID and LVM to set up a new clean Arch environment.

Last edited by scippie (2020-03-17 10:14:04)

Offline

Board footer

Powered by FluxBB