You are not logged in.

#1 2020-03-18 14:47:58

smoneck
Member
Registered: 2014-05-14
Posts: 83

Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

Hi,


since today my ThinkPad Thunderbolt 3 Dock (2. Gen.) stopped connecting to the Laptop in TB mode.
No obvious changes have been made.

> $ boltctl list 
○ Lenovo ThinkPad Thunderbolt 3 Dock
   ├─ type:          peripheral
   ├─ name:          ThinkPad Thunderbolt 3 Dock
   ├─ vendor:        Lenovo
   ├─ uuid:          00485118-dd2a-0801-ffff-ffffffffffff
   ├─ status:        disconnected
   ├─ authorized:    Mon 16 Mar 2020 06:45:54 PM UTC
   ├─ connected:     Mon 16 Mar 2020 06:45:54 PM UTC
   └─ stored:        Sun 05 Jan 2020 01:34:59 AM UTC
      ├─ policy:     auto
      └─ key:        yes

I have no idea what to look at. I just found:

Mar 18 15:41:08 hostname kernel: xhci_hcd 0000:3c:00.0: xHCI host controller not responding, assume dead
Mar 18 15:40:31 hostname kernel: typec_displayport port1-partner.0: failed to enter mode
Mar 18 15:40:31 hostname kernel: ucsi_acpi USBC000:00: con2: failed to register alternate modes

Any ideas? Thanks a lot!

---------------
P.s. Out of the blue, the 60 fps mode started working again on my 4k screen. That means TB must be working, right? boltctl still lists "disconnected".

Last edited by smoneck (2020-03-21 13:45:56)

Offline

#2 2020-03-18 15:22:20

nimdanitro
Member
Registered: 2020-03-18
Posts: 3

Re: Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

I had once a similar problem in the past with my X1 Carbon Gen 7 and a Thunderbolt 3 Dock. After figuring out that the same issue also exists with a USB Live System I concluded it had to be a HW problem.

A hardware hard reset by pressing the reset button hole on the bottom of the X1 solved the problem for me.

Offline

#3 2020-03-19 09:11:44

smoneck
Member
Registered: 2014-05-14
Posts: 83

Re: Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

nimdanitro wrote:

A hardware hard reset by pressing the reset button hole on the bottom of the X1 solved the problem for me.

Could you say what exactly did you do? There is basically zero information about the reset hole in the T480 manual. It just says "Remove the power cord and press the button." No change.

P.s. I'm asking this because at one place in the Hardware Maintenance Manual, they also want to have the coin-cell battery removed and I don't want to open the bottom.

Last edited by smoneck (2020-03-19 09:17:28)

Offline

#4 2020-03-19 13:08:41

nimdanitro
Member
Registered: 2020-03-18
Posts: 3

Re: Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

smoneck wrote:

Could you say what exactly did you do?

Well, it may be different depending on the hardware. On my X1 Carbon Gen 7, it was powering it off, removing power cord and pressing the button for 10 seconds. Then reattach power again.

Have you verified with a Live System that you are experiencing the same issues there?

Offline

#5 2020-03-19 14:09:11

smoneck
Member
Registered: 2014-05-14
Posts: 83

Re: Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

I have now tested the Manjaro KDE Live image and there it connected fine. Back to Arch, Disconnected again. 30 fps and 60 fps seem to go back and forth. Any idea what I can have a look at? hmm

Offline

#6 2020-03-19 16:14:46

nimdanitro
Member
Registered: 2020-03-18
Posts: 3

Re: Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

smoneck wrote:

Any idea what I can have a look at? hmm

How does the sysfs tree look under /sys/bus/thunderbolt/devices?
What Thunderbolt security settings do you have configured in the BIOS? Do you have IOMMU DMA protection enabled?

Have you tried to boltctl forget 00485118-dd2a-0801-ffff-ffffffffffff and enroll it again? What does boltctl domains -v show?

Offline

#7 2020-03-19 16:57:26

smoneck
Member
Registered: 2014-05-14
Posts: 83

Re: Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

Thank you for the reply! :-)

  • I don't have /sys/bus/thunderbolt

  • Thunderbolt Security is set to Secure Connect, although bolt lists Security Level: unknown

  • boltctl monitor does not recognize pulling and plugging the cable

  • boltctl power results in timeout

  • boltctl power -q: supported: yes, power state: wait

  • After boltctl forget [...] I couldn't use the Dock until reboot. After reboot, it worked again: 4k 60 fps (no full RGB), peripherals working. boltctl list now prints nothing.

  • IOMMU: VMM and VT-d are enabled

  • > boltctl domains -v
     ○ domain c8010000-0092-9088-20ba-ac0d2072a820
       ├─ online:   no
       ├─ bootacl:  0/16
       └─ security: unknown
          ├─ iommu: no
          └─ level: unknown

Last edited by smoneck (2020-03-19 17:08:51)

Offline

#8 2020-03-20 17:52:39

smoneck
Member
Registered: 2014-05-14
Posts: 83

Re: Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

Suddenly it works again ... -.-

Last edited by smoneck (2020-03-20 17:56:24)

Offline

#9 2020-03-21 13:47:25

smoneck
Member
Registered: 2014-05-14
Posts: 83

Re: Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

... but it looses all peripherals after sleep. The only way so far is reboot or pull the cable, plug it into the other usb-c port, pull and plug again into the thunderbolt port.

Any ideas? :'(

Last edited by smoneck (2020-03-21 13:47:45)

Offline

#10 2022-09-22 06:13:59

kevinkleine
Member
Registered: 2022-09-22
Posts: 1

Re: Lenovo ThinkPad Thunderbolt 3 Dock stopped connecting

Hardware reset worked for me without (further) problems.

Offline

Board footer

Powered by FluxBB