You are not logged in.

#1 2020-03-18 21:28:41

darose
Member
Registered: 2004-04-13
Posts: 144

Pulseaudio disabling auto-mute mode

I'm not sure how/why (or when it started) but pulseaudio is disabling auto-mute mode on my laptop.  Normally when you plug in headphones, speakers get muted.  However, every time PA starts up, it disables that auto-mute feature.  (I then have to go into alsamixer and manually re-enable it.)  Not a huge issue, but definitely a nuisance.

It's definitely PA that's responsible:  if I enable auto-mute, then do "pulseaudio --kill", the setting immediately gets disabled.  I've followed the instructions at https://wiki.archlinux.org/index.php/Pu … -Mute_Mode and https://wiki.archlinux.org/index.php/Ad … on_startup - i.e., change the setting to enabled, and then alsactl store.  However, that's obviously having no impact, since pulseaudio later *overrides* the alsa setting when it starts up.

Anyone else having similar issue?  Or have any idea what the issue is / how to fix?  (Or link to an open bug report?)

Offline

#2 2020-03-19 00:14:41

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,993

Re: Pulseaudio disabling auto-mute mode

You could try to remove/comment

load-module module-switch-on-port-available

in your /etc/pulse/default.pa that should stop pulse from reacting and changing the profile on a jack event. I have seldom seen that actively disable the auto-mute mode though so you might have some weird profile definitions, what's your outputs for

pacmd list-cards
pacmd list-sinks

?

Offline

#3 2020-03-19 14:58:41

darose
Member
Registered: 2004-04-13
Posts: 144

Re: Pulseaudio disabling auto-mute mode

$ pacmd list-cards
1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic>
	driver: <module-alsa-card.c>
	owner module: 6
	properties:
		alsa.card = "0"
		alsa.card_name = "sof-hda-dsp"
		alsa.long_card_name = "HP-HPEliteBookx3601030G4--8637"
		alsa.driver_name = "snd_soc_skl_hda_dsp"
		device.bus_path = "pci-0000:00:1f.3-platform-skl_hda_dsp_generic"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "9dc8"
		device.product.name = "Cannon Point-LP High Definition Audio Controller"
		device.string = "0"
		device.description = "Cannon Point-LP High Definition Audio Controller"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		HiFi: Play HiFi quality Music (priority 8000, available: no)
		off: Off (priority 0, available: unknown)
	active profile: <off>
	ports:
		[Out] HDMI3: HDMI3/DP3 Output (priority 700, latency offset 0 usec, available: no)
			properties:
				
		[Out] HDMI2: HDMI2/DP2 Output (priority 600, latency offset 0 usec, available: no)
			properties:
				
		[Out] HDMI1: HDMI1/DP1 Output (priority 500, latency offset 0 usec, available: no)
			properties:
				
		[Out] Speaker: Speaker (priority 100, latency offset 0 usec, available: unknown)
			properties:
				
		[Out] Headphones1: Headphones (priority 200, latency offset 0 usec, available: yes)
			properties:
				
		[In] Headphones2: Headphones Stereo Microphone (priority 200, latency offset 0 usec, available: no)
			properties:
				
		[In] Mic: Digital Microphone (priority 100, latency offset 0 usec, available: no)
			properties:
$ pacmd list-sinks
1 sink(s) available.
  * index: 1
	name: <alsa_output.hw_0_0>
	driver: <module-alsa-sink.c>
	flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9030
	volume: front-left: 5249 /   8% / -65.78 dB,   front-right: 5249 /   8% / -65.78 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 337.69 ms
	max request: 63 KiB
	max rewind: 63 KiB
	monitor source: 2
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	configured latency: 341.00 ms; range is 0.50 .. 341.00 ms
	module: 26
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = ""
		alsa.id = "HDA Analog (*)"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "sof-hda-dsp"
		alsa.long_card_name = "HP-HPEliteBookx3601030G4--8637"
		alsa.driver_name = "snd_soc_skl_hda_dsp"
		device.bus_path = "pci-0000:00:1f.3-platform-skl_hda_dsp_generic"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/skl_hda_dsp_generic/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "9dc8"
		device.product.name = "Cannon Point-LP High Definition Audio Controller"
		device.string = "hw:0,0"
		device.buffering.buffer_size = "65472"
		device.buffering.fragment_size = "16320"
		device.access_mode = "mmap+timer"
		device.description = "Cannon Point-LP High Definition Audio Controller"
		device.icon_name = "audio-card-pci"

Offline

#4 2020-03-20 01:45:17

darose
Member
Registered: 2004-04-13
Posts: 144

Re: Pulseaudio disabling auto-mute mode

BTW, doesn't look like removing "load-module module-switch-on-port-available" made any difference.

Offline

#5 2020-03-20 02:26:55

darose
Member
Registered: 2004-04-13
Posts: 144

Re: Pulseaudio disabling auto-mute mode

Hmmm, seems like removing "load-module module-udev-detect" prevents the disable-auto-mute behavior.  Not sure why ...

Offline

Board footer

Powered by FluxBB