You are not logged in.

#1 2020-03-19 16:28:01

Norxp256
Member
Registered: 2020-03-18
Posts: 4

Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

FULL DISCLAIMER: I am a colossal noob. I am only on arch linux because I'm willing to learn, not because I have any previous experience whatsoever.

My Issue:

Ever since I got my Dell XPS, the Killer Wifi card has been worthless, and only ever worked on Kernel 5.3. On all other kernels, nothing about it worked. Period. So, I boot into arch linux, the ISO on the live USB works fine, I can access internet, wifi-menu works, etc. etc. HOWEVER, once I finally got into the system, the wifi card would stop working and I'd be stuck with the same issue: no working wifi. Here is the output of ip link

 1: lo: <LOOPBACK, UP, LOWER_UP> mtu 65536 qdisc nonqueue state UNKNOWN mode DEFAULT group default qlen 1000
            link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 

wifi-menu only returns a faulty "Invalid interface specification"

Pinging archlinux.org returns "Temporary failure in name resolution."



I am curious if anyone can help me find a way to get my wifi-card working on the latest stable kernel, or if I am flat out of luck and this is just something I cannot fix, and must be left up to Killer Wifi.

Hardware:

Dell XPS 13 2-in-1 7390

KillerWifi AX1650

i7 1065G7

16G 3733MHZ RAM

477GB NvME SSD

1200p Touch Display

If you need any further outputs or info, just let me know.

Offline

#2 2020-03-19 16:45:23

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,993

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

Make sure linux-firmware is installed and if you're sure that it is post a

lspci-k
dmesg

of your system.

Last edited by V1del (2020-03-19 16:46:08)

Offline

#3 2020-03-19 17:13:37

Norxp256
Member
Registered: 2020-03-18
Posts: 4

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

lspci -k (only for network controller since I have to do all this manually):

 Network Controller: Intel Corporation Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter (201NGW) (rev30) 
           Subsystem: Bigfoot Networks, Inc. Killer Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter (201NGW)
           Kernel modules: iwlwifi 

dmesg: I couldn't repost dmesg because it is an incredibly long output, and I don't have a wired internet connection of any sort, unfortunately. I use a hotspot as I live in a rural part of America. However, I took a look through myself and found everything related to iwlwifi and network controllers:

https://imgur.com/a/2epLS7m

Linux-firmware does seem to be installed.

Last edited by Norxp256 (2020-03-19 17:16:48)

Offline

#4 2020-03-19 17:24:45

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,993

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

You do not appear have linux-firmware installed.

Also you can use the live disk chroot in and post the journal log from the real system which should include dmesg via https://wiki.archlinux.org/index.php/Li … in_clients

Which instructions did you follow to install Arch Linux?

And maybe throw in

pacman -Qkk linux-firmware

from the chroot if you are sure that it is.

Last edited by V1del (2020-03-19 17:26:11)

Offline

#5 2020-03-22 00:22:43

Norxp256
Member
Registered: 2020-03-18
Posts: 4

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

I went back around and executed -Qkk, you were right. It was not installed, went ahead and did that. wifi-menu works fine now; however, trying to connect to ANY wifi results in a simple, blunt "CONNECTION FAILED" error code, which is rather disappointing.

Here is the link to the dmesg output AFTER installing linux-firmware: http://ix.io/2eUv

Apologies for the late response.

Last edited by Norxp256 (2020-03-22 00:23:35)

Offline

#6 2020-03-24 14:01:21

GrandSeB
Member
Registered: 2020-03-20
Posts: 6

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

Greetings,

I am experiencing the same issue. So my later thread in this section may come as duplicate.

I have found out that there might have been a kernel regression:
https://bugzilla.kernel.org/show_bug.cgi?id=206479

wifi works fine with Arch ISO installation (kernel 5.5.6) but no more after (current kernel 5.5.9-arch1-2)

in your dmesg (as in mine), the issue is stated here:
[   10.195299] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-Qu-c0-hr-b0-52.ucode failed with error -2
[   10.195369] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-Qu-c0-hr-b0-51.ucode failed with error -2

I am not able to give you a workaround; My only hope at the moment is to see this bug taken care of and that we get a new kernel version supporting the WiFi again.

Best Regards,

Last edited by GrandSeB (2020-03-24 14:03:16)

Offline

#7 2020-03-24 15:20:58

Norxp256
Member
Registered: 2020-03-18
Posts: 4

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

I was hoping that wasn't the case, and I'd seen your message in the discussion section of the Dell XPS 13 7390. I really was hoping it wasn't a kernel regression, but honestly I knew it was deep down because this has happened before on several occasions.

Thank you for the second eye in the matter.

Last edited by Norxp256 (2020-03-24 15:21:43)

Offline

#8 2020-03-24 15:53:04

loqs
Member
Registered: 2014-03-06
Posts: 10,045

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

GrandSeB wrote:

Greetings,

I am experiencing the same issue. So my later thread in this section may come as duplicate.

I have found out that there might have been a kernel regression:
https://bugzilla.kernel.org/show_bug.cgi?id=206479

was fixed in linux 5.5.11.arch1-1 by https://git.archlinux.org/linux.git/com … 2210521c5f

[   10.195299] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-Qu-c0-hr-b0-52.ucode failed with error -2
[   10.195369] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-Qu-c0-hr-b0-51.ucode failed with error -2
....
[   10.540766] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version: 58.3.35.22
[   10.540769] iwlwifi 0000:00:14.3: Found debug destination: EXTERNAL_DRAM
[   10.540770] iwlwifi 0000:00:14.3: Found debug configuration: 0
[   10.540991] iwlwifi 0000:00:14.3: loaded firmware version 50.3e391d3e.0 op_mode iwlmvm

Shows firmware was loaded.  Looking at the rest of the output Norxp256 posted I can not see an obvious issue.  The NIC ascociated with the AP.
Did it then fail to obtain an IPV4 address?  This would not show in dmesg.

Offline

#9 2020-03-24 21:33:27

GrandSeB
Member
Registered: 2020-03-20
Posts: 6

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

I have upgraded to 5.5.11-arch1-1 and the issue remains for me

it's even worse than with 5.5.9, since Gnome doesn't offer Wifi configuration no more.

I have to go through terminal, the error remains the same.

Do we have to apply a patch of some sort?


Thank you for your reply

Offline

#10 2020-03-24 22:04:40

loqs
Member
Registered: 2014-03-06
Posts: 10,045

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

GrandSeB wrote:

I have upgraded to 5.5.11-arch1-1 and the issue remains for me

it's even worse than with 5.5.9, since Gnome doesn't offer Wifi configuration no more.

I have to go through terminal, the error remains the same.

The GUI interface was to NetworkManager?  What exactly are you doing from the terminal?

Direct firmware load for iwlwifi-Qu-c0-hr-b0-52.ucode failed with error -2
Direct firmware load for iwlwifi-Qu-c0-hr-b0-51.ucode failed with error -2

Is the above the error that remains the same?  Please post the journal for an affected boot.  If it is too big to fit in code tags see the tip box from pastebin.

Offline

#11 2020-03-25 06:36:24

GrandSeB
Member
Registered: 2020-03-20
Posts: 6

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

I am very sorry.

As you figured out of my reply, my issue was that NetworkManager service wasn't started/enabled.

It didn't work right away after service started, I had to reboot the system. It is now working fine.

The error in dmesg remains, though:

[seb@XPS13-7390 ~]$ dmesg -T | grep iwl
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: enabling device (0000 -> 0002)
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-Qu-c0-hr-b0-52.ucode failed with error -2
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-Qu-c0-hr-b0-51.ucode failed with error -2
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-Qu-c0-hr-b0-50.ucode failed with error -2
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: Direct firmware load for iwlwifi-Qu-c0-hr-b0-49.ucode failed with error -2
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: TLV_FW_FSEQ_VERSION: FSEQ Version: 43.2.23.17
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: Found debug destination: EXTERNAL_DRAM
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: Found debug configuration: 0
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: loaded firmware version 48.4fa0041f.0 op_mode iwlmvm
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: Detected Killer(R) Wi-Fi 6 AX1650i 160MHz Wireless Network Adapter (201NGW), REV=0x338
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: Allocated 0x00400000 bytes for firmware monitor.
[mer. mars 25 07:26:54 2020] iwlwifi 0000:00:14.3: base HW address: 98:af:65:1b:13:a9
[mer. mars 25 07:26:55 2020] iwlwifi 0000:00:14.3 wlp0s20f3: renamed from wlan0
[mer. mars 25 07:26:55 2020] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[mer. mars 25 07:26:55 2020] iwlwifi 0000:00:14.3: FW already configured (0) - re-configuring
[mer. mars 25 07:26:55 2020] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM
[mer. mars 25 07:26:55 2020] iwlwifi 0000:00:14.3: FW already configured (0) - re-configuring
[mer. mars 25 07:27:46 2020] iwlwifi 0000:00:14.3: Applying debug destination EXTERNAL_DRAM


[seb@XPS13-7390 ~]$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: wlp0s20f3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 98:af:65:1b:13:a9 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.8/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp0s20f3
       valid_lft 85927sec preferred_lft 85927sec
    inet6 fe80::2437:f889:c8e6:3f33/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

Last edited by GrandSeB (2020-03-25 06:37:09)

Offline

#12 2020-03-25 09:31:51

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,993

Re: Killer Wifi Compatibility Issues: Dell XPS 13 2-in-1 7390

Yes this "error" is expected. The kernel drivers contain loading support for newer firmware than what is publicly released (I'd assume internal testing by developers) nearly all drivers that load firmware are setup that way. It isn't an inherent problem if it eventually loads a firmware even if it isn't the "latest" version wise.

Offline

Board footer

Powered by FluxBB