You are not logged in.

#1 2020-03-19 19:22:04

nandhas
Member
Registered: 2020-03-19
Posts: 3

Failed to load module "canberra-gtk-module" when i try to open Spotify

I installed snap through spotify today. While snap seemed to be working fine. spotify will not open and I get the following error message. How can I solve this?

(process:5227): Gtk-WARNING **: 14:55:42.865: Locale not supported by C library.
    Using the fallback 'C' locale.
Gtk-Message: 14:55:42.868: Failed to load module "canberra-gtk-module"
Gtk-Message: 14:55:42.875: Failed to load module "canberra-gtk-module"
Trace/breakpoint trap (core dumped)

Offline

#2 2020-03-19 19:36:24

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,032

Re: Failed to load module "canberra-gtk-module" when i try to open Spotify

Locale C is likely the bigger problem here, what are your outputs for

locale 
locale -a
localectl

you might also want to post a core dump backtrace and in general please post outputs wrapped in [ code ] [ /code ] tags without the spaces.

Last edited by V1del (2020-03-19 19:38:18)

Online

#3 2020-03-19 20:03:16

nandhas
Member
Registered: 2020-03-19
Posts: 3

Re: Failed to load module "canberra-gtk-module" when i try to open Spotify

This is my output for locale

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
LANG=en_EG.UTF-8
LC_CTYPE="en_EG.UTF-8"
LC_NUMERIC="en_EG.UTF-8"
LC_TIME="en_EG.UTF-8"
LC_COLLATE="en_EG.UTF-8"
LC_MONETARY="en_EG.UTF-8"
LC_MESSAGES="en_EG.UTF-8"
LC_PAPER="en_EG.UTF-8"
LC_NAME="en_EG.UTF-8"
LC_ADDRESS="en_EG.UTF-8"
LC_TELEPHONE="en_EG.UTF-8"
LC_MEASUREMENT="en_EG.UTF-8"
LC_IDENTIFICATION="en_EG.UTF-8"
LC_ALL=

locale -a

locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory

localectl

System Locale: LANG=en_EG.UTF-8
       VC Keymap: n/a
      X11 Layout: n/a

This might be the problem indeed, how do I fix this?

Offline

#4 2020-03-19 20:15:52

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,032

Re: Failed to load module "canberra-gtk-module" when i try to open Spotify

You have to generate the actual locales for the languages you intend to use https://wiki.archlinux.org/index.php/Lo … ng_locales https://wiki.archlinux.org/index.php/Lo … tem_locale

You should also do yourself a favor and include en_US.UTF-8 in addition to whatever native locale you intend to use. Lots of programs require it in some form or at least as a fallback if anything. And seeing how little references for en_EG I find lots utilities will fallback to en_US

Last edited by V1del (2020-03-19 20:19:15)

Online

#5 2020-03-19 20:49:19

nandhas
Member
Registered: 2020-03-19
Posts: 3

Re: Failed to load module "canberra-gtk-module" when i try to open Spotify

I fixed the locale errors but the remaining errors remain

Gtk-Message: 14:55:42.868: Failed to load module "canberra-gtk-module"
Gtk-Message: 14:55:42.875: Failed to load module "canberra-gtk-module"
Trace/breakpoint trap (core dumped)

How do I find the dump now?

Offline

Board footer

Powered by FluxBB