You are not logged in.

#1 2020-03-23 18:10:41

korimitsu
Member
Registered: 2016-08-14
Posts: 21

[SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

Tested laptop is MSI GT73VR
Used dd to put archlinux-2020.03.01-x86_64.iso to my USB pendrive

Then I use F11 to select boot device -> choose the pendrive -> choose Arch Linux archiso x86_64 UEFI CD. With Secure Boot enabled doesn't boot, says something about policy.

Now two things happen, depending on BIOS settings:

1) This way boots to root shell with verbose output, looks like actually I can install Arch Linux:

  • Boot mode select: LEGACY

  • Fast Boot: Disabled

  • Secure Boot: Disabled

2) This way boots only to grub, then, after choosing first option, screen stays on with no debug and pendrive powers off:

  • Boot mode select: UEFI

  • Fast Boot: Disabled

  • Secure Boot: Disabled

i am required to install Arch as Legacy BIOS or can I install it as UEFI? I have installed Ubuntu and worked fine both ways.

Last edited by korimitsu (2020-03-24 11:13:53)

Offline

#2 2020-03-23 19:53:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,074

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

What's the graphics driver? If anything nvidia try adding nomodeset (and if that isn't sufficient add loglevel=7 to check whether you get output) to the kernel parameters . Also MSIs are notorious for broken UEFI implementations, you'll likely only be able to boot if you populate $esp/BOOT/BOOTx64.efi with whatever bootloader you choose.

Offline

#3 2020-03-23 20:21:40

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

The graphics driver is nvidia, although can be set to intel on the BIOS. You can choose either IGPU or DGPU (but doesn't have optimus, from operating system standpoint is like having one graphics card at a time). You need to reboot and enter BIOS to switch from one to another, or alternatively using the MSI-GT7x-VGA-SWITCH from github, or alternatively clicking the physical button while on Windows which uses the MSI SCM software, in any case rebooting is mandatory.

Anyhow with either nvidia or intel the results are the same.

Offline

#4 2020-03-23 20:51:20

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

Tried with nomodeset and loglevel=7 pressing the letter e to edit the command line and add those at the end. Same result. Pendrive blinks for a couple of seconds then powers off.

I wonder why by default it's not verbose? Hate Arch already.

Offline

#5 2020-03-23 22:59:03

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,074

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

No distribution defaults to that, and as said MSIs are somewhat notorious for all sorts of UEFI weirdness. Because this reads reminiscent of a similar issue try A) pressing buttons, B) unplugging and replugging the stick once you are on the black screen. Depending on which kernel was used you might also just run into an issue with the newer kernel.

Last edited by V1del (2020-03-23 23:00:15)

Offline

#6 2020-03-24 10:18:29

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

V1del wrote:

No distribution defaults to that, and as said MSIs are somewhat notorious for all sorts of UEFI weirdness. Because this reads reminiscent of a similar issue try A) pressing buttons, B) unplugging and replugging the stick once you are on the black screen. Depending on which kernel was used you might also just run into an issue with the newer kernel.

Ok what really happens is that all USB ports shut down. Tested having a second USB keyboard with backlight and shuts down alongside with the pendrive. Will try an older version of arch iso or Manjaro or Antergos and see what happens.

Offline

#7 2020-03-24 10:19:24

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

I wonder why there isn't more than one kernel to choose.

Offline

#8 2020-03-24 10:20:45

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

Also can't find older versions of arch on download site. What a nightmare.

Offline

#9 2020-03-24 10:35:32

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

Tested with archlinux-2020.01.01-x86_64.iso and now it boots perfectly fine with UEFI, no modeset required.

For those with same problem, older Arch linux releases can be found here: Older Arch Linux iso releases

Offline

#10 2020-03-24 10:49:26

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

Tested also with archlinux-2020.02.01-x86_64.iso and perfectly fine too, gets to root shell with no "errors". Maybe it's kernel 5.5.6 which is buggy, so it's advisable to stay on linux 5.4.6 or 5.4.15.

Last edited by korimitsu (2020-03-24 10:49:41)

Offline

#11 2020-03-24 10:52:53

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

Would like that Arch Linux Downloads page includes references to archived releases. How can I report the issue so they add the section?

Last edited by korimitsu (2020-03-24 10:53:25)

Offline

#12 2020-03-24 10:55:45

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,074

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

Well yes that's unfortunate and can happen (there once was a kernel that broke a specific keyboard vendor for example). There isn't much room for multiple kernels while still staying in CD size land (and by what metrics would you make the selection? ). You can install linux-lts on the actual system and if this is reproducible on a 5.5 kernel you might want to check/report relevant kernel bug reports.

If the issue is solved, please mark it as such by editing the title in your first post.

Offline

#13 2020-03-24 11:14:37

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

Saying "solved" is a big word until the "default" iso comes out without the problem, but at least there's a workaround. I'll stick to linux-lts unless I want bleeding edge features. Any way to report this bug?

Last edited by korimitsu (2020-03-24 11:47:29)

Offline

#14 2020-03-24 11:46:59

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

V1del wrote:

No distribution defaults to that

Gentoo does boot in verbose mode by default.

Last edited by korimitsu (2020-03-24 11:47:47)

Offline

#15 2020-03-24 14:49:54

korimitsu
Member
Registered: 2016-08-14
Posts: 21

Re: [SOLVED] archlinux-2020.03.01-x86_64.iso doesn't boot with UEFI

Offline

Board footer

Powered by FluxBB