You are not logged in.

#1 2020-03-24 19:42:50

f4rm0r
Member
Registered: 2011-08-23
Posts: 37

Suddenly no microphone [SOLVED]

Heya,

Today my sound suddenly disappeared when I restarted discord.
So I did a check and found that I should check with pavucontrol, apparently I have no recording devices at all in my system.
I have done several restarts and I found nothing.
I do not use alsa, I only have pulseaudio installed and running, unless you count "pulseaudio-alsa".

here is the pulseaudio config file, I have not touched it.

[arch@Archangelz ~]$ pulseaudio --dump-conf 
### Read from configuration file: /etc/pulse/daemon.conf ###
daemonize = no
fail = yes
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 5
allow-module-loading = yes
allow-exit = yes
use-pid-file = yes
system-instance = no
local-server-type = user
cpu-limit = no
enable-shm = yes
flat-volumes = no
lock-memory = no
exit-idle-time = 20
scache-idle-time = 20
dl-search-path = /usr/lib/pulse-13.0/modules
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = 
log-level = notice
resample-method = auto
avoid-resampling = no
enable-remixing = yes
remixing-use-all-sink-channels = yes
enable-lfe-remixing = no
lfe-crossover-freq = 0
default-sample-format = s16le
default-sample-rate = 44100
alternate-sample-rate = 48000
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 4
default-fragment-size-msec = 25
enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 8000
deferred-volume-extra-delay-usec = 0
shm-size-bytes = 0
log-meta = no
log-time = no
log-backtrace = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-rss = -1
rlimit-as = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 200000
[arch@Archangelz ~]$ 

I am using a Corsair wireless headset, have tried plugging out and in, turning it on/off, tried several USB-ports.... Only the headsets speaker shows and are usable, but the microphone in the headset wont show up.

just in case it is neccesary:

[arch@Archangelz ~]$ lsusb | grep 1b1c
Bus 003 Device 002: ID 1b1c:1b3e Corsair Corsair Gaming SCIMITAR PRO RGB Mouse
Bus 001 Device 002: ID 1b1c:0a14 Corsair Corsair VOID PRO Wireless Gaming Headset

I have tried doing a pacman -Syyu  (also yay -Syyu to update AUR) everything is updated and working perfectly, except the microphone in my headset.

I am not sure what logs you may need or where they reside, but if you specify it and the command to retrieve it, I will get it to you asap!

Thank you for taking your time with this!


UPDATE:
I am in a discord server with a friend, and it seems like they pick up on the sound from my computer, but not my microphone. I am not sure if this is relevant, but I will put it here in case it has relevance.
- in my travel in pavucontrol I accidentally activated loopback to my mic from headphones on headset.

Last edited by f4rm0r (2020-03-25 17:29:53)

Offline

#2 2020-03-25 09:14:41

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,993

Re: Suddenly no microphone [SOLVED]

Post

aplay -l
amixer -c$correct index number from aplay$
pacmd list-cards
pacmd list-sources
dmesg | grep snd

Offline

#3 2020-03-25 17:06:58

f4rm0r
Member
Registered: 2011-08-23
Posts: 37

Re: Suddenly no microphone [SOLVED]

Here are the logs as requested:

[arch@Archangelz ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Gamin [Corsair VOID PRO Wireless Gamin], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
[arch@Archangelz ~]$ amixer -c 2
Simple mixer control 'PCM',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 64
  Mono: Playback 45 [70%] [-19.00dB] [on]
Simple mixer control 'Headset',0
  Capabilities: cvolume cvolume-joined cswitch cswitch-joined
  Capture channels: Mono
  Limits: Capture 0 - 64
  Mono: Capture 64 [100%] [0.00dB] [on]
[arch@Archangelz ~]$ pacmd list-cards
3 card(s) available.
    index: 0
        name: <alsa_card.usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00>
        driver: <module-alsa-card.c>
        owner module: 6
        properties:
                alsa.card = "2"
                alsa.card_name = "Corsair VOID PRO Wireless Gamin"
                alsa.long_card_name = "Corsair Corsair VOID PRO Wireless Gamin at usb-0000:03:00.0-3, full speed"
                alsa.driver_name = "snd_usb_audio"
                device.bus_path = "pci-0000:03:00.0-usb-0:3:1.0"
                sysfs.path = "/devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-3/1-3:1.0/sound/card2"
                udev.id = "usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00"
                device.bus = "usb"
                device.vendor.id = "1b1c"
                device.vendor.name = "Corsair"
                device.product.id = "0a14"
                device.product.name = "Corsair VOID PRO Wireless Gaming Headset"
                device.serial = "Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset"
                device.form_factor = "headset"
                device.string = "2"
                device.description = "Corsair VOID PRO Wireless Gaming Headset"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-headset-usb"
                device.intended_roles = "phone"
        profiles:
                input:mono-fallback: Mono Input (priority 1, available: unknown)
                input:multichannel-input: Multichannel Input (priority 1, available: unknown)
                output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
                output:analog-stereo+input:mono-fallback: Analog Stereo Output + Mono Input (priority 6501, available: unknown)
                output:analog-stereo+input:multichannel-input: Analog Stereo Output + Multichannel Input (priority 6501, available: unknown)
                output:iec958-stereo: Digital Stereo (IEC958) Output (priority 5500, available: unknown)
                output:iec958-stereo+input:mono-fallback: Digital Stereo (IEC958) Output + Mono Input (priority 5501, available: unknown)
                output:iec958-stereo+input:multichannel-input: Digital Stereo (IEC958) Output + Multichannel Input (priority 5501, available: unknown)
                off: Off (priority 0, available: unknown)
        active profile: <output:analog-stereo>
        sinks:
                alsa_output.usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00.analog-stereo/#0: Corsair VOID PRO Wireless Gaming Headset Analog Stereo
        sources:
                alsa_output.usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00.analog-stereo.monitor/#0: Monitor of Corsair VOID PRO Wireless Gaming Headset Analog Stereo
        ports:
                analog-input-headset-mic: Headset Microphone (priority 8800, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-input-microphone"
                multichannel-input: Multichannel Input (priority 0, latency offset 0 usec, available: unknown)
                        properties:

                analog-output: Analog Output (priority 9900, latency offset 0 usec, available: unknown)
                        properties:

                iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
                        properties:

    index: 1
        name: <alsa_card.pci-0000_1f_00.1>
        driver: <module-alsa-card.c>
        owner module: 7
        properties:
                alsa.card = "0"
                alsa.card_name = "HDA ATI HDMI"
                alsa.long_card_name = "HDA ATI HDMI at 0xfd060000 irq 51"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:1f:00.1"
                sysfs.path = "/devices/pci0000:00/0000:00:03.1/0000:1f:00.1/sound/card0"
                device.bus = "pci"
                device.vendor.id = "1002"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
                device.product.id = "aaf0"
                device.product.name = "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
                device.string = "0"
                device.description = "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: no)
                output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 800, available: no)
                output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 800, available: no)
                output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
                output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
                output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
                output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
                output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no)
                output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available: no)
                output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
                output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5700, available: no)
                output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-stereo-extra5: Digital Stereo (HDMI 6) Output (priority 5700, available: unknown)
                off: Off (priority 0, available: unknown)
        active profile: <output:hdmi-stereo-extra5>
        sinks:
                alsa_output.pci-0000_1f_00.1.hdmi-stereo-extra5/#4: Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] Digital Stereo (HDMI 6)
        sources:
                alsa_output.pci-0000_1f_00.1.hdmi-stereo-extra5.monitor/#4: Monitor of Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] Digital Stereo (HDMI 6)
        ports:
                hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-5: HDMI / DisplayPort 6 (priority 5400, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "video-display"
                                device.product.name = "2590G5"
    index: 2
        name: <alsa_card.pci-0000_21_00.3>
        driver: <module-alsa-card.c>
        owner module: 8
        properties:
                alsa.card = "1"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xfcf00000 irq 53"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:21:00.3"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:21:00.3/sound/card1"
                device.bus = "pci"
                device.vendor.id = "1022"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
                device.product.id = "1457"
                device.product.name = "Family 17h (Models 00h-0fh) HD Audio Controller"
                device.string = "1"
                device.description = "Family 17h (Models 00h-0fh) HD Audio Controller"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                input:analog-stereo: Analog Stereo Input (priority 65, available: no)
                output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
                output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: no)
                output:analog-surround-21: Analog Surround 2.1 Output (priority 1300, available: unknown)
                output:analog-surround-21+input:analog-stereo: Analog Surround 2.1 Output + Analog Stereo Input (priority 1365, available: no)
                output:analog-surround-40: Analog Surround 4.0 Output (priority 1200, available: unknown)
                output:analog-surround-40+input:analog-stereo: Analog Surround 4.0 Output + Analog Stereo Input (priority 1265, available: no)
                output:analog-surround-41: Analog Surround 4.1 Output (priority 1300, available: unknown)
                output:analog-surround-41+input:analog-stereo: Analog Surround 4.1 Output + Analog Stereo Input (priority 1365, available: no)
                output:analog-surround-50: Analog Surround 5.0 Output (priority 1200, available: unknown)
                output:analog-surround-50+input:analog-stereo: Analog Surround 5.0 Output + Analog Stereo Input (priority 1265, available: no)
                output:analog-surround-51: Analog Surround 5.1 Output (priority 1300, available: unknown)
                output:analog-surround-51+input:analog-stereo: Analog Surround 5.1 Output + Analog Stereo Input (priority 1365, available: no)
                output:analog-surround-71: Analog Surround 7.1 Output (priority 1200, available: unknown)
                output:analog-surround-71+input:analog-stereo: Analog Surround 7.1 Output + Analog Stereo Input (priority 1265, available: no)
                off: Off (priority 0, available: unknown)
        active profile: <output:analog-stereo>
        sinks:
                alsa_output.pci-0000_21_00.3.analog-stereo/#2: Family 17h (Models 00h-0fh) HD Audio Controller Analog Stereo
        sources:
                alsa_output.pci-0000_21_00.3.analog-stereo.monitor/#2: Monitor of Family 17h (Models 00h-0fh) HD Audio Controller Analog Stereo
        ports:
                analog-input-front-mic: Front Microphone (priority 8500, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-input-rear-mic: Rear Microphone (priority 8200, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-input-linein: Line In (priority 8100, latency offset 0 usec, available: no)
                        properties:

                analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
                        properties:

                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-headphones"
[arch@Archangelz ~]$ pacmd list-sources
3 source(s) available.
  * index: 0
        name: <alsa_output.usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00.analog-stereo.monitor>
        driver: <module-alsa-card.c>
        flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: RUNNING
        suspend cause: (none)
        priority: 1040
        volume: front-left: 49797 /  76% / -7.16 dB,   front-right: 49797 /  76% / -7.16 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: yes
        current latency: 0.00 ms
        max rewind: 2 KiB
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 1
        linked by: 1
        configured latency: 30.00 ms; range is 16.00 .. 2000.00 ms
        monitor_of: 0
        card: 0 <alsa_card.usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00>
        module: 6
        properties:
                device.description = "Monitor of Corsair VOID PRO Wireless Gaming Headset Analog Stereo"
                device.class = "monitor"
                alsa.card = "2"
                alsa.card_name = "Corsair VOID PRO Wireless Gamin"
                alsa.long_card_name = "Corsair Corsair VOID PRO Wireless Gamin at usb-0000:03:00.0-3, full speed"
                alsa.driver_name = "snd_usb_audio"
                device.bus_path = "pci-0000:03:00.0-usb-0:3:1.0"
                sysfs.path = "/devices/pci0000:00/0000:00:01.3/0000:03:00.0/usb1/1-3/1-3:1.0/sound/card2"
                udev.id = "usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00"
                device.bus = "usb"
                device.vendor.id = "1b1c"
                device.vendor.name = "Corsair"
                device.product.id = "0a14"
                device.product.name = "Corsair VOID PRO Wireless Gaming Headset"
                device.serial = "Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset"
                device.form_factor = "headset"
                device.string = "2"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-headset-usb"
                device.intended_roles = "phone"
    index: 2
        name: <alsa_output.pci-0000_21_00.3.analog-stereo.monitor>
        driver: <module-alsa-card.c>
        flags: DECIBEL_VOLUME LATENCY 
        state: SUSPENDED
        suspend cause: IDLE
        priority: 1030
        volume: front-left: 62259 /  95% / -1.34 dB,   front-right: 62259 /  95% / -1.34 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max rewind: 0 KiB
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        fixed latency: 100.14 ms
        monitor_of: 2
        card: 2 <alsa_card.pci-0000_21_00.3>
        module: 8
        properties:
                device.description = "Monitor of Family 17h (Models 00h-0fh) HD Audio Controller Analog Stereo"
                device.class = "monitor"
                alsa.card = "1"
                alsa.card_name = "HD-Audio Generic"
                alsa.long_card_name = "HD-Audio Generic at 0xfcf00000 irq 53"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:21:00.3"
                sysfs.path = "/devices/pci0000:00/0000:00:08.1/0000:21:00.3/sound/card1"
                device.bus = "pci"
                device.vendor.id = "1022"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD]"
                device.product.id = "1457"
                device.product.name = "Family 17h (Models 00h-0fh) HD Audio Controller"
                device.string = "1"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
    index: 4
        name: <alsa_output.pci-0000_1f_00.1.hdmi-stereo-extra5.monitor>
        driver: <module-alsa-card.c>
        flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: IDLE
        priority: 1030
        volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max rewind: 0 KiB
        sample spec: s16le 2ch 44100Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 1999.82 ms
        monitor_of: 4
        card: 1 <alsa_card.pci-0000_1f_00.1>
        module: 7
        properties:
                device.description = "Monitor of Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] Digital Stereo (HDMI 6)"
                device.class = "monitor"
                alsa.card = "0"
                alsa.card_name = "HDA ATI HDMI"
                alsa.long_card_name = "HDA ATI HDMI at 0xfd060000 irq 51"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:1f:00.1"
                sysfs.path = "/devices/pci0000:00/0000:00:03.1/0000:1f:00.1/sound/card0"
                device.bus = "pci"
                device.vendor.id = "1002"
                device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
                device.product.id = "aaf0"
                device.product.name = "Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]"
                device.string = "0"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
[arch@Archangelz ~]$ dmesg | grep snd
[    7.627133] snd_hda_intel 0000:1f:00.1: Force to non-snoop mode
[    7.627331] snd_hda_intel 0000:21:00.3: enabling device (0000 -> 0002)
[    7.652986] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC892: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
[    7.652988] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    7.652989] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[    7.652991] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[    7.652991] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[    7.652992] snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
[    7.652993] snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
[    7.652995] snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
[    7.768786] usbcore: registered new interface driver snd-usb-audio
[    8.533308] snd_hda_intel 0000:1f:00.1: bound 0000:1f:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])

Offline

#4 2020-03-25 17:18:01

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,993

Re: Suddenly no microphone [SOLVED]

index: 0
        name: <alsa_card.usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00>
...
        profiles:
                input:mono-fallback: Mono Input (priority 1, available: unknown)
                input:multichannel-input: Multichannel Input (priority 1, available: unknown)
                output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
                output:analog-stereo+input:mono-fallback: Analog Stereo Output + Mono Input (priority 6501, available: unknown)
                output:analog-stereo+input:multichannel-input: Analog Stereo Output + Multichannel Input (priority 6501, available: unknown)
...
        active profile: <output:analog-stereo>
pacmd set-card-profile alsa_card.usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00  output:analog-stereo+input:multichannel-input

or take a closer look at the "Configuration" tab in pavucontrol. I assume you also accidentally toggled that during your travels (or rather that the act of doing so correctly registered the lack of a mic).

Last edited by V1del (2020-03-25 17:20:29)

Offline

#5 2020-03-25 17:29:08

f4rm0r
Member
Registered: 2011-08-23
Posts: 37

Re: Suddenly no microphone [SOLVED]

Thank you, it is now working, although it is a bit low, but I am going to check if I can raise it with amixer which I also installed yesterday.

I shall mark this thread as resolved.

thank you yet again for taking again! big_smile

V1del wrote:
index: 0
        name: <alsa_card.usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00>
...
        profiles:
                input:mono-fallback: Mono Input (priority 1, available: unknown)
                input:multichannel-input: Multichannel Input (priority 1, available: unknown)
                output:analog-stereo: Analog Stereo Output (priority 6500, available: unknown)
                output:analog-stereo+input:mono-fallback: Analog Stereo Output + Mono Input (priority 6501, available: unknown)
                output:analog-stereo+input:multichannel-input: Analog Stereo Output + Multichannel Input (priority 6501, available: unknown)
...
        active profile: <output:analog-stereo>
pacmd set-card-profile alsa_card.usb-Corsair_Corsair_VOID_PRO_Wireless_Gaming_Headset-00  output:analog-stereo+input:multichannel-input

or take a closer look at the "Configuration" tab in pavucontrol. I assume you also accidentally toggled that during your travels (or rather that the act of doing so correctly registered the lack of a mic).

Offline

#6 2020-03-25 18:07:08

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,993

Re: Suddenly no microphone [SOLVED]

you shouldn't mix mixers, up it in pavucontrol/pulseaudio to ensure it's consistent, maybe also switch over to the mono-fallback there might be some weird internal logic with the multi-channel input. I mostly request amixer for some further diagnosis and sometimes there are volume controls on the ALSA side that might be important, that aren't exposed by pulse, this doesn't seem to be the case here.

Last edited by V1del (2020-03-25 18:09:05)

Offline

Board footer

Powered by FluxBB