You are not logged in.

#1 2020-03-26 09:32:08

hardrock
Member
Registered: 2016-12-20
Posts: 7

Can't get audio to work properly

I have two shortcuts on my keyboard to lower and raise the volume. F8 runs "amixer -q sset 'Master' 4%+" while F7 runs "amixer -q sset 'Master' 4%+"


It worked fine until I have to reinstall my system a few days ago, and then, weird things started to happen.

The fist time I tried, it didn't work in a linear way anymore, it was exponential: when I pressed F8, if volume was around 10% it only raises it by say a 4%, but if it was at 60% it raises it to the top with a single keystroke.

The same command worked linearly on my last install so I really have no idea what is wrong with it.

Also, it never reaches 0% volume. The minimum it gets was around a 5% and I can't get it lower than that, no matter how many times I press the button.

Googleing I found the solution to the exponential problem, I just added -M to the command: "amixer -M -q sset 'Master' 4%+"  and now it works on a linear way (I still dont understand why it worked in a linear way without -M before, but whatever...)

But I still cannot get the volume to 0%, the lower I can get with it is somewhere around 5%

And today when I booted the system I got a new problem. That command doesn't work anymore, I just get an error: "amixer: Unable to find simple control 'Master',0" while yesterday it was working fine.

Offline

Board footer

Powered by FluxBB