You are not logged in.

#1 2020-03-29 13:31:54

Strangiato
Member
Registered: 2020-01-10
Posts: 60

Cannot access samba shares since update to samba 4.11.3-3

Hi

Since update to samba 4.11.3-3 I can't mount the samba shares from my desktop computer running Arch + KDE Plasma 5.18.3.
Client computer is a laptop also running Arch but with Gnome 3.36. Both systems are fully updated. Nautilus shows the following error message:

ubuntu-beta-smb-does-not-work.png

smb.conf file from server:

#======================= Global Settings =====================================
[global]
   workgroup = WORKGROUP
   server string = Servidor Samba do PC
   security = user
   map to guest = Bad User
   server role = standalone server
   log file = /var/log/samba/%m.log
   usershare path = /var/lib/samba/usershares
   usershare max shares = 100
   usershare allow guests = yes
   usershare owner only = yes

#============================ Share Definitions ==============================
[Home Arch-PC]
   comment = Home do Arch do PC
   path = /home/stalker
   public = yes
   writable = yes
   browseable = yes
   guest ok = yes
   force create mode = 770
   force directory mode = 770

[WD]
   comment = Western Digital
   path = /mnt/WD
   public = yes
   writable = yes
   browseable = yes
   guest ok = yes

[SEAGATE]
   comment = Seagate
   path = /mnt/SEAGATE
   public = yes
   browseable = yes
   writable = yes
   guest ok = yes

[WIN7]
   comment = WIN7
   path = /mnt/WIN7
   public = yes
   writable = yes
   browseable = yes
   writable = yes
   guest ok = yes

[2TB]
   comment = Seagate 2TB
   path = /mnt/2TB
   public = yes
   browseable = yes
   writable = yes
   guest ok = yes
   

output of "systemctl status smb"   

   systemctl status smb
● smb.service - Samba SMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2020-03-29 09:29:43 -03; 41min ago
       Docs: man:smbd(8)
             man:samba(7)
             man:smb.conf(5)
   Main PID: 551 (smbd)
     Status: "smbd: ready to serve connections..."
      Tasks: 4 (limit: 9412)
     Memory: 17.4M
     CGroup: /system.slice/smb.service
             ├─551 /usr/bin/smbd --foreground --no-process-group
             ├─553 /usr/bin/smbd --foreground --no-process-group
             ├─554 /usr/bin/smbd --foreground --no-process-group
             └─555 /usr/bin/smbd --foreground --no-process-group

mar 29 09:29:41 arch-laptop systemd[1]: Starting Samba SMB Daemon...
mar 29 09:29:43 arch-laptop systemd[1]: Started Samba SMB Daemon.
mar 29 09:29:43 arch-laptop smbd[551]: [2020/03/29 09:29:43.373840,  0] ../../lib/util/become_daemon.c:>
mar 29 09:29:43 arch-laptop smbd[551]:   daemon_ready: daemon 'smbd' finished starting up and ready to >

output of "systemctl status nmb"

systemctl status nmb
● nmb.service - Samba NMB Daemon
     Loaded: loaded (/usr/lib/systemd/system/nmb.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2020-03-29 09:29:41 -03; 42min ago
       Docs: man:nmbd(8)
             man:samba(7)
             man:smb.conf(5)
   Main PID: 526 (nmbd)
     Status: "nmbd: ready to serve connections..."
      Tasks: 1 (limit: 9412)
     Memory: 14.8M
     CGroup: /system.slice/nmb.service
             └─526 /usr/bin/nmbd --foreground --no-process-group

mar 29 09:29:41 arch-laptop nmbd[526]:   daemon_ready: daemon 'nmbd' finished starting up and ready to >
mar 29 09:34:54 arch-laptop nmbd[526]: [2020/03/29 09:34:54.051707,  0] ../../source3/nmbd/nmbd_nameque>
mar 29 09:34:54 arch-laptop nmbd[526]:   query_name_response: Multiple (2) responses received for a que>
mar 29 09:34:54 arch-laptop nmbd[526]:   This response was from IP 192.168.0.4, reporting an IP address>
mar 29 09:38:36 arch-laptop nmbd[526]: [2020/03/29 09:38:36.187500,  0] ../../source3/nmbd/nmbd_become_>
mar 29 09:38:36 arch-laptop nmbd[526]:   *****
mar 29 09:38:36 arch-laptop nmbd[526]: 
mar 29 09:38:36 arch-laptop nmbd[526]:   Samba name server ARCH-LAPTOP is now a local master browser fo>
mar 29 09:38:36 arch-laptop nmbd[526]: 
mar 29 09:38:36 arch-laptop nmbd[526]:   *****
lines 1-23/23 (END)

output of "smbclient -L arch-pc -U%"

smbclient -L arch-pc -U%
Unable to initialize messaging context

	Sharename       Type      Comment
	---------       ----      -------
	Home Arch-PC    Disk      Home do Arch do PC
	WD              Disk      Western Digital
	SEAGATE         Disk      Seagate
	WIN7            Disk      WIN7
	2TB             Disk      Seagate 2TB
	IPC$            IPC       IPC Service (Servidor Samba do PC)
SMB1 disabled -- no workgroup available

output of "smbfree -b -N"

smbtree -b -N
Unable to initialize messaging context

Any idea to solve this problem?

Last edited by Strangiato (2020-09-28 13:22:13)

Offline

#2 2020-03-29 15:18:26

atlas
Member
Registered: 2016-04-30
Posts: 3

Re: Cannot access samba shares since update to samba 4.11.3-3

I confirm this issue.

Offline

#3 2020-03-29 16:25:25

Andy_Vetrov
Member
Registered: 2019-02-09
Posts: 6

Re: Cannot access samba shares since update to samba 4.11.3-3

Same trouble. Rollback to previous version (samba 4.10.10-2, smbclient 4.10.10-2, libwbclient 4.10.10-2, ldb 1.5.6-2, tdb 1.3.18-4, tevent 0.9.39-4 from https://archive.archlinux.org ). Clients - Android/Arch Linux.

Offline

#4 2020-03-29 16:31:36

spsf64
Member
From: Brazil, SP
Registered: 2012-05-18
Posts: 85

Re: Cannot access samba shares since update to samba 4.11.3-3

I had similar problem and solved reading the wiki, as always, lol!
You probably have an old server like my case (old router with SMB1) with USB HD connected ...

https://wiki.archlinux.org/index.php/Sa … r_security

For compatibility with older clients and/or servers, you might need to set client min protocol = CORE or server min protocol = CORE, but please note that this makes you vulnerable to exploits in SMB1 including ransomware attacks.

Last edited by spsf64 (2020-03-29 16:33:20)


Sergio Schneider

Offline

#5 2020-03-29 16:33:39

fredbezies
Member
Registered: 2011-07-28
Posts: 342

Re: Cannot access samba shares since update to samba 4.11.3-3

There is a known bug opened back in november 2019: https://bugs.archlinux.org/task/64537

I think pushing this version to extra was a misbehaviour of Archlinux team. You have to downgrade these packages: samba libwbclient smbclient ldb

See this wiki page for more infos about packages downgrading until fixed versions are available. https://wiki.archlinux.org/index.php/Do … g_packages

Offline

#6 2020-03-29 16:37:31

stas-t
Member
Registered: 2019-05-21
Posts: 5

Re: Cannot access samba shares since update to samba 4.11.3-3

Just discovered that adding client min protocol = default to global section in smb.conf also fixes the issue for me. Is “default” vulnerable as well?

Offline

#7 2020-03-29 16:41:01

spsf64
Member
From: Brazil, SP
Registered: 2012-05-18
Posts: 85

Re: Cannot access samba shares since update to samba 4.11.3-3

stas-t wrote:

Just discovered that adding client min protocol = default to global section in smb.conf also fixes the issue for me. Is “default” vulnerable as well?

Well, good question...
Lets hope some samba expert jumps in and help us!

edit:
Weird; I could not find any reference to: client min protocol = default at this page:

https://www.samba.org/samba/docs/curren … onf.5.html

Last edited by spsf64 (2020-03-29 16:46:18)


Sergio Schneider

Offline

#8 2020-03-29 16:51:12

stas-t
Member
Registered: 2019-05-21
Posts: 5

Re: Cannot access samba shares since update to samba 4.11.3-3

I also couldn't find it in smb.conf manpage, however I've found it somewhere on forums and it worked even w/o any client max protocol specified.

UPD: I've tested against FRITZ!Box 7490 as Samba server b.t.w., it's fully updated (FRITZ!OS v.07.12).

UPD2: I believe I've seen “default” option here: https://superuser.com/questions/1279243 … b2-or-smb3

Last edited by stas-t (2020-03-29 17:16:14)

Offline

#9 2020-03-29 18:14:35

Strangiato
Member
Registered: 2020-01-10
Posts: 60

Re: Cannot access samba shares since update to samba 4.11.3-3

"client min protocol = default" did not solve the problem here.
Downgrade to samba 4.10.10-2, smbclient 4.10.10-2, libwbclient 4.10.10-2 and ldb 1.5.6-2 packages made samba to work again on my system.

Last edited by Strangiato (2020-03-29 18:14:59)

Offline

#10 2020-03-29 18:18:59

stas-t
Member
Registered: 2019-05-21
Posts: 5

Re: Cannot access samba shares since update to samba 4.11.3-3

Strangiato wrote:

"client min protocol = default" did not solve the problem here.
Downgrade to samba 4.10.10-2, smbclient 4.10.10-2, libwbclient 4.10.10-2 and ldb 1.5.6-2 packages made samba to work again on my system.

did you do this after changing your smb.conf?

killall gvfsd
nautilus -q

Offline

#11 2020-03-29 18:21:55

spsf64
Member
From: Brazil, SP
Registered: 2012-05-18
Posts: 85

Re: Cannot access samba shares since update to samba 4.11.3-3

Strangiato wrote:

"client min protocol = default" did not solve the problem here.
Downgrade to samba 4.10.10-2, smbclient 4.10.10-2, libwbclient 4.10.10-2 and ldb 1.5.6-2 packages made samba to work again on my system.

Did you try core under global as suggested in the wiki?:

[global]
client min protocol = CORE

Mine worked fine!

Last edited by spsf64 (2020-03-29 18:22:39)


Sergio Schneider

Offline

#12 2020-03-30 15:20:46

atlas
Member
Registered: 2016-04-30
Posts: 3

Re: Cannot access samba shares since update to samba 4.11.3-3

Even though network browsing is broken host name resolution itself is not.

You can still access the server machine by name but you have to do it explicitly in your file manager (test OK with Dolphin and PCManFM).

Example : smb://nameoftheservermachine/

Last edited by atlas (2020-03-30 15:21:38)

Offline

#13 2020-04-02 14:56:23

quiqueck
Member
Registered: 2013-04-15
Posts: 61

Re: Cannot access samba shares since update to samba 4.11.3-3

Had the same problem with running an old windows guest in qemu.

client min protocol = CORE

doesn't solved it for me, but downgrading the packages does.

Thanks for pointing this out :-)

Offline

#14 2020-04-10 19:03:20

browniesrgut
Member
Registered: 2014-10-28
Posts: 4

Re: Cannot access samba shares since update to samba 4.11.3-3

Hello all,

I had the same problem trying to access my samba shares (on a arch machine from another arch machine ; OK from a Windows PC).
Solved for me by adding this to the [global] section :

client min protocol = CORE
server min protocol = CORE

Thanks

Offline

#15 2020-04-17 15:38:54

h1pp13p373
Member
Registered: 2019-04-29
Posts: 9

Re: Cannot access samba shares since update to samba 4.11.3-3

Thanks browniesrgut!  For my Android clients, I had to add both server and client lines to my smb.conf as well.  Works well again.

Offline

#16 2020-04-25 10:32:51

kinleyd
Member
From: Bhutan
Registered: 2012-09-21
Posts: 142

Re: Cannot access samba shares since update to samba 4.11.3-3

Hmm, I waited for a while hoping updates would fix this. So I rolled back to samba 4.10.10-2, smbclient 4.10.10-2, libwbclient 4.10.10-2, ldb 1.5.6-2, tdb 1.3.18-4 and tevent 1:0.9.39-4 as suggested above.

I've changed nothing else, and smb and nmb services are up and running.

Yet I cannot access my Arch host from my Windows vm as I used to before. I'm getting a "network path not found" error.

Any help will be appreciated.

Edit:

I've also tried adding to smb.conf:
client min protocol = CORE
server min protocol = CORE
as well as:
client min protocol = default

Last edited by kinleyd (2020-04-25 12:23:08)

Offline

#17 2020-04-29 19:10:44

Strangiato
Member
Registered: 2020-01-10
Posts: 60

Re: Cannot access samba shares since update to samba 4.11.3-3

Today I have updated to samba 4.12.1-1 on both server and client machines and this problem persists.

Adding these lines
client min protocol = CORE
server min protocol = CORE
to smb.conf did not help.

client min protocol = default
also did not work.

However I can access my samba shares typing smb://server/shared_folder in the file managers.

Last edited by Strangiato (2020-04-29 19:11:32)

Offline

#18 2020-04-30 16:01:12

kinleyd
Member
From: Bhutan
Registered: 2012-09-21
Posts: 142

Re: Cannot access samba shares since update to samba 4.11.3-3

Strangiato wrote:

Today I have updated to samba 4.12.1-1 on both server and client machines and this problem persists.

Adding these lines
client min protocol = CORE
server min protocol = CORE
to smb.conf did not help.

client min protocol = default
also did not work.

However I can access my samba shares typing smb://server/shared_folder in the file managers.

I've had the same experience as you with samba 4.12.1-1. However, smb://server/shared_folder doesn't work for me.

What OS are you running on your guest? I'm running a WinXP guest and previously \\server\shared_folder used to work.

Offline

#19 2020-05-01 11:33:27

Strangiato
Member
Registered: 2020-01-10
Posts: 60

Re: Cannot access samba shares since update to samba 4.11.3-3

kinleyd wrote:
Strangiato wrote:

Today I have updated to samba 4.12.1-1 on both server and client machines and this problem persists.

Adding these lines
client min protocol = CORE
server min protocol = CORE
to smb.conf did not help.

client min protocol = default
also did not work.

However I can access my samba shares typing smb://server/shared_folder in the file managers.

I've had the same experience as you with samba 4.12.1-1. However, smb://server/shared_folder doesn't work for me.

What OS are you running on your guest? I'm running a WinXP guest and previously \\server\shared_folder used to work.

I use two computers:
desktop runs Arch + KDE Plasma
laptop runs Arch + Gnome
My laptop can access the shares from desktop after I add

client min protocol = CORE
server min protocol = CORE

OR

client min protocol = default

lines to its smb.conf file AND run the following commands:

killall gvfsd
nautilus -q

But the file managers installed on deskop computer (Dolphin, pcmanfm and nautilus) can not see the shares from laptop
even after I add the lines mentioned above to its smb.conf file and reboot.
I need to type smb://server/shared_folder as mentioned in my previous post.

Offline

#20 2020-05-02 08:22:40

kinleyd
Member
From: Bhutan
Registered: 2012-09-21
Posts: 142

Re: Cannot access samba shares since update to samba 4.11.3-3

Thanks, @Strangiato. It's a bummer, but I've tried everything without luck.

Offline

#21 2020-05-04 12:44:22

kinleyd
Member
From: Bhutan
Registered: 2012-09-21
Posts: 142

Re: Cannot access samba shares since update to samba 4.11.3-3

fredbezies wrote:

There is a known bug opened back in november 2019: https://bugs.archlinux.org/task/64537

I think pushing this version to extra was a misbehaviour of Archlinux team. You have to downgrade these packages: samba libwbclient smbclient ldb

See this wiki page for more infos about packages downgrading until fixed versions are available. https://wiki.archlinux.org/index.php/Do … g_packages

I'm inclined to agree. This was one heckuva mess up for me as I rely on my Windows VMs for some critical end-of-month work. We've gone past v. 4.12.2-3 and I don't see any sign of resolution. More so frustrating since rolling back hasn't worked for me.

Side note: I had recently wanted to try out timeshift for snapshot rollbacks for working with this kind of problem. Unfortunately I didn't set it up thoroughly and by the time I set out to restore a snapshot, the version I needed was no longer there. Ah!

Last edited by kinleyd (2020-05-04 12:45:39)

Offline

#22 2020-05-06 00:35:47

WFV
Member
From: ☭USSA⛧⭒⭒⭒⭒
Registered: 2013-04-23
Posts: 273

Re: Cannot access samba shares since update to samba 4.11.3-3

kinleyd wrote:
Side note: I had recently wanted to try out timeshift for snapshot rollbacks for working with this kind of problem. Unfortunately I didn't set it up thoroughly and by the time I set out to restore a snapshot, the version I needed was no longer there. Ah!

Might try the Archives if looking for 4.10 versions


"Wisdom is knowing I am Nothing." "Love is Knowing I am Everything." and in between the two, life moves.

Offline

#23 2020-05-06 09:24:44

kinleyd
Member
From: Bhutan
Registered: 2012-09-21
Posts: 142

Re: Cannot access samba shares since update to samba 4.11.3-3

Thanks for the reply @WFV. The problem for me isn't that I couldn't rollback the packages individually as I had the earlier versions in /var/cache/pacman/pkgs. The problem is that it wouldn't work despite rolling back. That's why I was trying a system snapshot rollback.

I'm now thinking of switching to a tap/tun configuration to get out of the samba mess once and for all. I'll do that when a bit of time opens up for me.

Offline

#24 2020-05-07 06:49:38

quiqueck
Member
Registered: 2013-04-15
Posts: 61

Re: Cannot access samba shares since update to samba 4.11.3-3

kinleyd wrote:

I'm inclined to agree. This was one heckuva mess up for me as I rely on my Windows VMs for some critical end-of-month work.

The same for me. I use qemu for running an old windows guest. The solution for qemu is: qemu does not use

/etc/samba/smb.conf

but uses his own smb.conf in a temporary folder

/tmp/qemu-smb.xxxxxxxx/smb.conf

The folder is created when starting qemu, and deleted again when the virtualization ends. The 'xxxxxxx' is always different.

If using qemu you have to add the values in the temporary smb.conf. Unfortunately i didn't found any qemu options to adjust his own smb.conf, so i wrote a small python script which starts the virtual machine, searches for the smb.conf in /tmp/ and adds the values.

Other machine emulators may have similar behavior.

Offline

#25 2020-05-07 07:10:51

kinleyd
Member
From: Bhutan
Registered: 2012-09-21
Posts: 142

Re: Cannot access samba shares since update to samba 4.11.3-3

Hi, thanks for the input. I've seen smb.conf in the tmp folder, but to my eye it looks alright. What values do you change to get it to work?

Yours in shared pain!

Offline

Board footer

Powered by FluxBB