You are not logged in.
After upgrading systemd (243.162-2 -> 245.4-2), the system can not hibernate, it shows Failed to hibernate system via logind: Not enough swap space for hibernation. However, I have a 20G swap file space while my memory is 16G.
And then I downgraded systemd, systemd-libs, and systemd-sysvcompat to 2.43.162-2. It can hibernate normally. And then I upgrade them and it shows the error again. Thanks in advance!
Last edited by BBBob (2020-04-08 17:20:47)
Offline
It may be that recent systemd is more stringent about swap ids.
What's the output of the following commands?
# cat /proc/cmdline
# findmnt --fstab -t swap--
saint_abroad
Offline
cat /proc/cmdline:
initrd=\intel-ucode.img initrd=\initramfs-linux.img root=PARTUUID=81f96f42-8512-497b-8719-2b398183e3cb rw button.lid_init_state=open i915.enable_rc6=0 i915.enable_psr=0 intel_idle.max_cstate=4 resume=/dev/nvme0n1p4 resume_offset=5486592findmnt --fstab -t swap:
TARGET SOURCE FSTYPE OPTIONS
none /home/xuzhenan/C/swapfile swap defaultsLast edited by BBBob (2020-04-08 11:40:00)
Offline
Solved here.
Thanks for the help!
Offline