You are not logged in.

#1 2020-04-07 15:08:12

MMime
Member
Registered: 2020-04-07
Posts: 2

[Solved] No sound after kernel update to 5.6.2 (sof-hda-dsp)

My configuration (Lenovo X1 Carbon gen 7) used to work before update to kernel 5.6.2 (following Wiki indications).

Now it is not working anymore, with or without Wiki changes.

Alsa still sees the card:

$ aplay -l

card 0: sofhdadsp [sof-hda-dsp], device 0: HDA Analog (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 1: HDA Digital (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 3: HDMI1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 4: HDMI2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofhdadsp [sof-hda-dsp], device 5: HDMI3 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

but cannot access it:

$ amixer
amixer: Mixer default load error: Invalid argument

(same thing for amixer -c0).


In turn, this cascades into multiple errors leading to pulseaudio crashing (I'm putting that for search engine discoverability):

$ sudo journalctl


Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] pid.c: Stale PID file, overwriting.
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-ucm.c: UCM file does not specify 'PlaybackChannels' or 'CaptureChannels'for device HDMI3, assu>
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-ucm.c: UCM file does not specify 'PlaybackChannels' or 'CaptureChannels'for device HDMI2, assu>
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-ucm.c: UCM file does not specify 'PlaybackChannels' or 'CaptureChannels'for device HDMI1, assu>
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-ucm.c: UCM file does not specify 'PlaybackChannels' or 'CaptureChannels'for device Headphones2>
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-ucm.c: UCM file does not specify 'PlaybackChannels' or 'CaptureChannels'for device Speaker, as>
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-ucm.c: UCM file does not specify 'PlaybackChannels' or 'CaptureChannels'for device Headphones1>
Apr 07 15:44:00 midgard MainThread[2449]: Failed to load module "canberra-gtk-module"
Apr 07 15:44:00 midgard MainThread[2449]: Failed to load module "canberra-gtk-module"
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-util.c: Unable to load mixer: Invalid argument
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-util.c: Unable to load mixer: Invalid argument
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-util.c: Unable to load mixer: Invalid argument
Apr 07 15:44:00 midgard pulseaudio[2395]: W: [pulseaudio] alsa-util.c: Unable to load mixer: Invalid argument
Apr 07 15:44:00 midgard kernel: skl_hda_dsp_generic skl_hda_dsp_generic: control 2:0:0:Dmic0 Capture Switch:0: value out of range 65536 (0/1) at count 0
Apr 07 15:44:00 midgard kernel: skl_hda_dsp_generic skl_hda_dsp_generic: control 2:0:0:Dmic0 Capture Switch:0: access overflow
Apr 07 15:44:00 midgard kernel: skl_hda_dsp_generic skl_hda_dsp_generic: control 2:0:0:Dmic0 Capture Switch:0: value out of range 65536 (0/1) at count 0
Apr 07 15:44:00 midgard kernel: skl_hda_dsp_generic skl_hda_dsp_generic: control 2:0:0:Dmic0 Capture Switch:0: access overflow
Apr 07 15:44:00 midgard kernel: skl_hda_dsp_generic skl_hda_dsp_generic: control 2:0:0:Dmic0 Capture Switch:0: value out of range 65536 (0/1) at count 0
Apr 07 15:44:00 midgard kernel: skl_hda_dsp_generic skl_hda_dsp_generic: control 2:0:0:Dmic0 Capture Switch:0: access overflow
Apr 07 15:44:00 midgard kernel: skl_hda_dsp_generic skl_hda_dsp_generic: control 2:0:0:Dmic0 Capture Switch:0: value out of range 65536 (0/1) at count 0
Apr 07 15:44:00 midgard kernel: skl_hda_dsp_generic skl_hda_dsp_generic: control 2:0:0:Dmic0 Capture Switch:0: access overflow
Apr 07 15:44:00 midgard kernel: pulseaudio[2395]: segfault at 8 ip 00007f12991a18fc sp 00007ffc98c9bf40 error 4 in libasound.so.2.0.0[7f129918b000+79000]
Apr 07 15:44:00 midgard kernel: Code: 48 39 3f 0f 94 c0 c3 0f 1f 80 00 00 00 00 55 48 89 f5 53 48 89 fb bf 18 00 00 00 48 83 ec 08 ff 15 21 5d 09 00 48 85 c0>

I want to stress again that the same configuration was working well in the previous kernel: I even downgraded it to test and sound is working again. I tried to activate testing repos, to no avail.

Does anybody have an idea? Could it be a mismatch between the kernel and alsa versions?


Edit: Update to 5.6.3 solved the issues. Even better, it looks like the workarounds from the wiki became unnecessary.

Last edited by MMime (2020-04-08 13:08:36)

Offline

#2 2020-04-07 16:20:36

tomaszc
Member
Registered: 2010-09-11
Posts: 19

Re: [Solved] No sound after kernel update to 5.6.2 (sof-hda-dsp)

It is similar with me, but it is sound but quiet, alsamixer not working.
I recompiled alsa-lib, alsa-plugins and alsa-utils, but it didn't help.
Someone has already reported a bug:
https://bugs.archlinux.org/task/66148

Last edited by tomaszc (2020-04-07 16:21:13)

Offline

Board footer

Powered by FluxBB