You are not logged in.

#1 2020-04-10 16:30:29

dlesnoff
Member
Registered: 2020-03-26
Posts: 7

[Solved] Zed! Free - dependency issue, debian package conversion

Hi everyone,

For my job, I have to install the Zed! Free software on my personal machine (x86-64). The website http://zedle.primx.eu/ only provides debian packages (32 and 64 bits).

So I have tried to use the debtap script to convert it (with success !). It asked me to specify the license, I could not find one corresponding to the software Zed. Here are the dependencies listed by trizen -Qi zedle :
dbus gcc-libs glib2 glibc libldap libxml2

I installed it then with pacman -U. The program zedle immediately fails and prompt :
zedle: error while loading shared libraries: libQtCore.so.4: cannot open shared object file: No such file or directory.

Here is the link to the file in Debian database for amd64 :
https://packages.debian.org/fr/buster/libqtcore4

I have tried to search the file with : trizen -F libqtcore

For the conversion, need I to install each dependency via converting deb packages ? Should I use dpkg instead ?

There is already a zed package in the AUR but this is an editor and is not what I seek.

Thank you for your attention.

Last edited by dlesnoff (2020-04-10 20:42:11)

Offline

#2 2020-04-10 16:49:19

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,934

Re: [Solved] Zed! Free - dependency issue, debian package conversion

Have you tried installing qt4 from the AUR?


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#3 2020-04-10 20:41:35

dlesnoff
Member
Registered: 2020-03-26
Posts: 7

Re: [Solved] Zed! Free - dependency issue, debian package conversion

qt4 (very long) installation fixed the problem. I am trying to change the PKGBUILD to add the dependency and I will add zed! to AUR.

Offline

#4 2020-04-11 00:01:25

yochananmarqos
Member
Registered: 2020-02-05
Posts: 18
Website

Re: [Solved] Zed! Free - dependency issue, debian package conversion

I was bored and came up with a PKGBUILD. I didn't bother adding the 32-bit file in there. I couldn't find the direct download URL, so you'll have to place the .deb in the same directory as the PKBUILD.

pkgname=zedle
pkgver=2.0.199
pkgrel=1
pkgdesc="A graphical interface to create, read and modify encrypted Zed! containers."
arch=('x86_64')
url="https://www.primx.eu"
license=('custom')
depends=('qt4' 'icu') # Needs older version of icu, not sure which version
source=("$pkgname-$pkgver.Ubuntu14.04.amd64.deb"
        'https://client.primx.eu/Legal/Terms.html')
sha256sums=('f20da22b246b459fad84d70429ca312270849a22f028a58ba10736226ecb0596'
            '26339931fb1040d2c93cd62b6f76991a87150295bb0db2b70a01b0afe3404b4f')

package() {
	tar -xvf data.tar.xz -C "$pkgdir"

	# Change directory permissions from 775 to 755
	chmod 755 -R "$pkgdir/usr"

	install -dm1777 "$pkgdir/etc/primx/accessfiles"
	install -dm1777 "$pkgdir/var/log/zed"

	touch "$pkgdir/etc/primx/users.registry"
	chmod 666 "$pkgdir/etc/primx/users.registry"

	install -Dm644 "$srcdir/Terms.html" -t "$pkgdir/usr/share/licenses/zed"
}

Qt4 should cover almost all the dependencies. It also relies on an older version of icu, but I'm not sure which version. I tried icu52 from the AUR, but still received the same error:

zedle: /usr/lib/liblber-2.4.so.2: no version information available (required by zedle)
zedle: /usr/lib/libldap_r-2.4.so.2: no version information available (required by zedle)
Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such file or directory)" 
libpng warning: iCCP: known incorrect sRGB profile
/etc/primx/users.registry:1: parser error : Document is empty

Last edited by yochananmarqos (2020-04-11 00:04:14)

Offline

Board footer

Powered by FluxBB