You are not logged in.

#1 2020-04-27 09:41:26

damnbug
Member
Registered: 2012-09-18
Posts: 51

[SOLVED] Broken UI in qBittorrent (issue related to DPI)

Problems with the UI started with version 4.2.4, and now, with 4.2.5, the UI is almost unusable. I can't even change settings.

https://i.ibb.co/Rjs552p/qbitUI.png

Is there a way to fix this?

Edit: The solution is to either run "QT_AUTO_SCREEN_SCALE_FACTOR=0 qbittorrent" or to add "QT_AUTO_SCREEN_SCALE_FACTOR=0" to ~/.pam_environment and then relogin.

Last edited by damnbug (2020-04-27 13:50:58)

Offline

#2 2020-04-27 10:45:18

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 725

Re: [SOLVED] Broken UI in qBittorrent (issue related to DPI)

Tried changing Qt widget theme?

Just for refference, this is qBittorent with Breeze widget style https://ibb.co/jMYps8Q

Last edited by Xabre (2020-04-27 10:55:44)

Offline

#3 2020-04-27 13:29:39

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 3,620

Re: [SOLVED] Broken UI in qBittorrent (issue related to DPI)

Upstream: https://github.com/qbittorrent/qBittorrent/issues/12441

But I don't think 4.2.4 -> 4.2.5 should have made it worse...

...

Note: it only affects some setups, you'd need a fractional DPI in the first place. I don't have one, and I don't see this bug either.

If upstream releases a fix for this, I'd be delighted to package it for you.

Last edited by eschwartz (2020-04-27 13:30:26)


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#4 2020-04-27 13:40:40

damnbug
Member
Registered: 2012-09-18
Posts: 51

Re: [SOLVED] Broken UI in qBittorrent (issue related to DPI)

eschwartz wrote:

Upstream: https://github.com/qbittorrent/qBittorrent/issues/12441

But I don't think 4.2.4 -> 4.2.5 should have made it worse...

...

Note: it only affects some setups, you'd need a fractional DPI in the first place. I don't have one, and I don't see this bug either.

If upstream releases a fix for this, I'd be delighted to package it for you.

Yes, it's related to DPI (I'm using 92; with 96, there's no issue).

Running "QT_AUTO_SCREEN_SCALE_FACTOR=0 qbittorrent" solves the issue. Thanks for the tip!

I've added "QT_AUTO_SCREEN_SCALE_FACTOR=0" to ~/.pam_environment.

Last edited by damnbug (2020-04-27 13:51:55)

Offline

Board footer

Powered by FluxBB