You are not logged in.

#1 2020-05-03 09:24:20

Clorden
Member
From: Cork, Ireland
Registered: 2016-04-13
Posts: 8

freerdp - patch to disable AAC by default

Hello,
A couple of weeks ago I submitted this bug report for freerdp, upstream:

https://github.com/FreeRDP/FreeRDP/issues/6072

They fixed it with this patch:

https://github.com/akallabeth/FreeRDP/c … d47cb9c0fe

Basically it deactivates AAC support by default to avoid related xfreerdp crashes.

Here is the diff:

--- a/libfreerdp/codec/dsp_ffmpeg.c     2020-04-09 17:00:51.000000000 +0100
+++ b/libfreerdp/codec/dsp_ffmpeg.c     2020-05-03 07:26:24.126571211 +0100
@@ -79,6 +79,14 @@
                case AV_CODEC_ID_NONE:
                        return TRUE;

+               case AV_CODEC_ID_AAC:
+               case AV_CODEC_ID_AAC_LATM:
+#if !defined(WITH_DSP_EXPERIMENTAL)
+                       if (encoder)
+                               return TRUE;
+#endif
+                       return FALSE;
+
                default:
                        return FALSE;
        }

I am not sure this is the right place to submit it and ask for it to be included in the arch freerdp package...

In any case I compiled it and the issue appears to be solved.

Thanks!
Clorden

Offline

#2 2020-05-03 10:45:30

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,717

Re: freerdp - patch to disable AAC by default

Open up a bug report/feature request for the patch to be included in the Arch bug tracker: bugs.archlinux.org (resp. go to the package page for freerdp and use the new bug report link to have some of the preliminary metadata filled out already)

It's not guaranteed the packagers will read this here.

Offline

#3 2020-05-03 19:46:39

Clorden
Member
From: Cork, Ireland
Registered: 2016-04-13
Posts: 8

Re: freerdp - patch to disable AAC by default

Thanks V1del!
I just opened a bug report as suggested.

Offline

Board footer

Powered by FluxBB