You are not logged in.

#1 2020-05-04 11:36:22

marko154
Member
Registered: 2013-08-13
Posts: 6

[SOLVED] Pacman-init.service error when booting live ISO

When booting live ISO (2020.05.01) through USB key I get the following error:

Failed to start Initializes Pacman keyring
See 'systemctl status pacman-init.service' for details.

Unfortunately, the system doesn't auto-login. After start jobs are completed, I am presented with a cursor on top of a blank screen, no login, unable to get any more details.

The hardware is a fresh new server, Intel Xeon coffee lake. Could there be some bios settings interfering with booting arch iso? I tried disabling some stuff, to no effect. The clock in BIOS is set to UTC.

I also tried booting the USB key on another computer and everything works as expected. I checked the ISO signature.

Any ideas on how I could debug this issue? Thanks.

Last edited by marko154 (2020-05-04 17:34:28)

Offline

#2 2020-05-04 14:28:27

bernieke
Member
Registered: 2020-05-04
Posts: 3

Re: [SOLVED] Pacman-init.service error when booting live ISO

Same problem here. At least the February ISO works fine. Not sure about March or April, but I didn't want to take the risk of them not working either, and I knew the February one worked since that's the one I installed against.

What's even worse is I came across this problem because the Arch installed to my pc does the same thing after upgrading it. (I wrote the latest iso to usb to boot from and try to fix the problem.) At least I now know it's not something I did, but something caused by an upgraded package during the last few days.

Offline

#3 2020-05-04 14:33:52

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 23,479
Website

Re: [SOLVED] Pacman-init.service error when booting live ISO

bernieke wrote:

I came across this problem because the Arch installed to my pc does the same thing after upgrading it.

Why would you have pacman-init.service enabled on your installed system?  It's not even installed unless you installed archboot or archiso, and even with those it's not meant to be enabled on an installed system.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#4 2020-05-04 14:41:13

bernieke
Member
Registered: 2020-05-04
Posts: 3

Re: [SOLVED] Pacman-init.service error when booting live ISO

Not the pacman-init.service, the blinking cursor instead of a login prompt.

Not sure if one has to do with the other...

Offline

#5 2020-05-04 14:44:03

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,620

Re: [SOLVED] Pacman-init.service error when booting live ISO

It probably has the screwed up dhcpcd, been causing all kinds of problems. I would use the April ISO

Offline

#6 2020-05-04 14:50:31

bernieke
Member
Registered: 2020-05-04
Posts: 3

Re: [SOLVED] Pacman-init.service error when booting live ISO

Yes! Downgrading dhcpcd fixed my pc.

Offline

#7 2020-05-04 15:46:37

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 758
Website

Re: [SOLVED] Pacman-init.service error when booting live ISO

I have the same issues with the latest iso from 1st of May:
1) Failed to start Initializes Pacman keyring
2) No login prompt when bootet in EFI mode
Booting in legacy mode with Syslinux works.

Also the default entry of the Grub boot loader in EFI mode is for some reason not the live system (1st entry) but an EFI shell (3rd entry).

Last edited by schard (2020-05-04 15:46:55)

Offline

#8 2020-05-04 17:32:38

marko154
Member
Registered: 2013-08-13
Posts: 6

Re: [SOLVED] Pacman-init.service error when booting live ISO

I can confirm that using April ISO avoided the issue. System is now installed, up to date and working fine. Thanks.

Offline

#9 2020-05-06 03:37:13

Qt.ng
Member
Registered: 2020-05-06
Posts: 2

Re: [SOLVED] Pacman-init.service error when booting live ISO

I also got this problem when trying the May 1 ISO

Offline

#10 2020-05-07 21:45:16

Jeremyxu666
Member
Registered: 2020-05-07
Posts: 1

Re: [SOLVED] Pacman-init.service error when booting live ISO

I made it work by freezing the dhcpcd version and add the lines in the file airootfs/root/customize_airootfs.sh in the archiso-releng

/usr/bin/pacman-key --init
/usr/bin/pacman-key --populate archlinux
pacman -U --noconfirm https://archive.archlinux.org/repos/2020/04/19/core/os/x86_64/dhcpcd-8.1.7-1-x86_64.pkg.tar.zst

Offline

Board footer

Powered by FluxBB