You are not logged in.

#1 2020-05-04 17:34:50

solonovamax
Member
Registered: 2020-05-04
Posts: 49

[SOLVED] LibGL errors with osu! and wine

I'm trying to get osu! set up for my pc like described in this guide. I got to the step of running the installer, at which point it errors out.

At first, it complained about not having mono, but that was fixed through the tutorial wine provides. (This isn't that relevant, but I'm putting it here in case it might be)
I have libGL and the proprietary nvidia drivers installed. I have rebooted multiple times since I installed it, so that isn't the cause.

If there is any other info that I should provide, please let me know; I am new to using linux as a primary OS, so I'm not that experienced with this.

Here is the libGL error:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request:  GLXBadContext
  Major opcode of failed request:  151 (GLX)
  Minor opcode of failed request:  6 (X_GLXIsDirect)
  Serial number of failed request:  378
  Current serial number in output stream:  377

Last edited by solonovamax (2020-05-05 20:33:44)


Thanks for your time,
solonovamax

https://github.com/solonovamax

Offline

#2 2020-05-04 17:52:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,898

Re: [SOLVED] LibGL errors with osu! and wine

Install the 32bit graphics drivers (lib32-nvidia-utils). Also whenever that guide reccommends -Sy run -Syu instead, in fact run -Syu immediately after reading this reply.

Offline

#3 2020-05-04 20:16:08

solonovamax
Member
Registered: 2020-05-04
Posts: 49

Re: [SOLVED] LibGL errors with osu! and wine

I'll install the 32 bit drivers once I get to my pc, but I've done -Syu many times since I've installed everything.

iirc, I've already installed the 32bit version, but I could be mistaken.
I'll update once I install it.


Thanks for your time,
solonovamax

https://github.com/solonovamax

Offline

#4 2020-05-04 20:55:54

solonovamax
Member
Registered: 2020-05-04
Posts: 49

Re: [SOLVED] LibGL errors with osu! and wine

I checked and I hadn't installed it. I have thus confirmed I am officially an idiot.

Thanks for your help.


Thanks for your time,
solonovamax

https://github.com/solonovamax

Offline

#5 2020-05-05 06:53:35

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,898

Re: [SOLVED] LibGL errors with osu! and wine

Glad to hear (not the idiot part, the problem solved part wink ), please mark it as such by prepending [SOLVED] or so to the title. https://wiki.archlinux.org/index.php/Co … ow_to_post

Offline

Board footer

Powered by FluxBB