You are not logged in.

#1 2020-05-08 13:09:41

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 875
Website

Cannot upgrade system due to missing key

I am trying to upgrade a system that has been in storage for about a year or so.
However, I cannot upgrade it, since the key "6D42BDD116E0068F" cannot be retrieved by GPG.

0 ✓ homeinfo@11.1038007 ~ $ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: curl will be installed before its ca-certificates dependency
warning: dependency cycle detected:
warning: curl will be installed before its ca-certificates-utils dependency
warning: dependency cycle detected:
warning: harfbuzz will be installed before its freetype2 dependency
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: lib32-harfbuzz will be installed before its lib32-freetype2 dependency
warning: dependency cycle detected:
warning: lib32-krb5 will be installed before its lib32-keyutils dependency
warning: dependency cycle detected:
warning: lib32-mesa will be installed before its lib32-libglvnd dependency
warning: dependency cycle detected:
warning: rubygems will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-irb will be installed before its ruby dependency
warning: dependency cycle detected:
warning: ruby-reline will be installed before its ruby dependency

Packages (331) acl-2.2.53-3  alsa-lib-1.2.2-1  alsa-plugins-1.2.2-1  alsa-topology-conf-1.2.2-2  alsa-ucm-conf-1.2.2-1  amd-ucode-20200421.78c0348-1  archlinux-keyring-20200422-1  argon2-20190702-3
               atk-2.36.0-1  attr-2.4.48-3  audit-2.8.5-6  avahi-0.8+15+ge8a3dd0-1  bash-5.0.016-1  bash-completion-2.10-1  beep-1.4.9-1  bzip2-1.0.8-3  ca-certificates-20181109-3
               ca-certificates-mozilla-3.52-1  ca-certificates-utils-20181109-3  cairo-1.17.2+17+g52a7c79fd-2  coreutils-8.32-1  cracklib-2.9.7-2  cryptsetup-2.3.2-2  curl-7.70.0-1  db-5.3.28-5  dbus-1.12.16-5
               desktop-file-utils-0.24-2  device-mapper-2.02.187-2  diffutils-3.7-3  dnssec-anchors-20190629-2  e2fsprogs-1.45.6-2  efibootmgr-17-1  efivar-37-3  expat-2.2.9-3  fakeroot-1.24-2  file-5.38-3
               filesystem-2020.05.03-1  findutils-4.7.0-2  fontconfig-2:2.13.91+24+g75eadca-2  freetype2-2.10.1-2  fribidi-1.0.9-1  gawk-5.1.0-1  gcc-libs-9.3.0-1  gdbm-1.18.1-3  gdk-pixbuf2-2.40.0-2
               gettext-0.20.2-1  giflib-5.2.1-1  glib2-2.64.2-1  glibc-2.31-2  glu-9.0.1-1  gmp-6.2.0-1  gnupg-2.2.20-1  gnutls-3.6.13-2  gpgme-1.13.1-5  gpm-1.20.7.r27.g1fd1941-2  graphite-1:1.3.14-1
               grep-3.4-1  groff-1.22.4-3  gtk-update-icon-cache-1:3.24.20-1  gtk2-2.24.32-2  gzip-1.10-3  harfbuzz-2.6.5-2  haveged-1.9.8-1  hwids-20200306-1  i2c-tools-4.1-3  iana-etc-20200428-1  icu-67.1-1
               imlib2-1.6.1-1  inetutils-1.9.4-8  intel-ucode-20191115-3  iproute2-5.6.0-1  iptables-1:1.8.4-1  iputils-20190709-2  jansson-2.12-2  json-c-0.14-4  kbd-2.2.0-5  keyutils-1.6.1-4  kmod-27-1
               krb5-1.18-1  ldns-1.7.1-2  less-551-3  lib32-alsa-lib-1.2.2-1  lib32-alsa-plugins-1.2.2-1  lib32-atk-2.36.0-1  lib32-bzip2-1.0.8-2  lib32-cairo-1.17.2+17+g52a7c79fd-2  lib32-e2fsprogs-1.45.6-1
               lib32-expat-2.2.9-1  lib32-fontconfig-2:2.13.91+24+g75eadca-2  lib32-freetype2-2.10.1-2  lib32-fribidi-1.0.9-1  lib32-gcc-libs-9.3.0-1  lib32-gdk-pixbuf2-2.40.0-1  lib32-glib2-2.64.2-1
               lib32-glibc-2.31-2  lib32-gmp-6.2.0-1  lib32-gnutls-3.6.13-2  lib32-harfbuzz-2.6.5-2  lib32-icu-67.1-1  lib32-keyutils-1.6.1-1  lib32-krb5-1.18-1  lib32-libcap-2.33-1  lib32-libcups-2.3.3-1
               lib32-libdrm-2.4.101-1  lib32-libelf-0.177-1  lib32-libffi-3.3-2  lib32-libgcrypt-1.8.5-1  lib32-libglvnd-1.3.1-1  lib32-libgpg-error-1.37-1  lib32-libjpeg-turbo-2.0.4-1  lib32-libldap-2.4.49-1
               lib32-libpciaccess-0.16-1  lib32-libpng-1.6.37-2  lib32-libtasn1-4.16.0-1  lib32-libtiff-4.1.0-1  lib32-libx11-1.6.9-1  lib32-libxau-1.0.9-1  lib32-libxcb-1.14-1  lib32-libxcomposite-0.4.5-1
               lib32-libxcursor-1.2.0-1  lib32-libxdamage-1.1.5-1  lib32-libxdmcp-1.1.3-1  lib32-libxext-1.3.4-1  lib32-libxft-2.3.3-1  lib32-libxi-1.7.10-2  lib32-libxml2-2.9.10-2  lib32-libxrandr-1.5.2-1
               lib32-libxslt-1.1.34-1  lib32-llvm-libs-10.0.0-1  lib32-lm_sensors-3.6.0-1  lib32-lz4-1.9.2-1  lib32-mesa-20.0.6-2  lib32-ncurses-6.2-1  lib32-nettle-3.6-1  lib32-nspr-4.25-1  lib32-nss-3.52-1
               lib32-openssl-1:1.1.1.g-1  lib32-p11-kit-0.23.20-4  lib32-pango-1:1.44.7+11+g73b46b04-1  lib32-pcre-8.44-1  lib32-pixman-0.38.4-1  lib32-sqlite-3.31.1-1  lib32-systemd-245.5-1
               lib32-util-linux-2.35.1-1  lib32-wayland-1.18.0-2  lib32-xz-5.2.5-1  lib32-zstd-1.4.4-2  libarchive-3.4.2-1  libassuan-2.5.3-2  libcap-2.33-1  libcap-ng-0.7.10-1  libcups-2.3.3-1
               libdrm-2.4.101-1  libedit-20191231_3.1-1  libelf-0.178-2  libepoxy-1.5.4-1  libevdev-1.9.0-1  libffi-3.3-3  libgcrypt-1.8.5-2  libglvnd-1.3.1-1  libgpg-error-1.37-1  libgudev-233-1
               libice-1.0.10-2  libidn-1.35-2  libidn2-2.3.0-1  libinput-1.15.5-1  libjpeg-turbo-2.0.4-1  libksba-1.3.5-2  libldap-2.4.49-1  libmnl-1.0.4-3  libnetfilter_conntrack-1.0.8-1  libnftnl-1.1.6-1
               libnghttp2-1.40.0-1  libnl-3.5.0-2  libnsl-1.2.0-2  libp11-kit-0.23.20-4  libpcap-1.9.1-2  libpciaccess-0.16-1  libpipeline-1.5.2-1  libpng-1.6.37-1  libpsl-0.21.0-2  librsvg-2:2.48.4-1
               libsasl-2.1.27-2  libseccomp-2.4.2-1  libsecret-0.20.3-1  libsm-1.2.3-2  libssh2-1.9.0-2  libtasn1-4.16.0-1  libtiff-4.1.0-1  libtirpc-1.2.6-1  libtool-2.4.6+42+gb88cebd5-12
               libunistring-0.9.10-2  libusb-1.0.23-2  libutil-linux-2.35.1-2  libwacom-1.3-1  libwebp-1.1.0-1  libx11-1.6.9-6  libxau-1.0.9-2  libxcb-1.14-1  libxcomposite-0.4.5-2  libxdamage-1.1.5-2
               libxdmcp-1.1.3-2  libxext-1.3.4-2  libxfixes-5.0.3-3  libxfont2-2.0.4-2  libxi-1.7.10-2  libxinerama-1.1.4-2  libxml2-2.9.10-2  libxrandr-1.5.2-2  libxrender-0.9.10-3  libxshmfence-1.3-2
               libxslt-1.1.34-2  libxt-1.2.0-1  libxtst-1.2.3-3  libxv-1.0.11-3  libxvmc-1.0.12-2  libxxf86vm-1.1.4-3  libyaml-0.2.4-1  licenses-20200427-1  linux-api-headers-5.4.17-1
               linux-firmware-20200421.78c0348-1  linux-lts-5.4.39-1  linux-lts-headers-5.4.39-1  llvm-libs-10.0.0-1  lm_sensors-3.6.0-1  lz4-1:1.9.2-2  lzo-2.10-3  man-db-2.9.1-2  man-pages-5.06-2
               mesa-20.0.6-2  mkinitcpio-27-3  mkinitcpio-busybox-1.31.1-1  mpfr-4.0.2-2  mtdev-1.1.6-1  ncurses-6.2-1  nettle-3.6-1  nftables-1:0.9.4-1  npth-1.6-2  nspr-4.25-1  nss-3.52-1  openssh-8.2p1-3
               openssl-1.1.1.g-1  openvpn-2.4.9-2  p11-kit-0.23.20-4  pacman-5.2.1-5  pacman-contrib-1.3.0-1  pacman-mirrorlist-20200411-1  pam-1.3.1-2  pambase-20190105.1-2  pango-1:1.44.7+11+g73b46b04-1
               pciutils-3.6.4-1  pcre-8.44-1  pcre2-10.34-3  perl-5.30.2-1  pinentry-1.1.0-5  pixman-0.40.0-1  pkcs11-helper-1.26.0-1  popt-1.16-12  procps-ng-3.3.16-1  psmisc-23.3-2  python-3.8.2-2
               python-appdirs-1.4.3-5  python-chardet-3.0.4-4  python-click-7.1.1-1  python-docopt-0.6.2-7  python-flask-1.1.2-2  python-idna-2.9-1  python-itsdangerous-1.1.0-3  python-jinja-2.11.2-1
               python-markupsafe-1.1.1-3  python-ordered-set-3.1.1-1  python-packaging-20.3-1  python-pyparsing-2.4.7-1  python-requests-2.23.0-1  python-setuptools-1:46.1.3-1  python-six-1.14.0-1
               python-urllib3-1.25.9-1  python-werkzeug-1.0.1-1  readline-8.0.004-1  reflector-2020.3.21.2-1  rsync-3.1.3-3  ruby-2.7.1-2  ruby-irb-1.2.1-1  ruby-reline-0.0.7-2  rubygems-3.1.2-4  scrot-1.2-1
               sed-4.8-1  shadow-4.8.1-1  shared-mime-info-2.0+1+g6bf9e4f-1  sqlite-3.31.1-1  sudo-1.8.31.p1-1  sysfsutils-2.1.0-11  syslinux-6.04.pre2.r11.gbf6db5b4-3  systemd-245.5-2  systemd-libs-245.5-2
               tar-1.32-3  tigervnc-1.10.1-2  ttf-dejavu-2.37-3  tzdata-2020a-1  unzip-6.0-14  usbutils-012-2  util-linux-2.35.1-2  vim-8.2.0510-2  vim-runtime-8.2.0510-2  wayland-1.18.0-2  which-2.21-5
               xcb-proto-1.14-1  xcb-util-0.4.0-3  xdg-utils-1.1.3+19+g9816ebb-1  xf86-input-libinput-0.29.0-2  xf86-video-amdgpu-19.1.0-1  xf86-video-ati-1:19.1.0-1  xf86-video-intel-1:2.99.917+906+g846b53da-1
               xf86-video-vesa-2.4.0-3  xkeyboard-config-2.29-1  xorg-fonts-encodings-1.0.5-1  xorg-mkfontscale-1.2.1-2  xorg-server-1.20.8-2  xorg-server-common-1.20.8-2  xorg-setxkbmap-1.3.2-1
               xorg-xauth-1.1-1  xorg-xinput-1.6.3-1  xorg-xkbcomp-1.4.3-1  xorg-xprop-1.2.4-1  xorg-xrandr-1.5.1-1  xorg-xset-1.2.4-2  xorg-xsetroot-1.1.2-2  xorgproto-2020.1-1  xz-5.2.5-1  zlib-1:1.2.11-4
               zstd-1.4.4-1

Total Installed Size:  2103.26 MiB
Net Upgrade Size:       194.94 MiB

:: Proceed with installation? [Y/n] 
(331/331) checking keys in keyring                                                                                             [#############################################################################] 100%
downloading required keys...
error: key "6D42BDD116E0068F" could not be looked up remotely
error: key "7258734B41C31549" could not be looked up remotely
error: key "45A650E2638C536D" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
1 ✗ homeinfo@11.1038007 ~ $ sudo pacman -Sy archlinux-keyring 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...

Packages (1) archlinux-keyring-20200422-1

Total Installed Size:  1.23 MiB
Net Upgrade Size:      0.29 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                                                                                 [#############################################################################] 100%
downloading required keys...
error: key "6D42BDD116E0068F" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
1 ✗ homeinfo@11.1038007 ~ $ sudo rm -rf /etc/pacman.d/gnupg/
0 ✓ homeinfo@11.1038007 ~ $ sudo pacman-key --init
gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
gpg: no ultimately trusted keys found
gpg: starting migration from earlier GnuPG versions
gpg: porting secret keys from '/etc/pacman.d/gnupg/secring.gpg' to gpg-agent
gpg: migration succeeded
gpg: Generating pacman keyring master key...
gpg: key 9184A59E865ABE97 marked as ultimately trusted
gpg: directory '/etc/pacman.d/gnupg/openpgp-revocs.d' created
gpg: revocation certificate stored as '/etc/pacman.d/gnupg/openpgp-revocs.d/CA972D54C53F96D248009A1A9184A59E865ABE97.rev'
gpg: Done
==> Updating trust database...
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
0 ✓ homeinfo@11.1038007 ~ $ sudo pacman-key --populate archlinux
==> Appending keys from archlinux.gpg...
==> Locally signing trusted keys in keyring...
  -> Locally signing key D8AFDDA07A5B6EDFA7D8CCDAD6D055F927843F1C...
  -> Locally signing key DDB867B92AA789C165EEFA799B729B06A680C281...
  -> Locally signing key 684148BB25B49E986A4944C55184252D824B18E8...
  -> Locally signing key 91FFE0700E80619CEB73235CA88E23E377514E00...
  -> Locally signing key 0E8B644079F599DFC1DDC3973348882F6AC6A4C2...
  -> Locally signing key AB19265E5D7D20687D303246BA1DFB64FFF979E7...
==> Importing owner trust values...
gpg: inserting ownertrust of 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
gpg: setting ownertrust to 4
==> Disabling revoked keys in keyring...
  -> Disabling key 8F76BEEA0289F9E1D3E229C05F946DED983D4366...
  -> Disabling key 63F395DE2D6398BBE458F281F2DBB4931985A992...
  -> Disabling key 50F33E2E5B0C3D900424ABE89BDCF497A4BBCC7F...
  -> Disabling key 27FFC4769E19F096D41D9265A04F9397CDFD6BB0...
  -> Disabling key 39F880E50E49A4D11341E8F939E4F17F295AFBF4...
  -> Disabling key 8840BD07FC24CB7CE394A07CCF7037A4F27FB7DA...
  -> Disabling key 5559BC1A32B8F76B3FCCD9555FA5E5544F010D48...
  -> Disabling key 0B20CA1931F5DA3A70D0F8D2EA6836E1AB441196...
  -> Disabling key 07DFD3A0BC213FA12EDC217559B3122E2FA915EC...
  -> Disabling key 4FCF887689C41B09506BE8D5F3E1D5C5D30DB0AD...
  -> Disabling key 5A2257D19FF7E1E0E415968CE62F853100F0D0F0...
  -> Disabling key 7FA647CD89891DEDC060287BB9113D1ED21E1A55...
  -> Disabling key BC1FBE4D2826A0B51E47ED62E2539214C6C11350...
  -> Disabling key 4A8B17E20B88ACA61860009B5CED81B7C2E5C0D2...
  -> Disabling key 5696C003B0854206450C8E5BE613C09CB4440678...
  -> Disabling key 8CF934E339CAD8ABF342E822E711306E3C4F88BC...
  -> Disabling key F5A361A3A13554B85E57DDDAAF7EF7873CFD4BB6...
  -> Disabling key 5E7585ADFF106BFFBBA319DC654B877A0864983E...
  -> Disabling key 65EEFE022108E2B708CBFCF7F9E712E59AF5F22A...
  -> Disabling key 40440DC037C05620984379A6761FAD69BA06C6A9...
  -> Disabling key 34C5D94FE7E7913E86DC427E7FB1A3800C84C0A5...
  -> Disabling key 81D7F8241DB38BC759C80FCE3A726C6170E80477...
  -> Disabling key E7210A59715F6940CF9A4E36A001876699AD6E84...
  -> Disabling key 5357F3B111688D88C1D88119FCF2CB179205AC90...
  -> Disabling key FB871F0131FEA4FB5A9192B4C8880A6406361833...
  -> Disabling key 66BD74A036D522F51DD70A3C7F2A16726521E06D...
  -> Disabling key B1F2C889CB2CCB2ADA36D963097D629E437520BD...
  -> Disabling key 9515D8A8EAB88E49BB65EDBCE6B456CAF15447D5...
  -> Disabling key 40776A5221EF5AD468A4906D42A1DB15EC133BAD...
  -> Disabling key D4DE5ABDE2A7287644EAC7E36D1A9E70E19DAA50...
  -> Disabling key 44D4A033AC140143927397D47EFD567D4C7EA887...
==> Updating trust database...
gpg: key 1EB2638FF56C0C53: no user ID for key signature packet of class 10
gpg: key 1EB2638FF56C0C53: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: key 786C63F330D7CB92: no user ID for key signature packet of class 10
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:   6  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: depth: 1  valid:   6  signed:  69  trust: 0-, 0q, 0n, 6m, 0f, 0u
gpg: depth: 2  valid:  69  signed:   5  trust: 69-, 0q, 0n, 0m, 0f, 0u
gpg: next trustdb check due at 2020-06-15
0 ✓ homeinfo@11.1038007 ~ $ sudo pacman -Sy archlinux-keyring 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
resolving dependencies...
looking for conflicting packages...

Packages (1) archlinux-keyring-20200422-1

Total Installed Size:  1.23 MiB
Net Upgrade Size:      0.29 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                                                                                 [#############################################################################] 100%
downloading required keys...
error: key "6D42BDD116E0068F" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
1 ✗ homeinfo@11.1038007 ~ $ 

What am I doing wrong?

Update:
After checking the SHA-256 checksum of archlinux-keyring-20200422-1, I installed it via

sudo pacman -U /var/cache/pacman/pkg/archlinux-keyring-20200422-1-any.pkg.tar.zst 

What I don't understand is, why the pacman keyring still needed to download a pubkey, after I re-populated the archlinux keyring.

Last edited by schard (2020-05-08 13:23:33)

Offline

#2 2020-05-09 14:48:24

loqs
Member
Registered: 2014-03-06
Posts: 11,244

Re: Cannot upgrade system due to missing key

If the archlinux-keyring package on the system did not include eworm's ed25519 sub key due to being too old `pacman-key --init` which is only adding keys provided by the package will not contain it.
You did not include the version of archlinux-keyring before the update to 20200422-1.

Offline

#3 2020-05-11 06:35:38

NuSkool
Member
Registered: 2015-03-23
Posts: 101

Re: Cannot upgrade system due to missing key

Not an answer to your question, but over the years, I've got into the habit of running the following when I see the "error: key" during an update:

pacman -S archlinux-keyring

Then proceed with the system update. This usually gets things rolling again.

I usually encounter this error after a prolonged period of time since the last update.

Offline

Board footer

Powered by FluxBB