You are not logged in.

#1 2020-05-11 10:34:33

Registered: 2020-05-11
Posts: 1

"Virgl 3d acceleration not supported by host" for intel hd 4000

The problem occurs when I run Whonix on KVM host and prevents the guest from using virtio drivers which are recommended by default. I decided to post this thread on Arch forum and not Whonix because I use Arch Linux, and Whonix KVM maintainer already explained this problem occurs due to my host having obsolete graphics stack. Sorry, I can't find the link to this thread, I didn't start it. But my IGP was specified there.

I can't use Whonix normally because of screen tearing and overall slow graphics performance. If I run dmesg on guest, I have the message in this thread's topic.

I don't understand much about graphics infrastructure and how OS components(Xorg, kernel, video drivers) can configure it, my bad, so most likely I made very simple mistake unless my IGP is really outdated(2012/2013). I already tried to tweak 20-intel.conf, deleted xf86-video-intel, nothing works. My processor is i5-3230M.


#2 2020-05-16 14:39:10

Registered: 2019-07-13
Posts: 12

Re: "Virgl 3d acceleration not supported by host" for intel hd 4000

It is unrelated to your Xorg config. As long as you get into graphical environment, you'll have no problem running a virtual machine with virgl3d enabled if it is supported. The VM operating system itself knows nothing about the host's configuration. It thinks it is running on a physical device, which is virtual, so no matter what is going on with your Xorg, no matter what you do to it, if the host is usable, it shouldn't detect anything.
I think what the maintainer said is correct. Your intel gpu (hd4000) is way too old for virgl3d, it is not supported. The error message shows it clearly. You may try qxl with spice.
You can try disable some graphical effects, and lower the resolution of the VM.


Board footer

Powered by FluxBB