You are not logged in.

#1 2020-05-13 20:07:19

enricozb
Member
Registered: 2020-05-13
Posts: 3

[SOLVED] Booting from UEFI USB installer hangs after

Hi. Sorry to populate this forum with yet another installation issue.

I'm trying to install Arch. I created a bootable usb using

dd bs=4M if=path/to/archlinux.iso of=/dev/sdx status=progress oflag=sync

while on Ubuntu with the current (2020.05.01) version of the iso. I verified the sha1, md5, and PGP signature of the iso. I have my motherboard set to UEFI boot mode, and when I boot into the usb, I get a menu with 5 options:

- Arch Linux archiso x86_64 UEFI CD
- UEFI Shell x86_64 v1
- UEFI Shell x86_64 v2
- EFI Default Loader
- Reboot Into Firmware Interface

When I select the first option, a lot of text scrolls by the screen, for about 5 seconds. The notable messages are:

- Triggerring uevents passed
... ( screen flashes and font becomes less blurry )
- [FAILED] to start Initialized the pacman keyring
... ( several [  OK  ] lines )
- [  OK  ] started dhcpd on enp0s31f6
- a start job is running for dhcpd on enp4s0 (32s)

Now, this very last line stays on for ~30 seconds, and then the screen clears and I get a blinking cursor for the remainder of time.

I have tried setting `nomodeset` when selecting the `Arch Linux archiso x86_64 UEFI CD` option, but that didn't work.

My computer specs are:
- Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
- 16 GB RAM
- NVIDIA GTX 1070 (the monitor is connected through the dedicated graphics card, not through the one on the mother board)
- EVGA Z170 Classified K motherboard

When I try this process on Legacy (non-UEFI) boot, I get a differently styled menu of options when booting the USB:

- Boot Arch Linux (x86_64)
- Boot existing OS
- Run Memtest86+ (RAM test)
- Hardware Information (HDT)
- Reboot
- Power Off

If I select the first option, I get the exact same behavior as described above in the UEFI boot.

I can't seem to get past this... I'd like to boot into the installation usb to install arch on one of my SSDs.

Any help would be appreciated. Let me know if I can provide any more information. Thanks

Last edited by enricozb (2020-05-16 21:49:39)

Offline

#2 2020-05-13 20:25:05

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,761

Re: [SOLVED] Booting from UEFI USB installer hangs after

There is potentially  an issue with the current ISO and it's constellation of packages try a month earlier: https://www.archlinux.org/releng/releases/

Offline

#3 2020-05-14 00:38:07

enricozb
Member
Registered: 2020-05-13
Posts: 3

Re: [SOLVED] Booting from UEFI USB installer hangs after

Wow, I can't believe out of all of the things I tried, that I didn't try this one. Thanks a ton, doing this booted me into the live USB, so that answers my question. Do you think I should refrain from updating to 2020.05.01 with

pacman -Syu

after install?

Offline

#4 2020-05-14 00:54:28

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,733
Website

Re: [SOLVED] Booting from UEFI USB installer hangs after

Arch is a rolling release. The only snapshots are the installation images, everything else is in constant motion. Always -Syu.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#5 2020-05-14 16:11:37

Voglscheichn
Member
Registered: 2015-08-31
Posts: 6

Re: [SOLVED] Booting from UEFI USB installer hangs after

I have the same issue. It does not seem to affect every machine. The current install medium works on all machines I own except for an HP DL380 Gen8. Systemd shows all boot messages and when it is supposed to show the command line prompt, only a black screen with a blinking cursor appears on all ttys. I have this issue with the current Arch install medium (archlinux-2020.05.01-x86_64.iso) with systemd 245.5-2. However the install medium archlinux-2019.12.01-x86_64.iso with systemd 243.162-2 works just fine. In addition, I built a custom Arch install medium too, which is exact the same as the upstream one but with sshd enabled on boot. During boot, I can see the HP machine requests an IP. When I try to ssh to it the connection is refused while ping works flawlessly. On other machines, I can ssh to them without problems with the same install medium.

Unfortunately I do not know what exactly causes this behavior. Hopefully some figures it out as I need to build my own install medium which of course have always the latest packages.

Edit: I forgot to mention, that I did not test UEFI, I have this problem with Syslinux.

Last edited by Voglscheichn (2020-05-14 18:27:05)

Offline

#6 2020-05-16 21:49:20

enricozb
Member
Registered: 2020-05-13
Posts: 3

Re: [SOLVED] Booting from UEFI USB installer hangs after

Using the 2020-04-01 image solved my problem, and both the BIOS and the UEFI boots worked. Thank you @V1del and @jasonwryan!

Last edited by enricozb (2020-05-16 21:50:15)

Offline

Board footer

Powered by FluxBB