You are not logged in.

#1 2020-05-17 17:02:16

wilmerhenao
Member
From: Ann Arbor, MI
Registered: 2012-10-15
Posts: 37
Website

nvidia-settings ERROR: Unable to find display on any available system

Hi. I just went through a fresh install. I have two monitors, one of them is connected to the nvidia video card and the other one is connected to a different port.

I can see the one that is connected to the port. I cannot see the nvidia one. I was hopping that nvidia-settings would help me but my computer can't find the other monitor.

I ran:
    pacman -S nvidia
    nvidia-xconfig
    pacman -S gdm
    pacman -S gnome
    systemctl enable gdm

my lspci -k looks like this:

01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)
    Subsystem: Dell GP106 [GeForce GTX 1060 6GB]
    Kernel driver in use: nvidia
    Kernel modules: nouveau, nvidia_drm, nvidia
01:00.1 Audio device: NVIDIA Corporation GP106 High Definition Audio Controller (rev a1)
    Subsystem: Dell GP106 High Definition Audio Controller
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

and here is the xorg.conf file:

nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.82


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection
01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)
        Subsystem: Dell GP106 [GeForce GTX 1060 6GB]
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia
01:00.1 Audio device: NVIDIA Corporation GP106 High Definition Audio Controller (rev a1)
        Subsystem: Dell GP106 High Definition Audio Controller
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Any help would be appreciated

Offline

#2 2020-05-17 17:12:13

wilmerhenao
Member
From: Ann Arbor, MI
Registered: 2012-10-15
Posts: 37
Website

Re: nvidia-settings ERROR: Unable to find display on any available system

UPDATE: Not an emergency anymore. Disconnecting the old monitor and restarting takes me to the NVIDIA monitor which is the one I want to work.

It would still be nice to get the old monitor working too. Although it can wait a few days.

Offline

Board footer

Powered by FluxBB