You are not logged in.

#1 2020-05-18 10:33:27

albeus
Member
Registered: 2020-05-18
Posts: 1

Joplin sqlite3 error

Hello,

I installed Joplin:

Name            : joplin
Version         : 1.0.201-1
Description     : A note taking and to-do application with synchronization
                  capabilities
Architecture    : x86_64
URL             : https://joplinapp.org/
Licenses        : MIT
Groups          : None
Provides        : None
Depends On      : gtk3  libexif  libgsf  libjpeg-turbo  libwebp  libxss  nodejs
                  nss  orc
Optional Deps   : libappindicator-gtk3: for tray icon [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 399.04 MiB
Packager        : Unknown Packager
Build Date      : Sat 25 Apr 2020 06:35:04 PM BST
Install Date    : Mon 18 May 2020 10:49:14 AM BST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None

The GUI is running fine but when I launch the CLI (running the "joplin" command from terminal) I get this error:

internal/modules/cjs/loader.js:1023
  throw err;
  ^

Error: Cannot find module '/usr/share/joplin-cli/node_modules/sqlite3/lib/binding/node-v83-linux-x64/node_sqlite3.node'
Require stack:
- /usr/share/joplin-cli/node_modules/sqlite3/lib/sqlite3.js
- /usr/share/joplin-cli/lib/database-driver-node.js
- /usr/share/joplin-cli/lib/BaseApplication.js
- /usr/share/joplin-cli/app.js
- /usr/share/joplin-cli/main.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:1020:15)
    at Function.Module._load (internal/modules/cjs/loader.js:890:27)
    at Module.require (internal/modules/cjs/loader.js:1080:19)
    at require (internal/modules/cjs/helpers.js:72:18)
    at Object.<anonymous> (/usr/share/joplin-cli/node_modules/sqlite3/lib/sqlite3.js:4:15)
    at Module._compile (internal/modules/cjs/loader.js:1176:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:1196:10)
    at Module.load (internal/modules/cjs/loader.js:1040:32)
    at Function.Module._load (internal/modules/cjs/loader.js:929:14)
    at Module.require (internal/modules/cjs/loader.js:1080:19) {
  code: 'MODULE_NOT_FOUND',
  requireStack: [
    '/usr/share/joplin-cli/node_modules/sqlite3/lib/sqlite3.js',
    '/usr/share/joplin-cli/lib/database-driver-node.js',
    '/usr/share/joplin-cli/lib/BaseApplication.js',
    '/usr/share/joplin-cli/app.js',
    '/usr/share/joplin-cli/main.js'
  ]
}

Ideas?

Offline

Board footer

Powered by FluxBB