You are not logged in.

#1 2020-05-19 13:35:28

Salkay
Member
Registered: 2014-05-22
Posts: 448

[CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

A recent update (probably xf86-input-libinput 0.29.0-2 -> 0.30.0-1) has stopped some of my xorg.conf files from working. Specifically, I had previously followed instructions to prevent mouse acceleration, by putting the following in a file at /etc/X11/xorg.conf.d/81-anker-wireless-deceleration.conf

Section "InputClass"
    Identifier "Anker wireless slowdown"
    MatchIsPointer "yes"
    MatchVendor "MOSART_Semi."
    MatchProduct "MOSART Semi. 2.4G Wireless Mouse"
# set the following to 1 1 0 respectively to disable acceleration.
    Option "AccelerationNumerator" "1"
    Option "AccelerationDenominator" "1"
    Option "AccelerationThreshold" "0"
# linear deceleration (mouse speed reduction)
    Option "ConstantDeceleration" "2"
EndSection

With the new libinput, I realise that some of these commands have changed. To remove mouse acceleration and slow down the pointer manually, I can run the following in a terminal, which works well.

xinput set-prop 'MOSART Semi. 2.4G Wireless Mouse' 'libinput Accel Profile Enabled' 0 1
xinput set-prop 'MOSART Semi. 2.4G Wireless Mouse' 'libinput Accel Speed' -0.4

However, the xorg.conf changes suggested in the link above don't seem to work.

  # No acceleration
  Option "AccelProfile" "flat"
  # Reduce speed
  Option "AccelSpeed" "-0.4"

I'm not sure if I'm doing something daft, but neither property has changed. I can also see them unchanged with xinput list-props 'MOSART Semi. 2.4G Wireless Mouse'. How can I change mouse acceleration and speed now?

Last edited by Salkay (2020-05-26 10:34:58)

Offline

#2 2020-05-24 00:15:28

euromatlox
Member
Registered: 2017-02-10
Posts: 15

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

I have keyboard settings in "InputClass" and mouse settings in "InputDevice".
Perhaps you can try using "InputDevice" instead of "InputClass" for your mouse settings.

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    Option "BlankTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
EndSection

Section "InputClass"
    Identifier	   	"Keyboard Defaults"
    MatchIsKeyboard	"yes"
    Option         "XkbModel"  "pc105"
    Option	   "XkbLayout" "fi"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option	   "CorePointer"
    Option	   "Device" "/dev/input/mouse0"
    Option	   "Protocol" "ImPS/2"
    Option	    "ZAxisMapping" "4 5 6 7"
    Option	   "Resolution" "400"
    Option	   "Emulate3Buttons" "no"
EndSection

Offline

#3 2020-05-24 01:47:23

Ropid
Member
Registered: 2015-03-09
Posts: 858

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

I'm thinking what you are trying should work.

Try checking the Xorg log file. There might be a hint in there about what's going wrong. Search for the "Identifier" you used in your config, this means "Anker wireless slowdown".

If you'd like, you can go back to using the old "evdev" driver. You need to add a line like this to your InputClass section:

Driver "evdev"

And you need to have the package "xf86-input-evdev" installed.

Offline

#4 2020-05-25 10:22:59

Salkay
Member
Registered: 2014-05-22
Posts: 448

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

euromatlox wrote:

Perhaps you can try using "InputDevice" instead of "InputClass" for your mouse settings.

Thank you for the suggestion, but unfortunately that didn't work. X failed to start with Parse error on line 6 of section InputDevice in file /etc/X11/xorg.conf.d/81-anker-wireless-deceleration.conf "MatchIsPointer" is not a valid keyword in this section.

Ropid wrote:

Try checking the Xorg log file. There might be a hint in there about what's going wrong. Search for the "Identifier" you used in your config, this means "Anker wireless slowdown".

Thanks for the reply. I couldn't find Anker in /var/log/Xorg.0.log at all.

Ropid wrote:

If you'd like, you can go back to using the old "evdev" driver.

I haven't tried this yet, but I did do some other troubleshooting. I tried reverting to xf86-input-libinput-0.29.0-2 with the old config, but that didn't work either. Hence, it might be a problem with a different package.

I'm not really sure what the interaction is with my desktop environment (KDE) and the Xorg rules. I don't know if KDE is overriding xorg.conf after I log in. I can't really see a way to explicitly prevent KDE's rules from working.

I wanted to find a way to isolate the two configs before troubleshooting further, otherwise I wouldn't be sure what effect xorg.conf changes are having.

Offline

#5 2020-05-25 11:15:36

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,480
Website

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

Salkay wrote:

I don't know if KDE is overriding xorg.conf after I log in.

Are you using the Wayland session?

Offline

#6 2020-05-25 11:22:12

Salkay
Member
Registered: 2014-05-22
Posts: 448

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

Head_on_a_Stick wrote:

Are you using the Wayland session?

I don't think so. I'm not using a display manager, but if $DISPLAY is :0, then I think I'm using X?

Offline

#7 2020-05-25 11:23:45

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,480
Website

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

Salkay wrote:

if $DISPLAY is :0, then I think I'm using X?

Not necessarily, my GNOME Wayland desktop reports that output. Try `xrandr` instead.

How are you starting your session?

Offline

#8 2020-05-25 11:31:47

Salkay
Member
Registered: 2014-05-22
Posts: 448

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

Head_on_a_Stick wrote:

Try `xrandr` instead.

Yep, that works.

Head_on_a_Stick wrote:

How are you starting your session?

With a login script, but essentially startx.

Offline

#9 2020-05-25 12:21:12

Ropid
Member
Registered: 2015-03-09
Posts: 858

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

Can you show your Xorg log file and show your xinput output?

Offline

#10 2020-05-26 07:55:06

Salkay
Member
Registered: 2014-05-22
Posts: 448

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

Ropid wrote:

Can you show your Xorg log file and show your xinput output?

Do you mean something specific in the Xorg log file? It's 2000 lines long. I'm also not 100% sure what you mean by "show your xinput output".

Offline

#11 2020-05-26 08:12:13

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,141

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

To shorten this back and forth a bit. KDE definitely has a daemon here that might override what's initially set by a static xorg.conf . The easiest would probably be if you can just replicate your intentions in the relevant KDE gui dialog ( kcmshell5 mouse ). I'm not sure whether that particular service is disableable, it's not listed as part of the kded modules that are usually used for this purpose.

But yes entire xorg.log would be nice, and I assume they are asking about the output of a plain xinput call (or probably rather prop-list of the relevant device so we can see what's actually set and where)

Last edited by V1del (2020-05-26 08:15:06)

Offline

#12 2020-05-26 10:34:43

Salkay
Member
Registered: 2014-05-22
Posts: 448

Re: [CLOSED]Disable mouse acceleration with new xf86-input-libinput 0.30.0

V1del wrote:

KDE definitely has a daemon here that might override what's initially set by a static xorg.conf

I'm not sure whether that particular service is disableable

Yeah, I figured as much. I originally had my mouse rules in xorg.conf because I was (a) using different mice and (b) multiple users, so this simplified my configuration. However, I'm not using multiple mice really, so I think it's probably easiest to just set the settings separately for each user.

Thanks for the help everyone, but I think I won't bother with xorg.conf and just use the KDE GUI instead.

Offline

Board footer

Powered by FluxBB