You are not logged in.

#1 2020-05-27 07:05:58

thehungryturnip
Member
From: New York, NY
Registered: 2019-05-02
Posts: 15

[SOLVED] PulseAudio no Microphone for Google Chrome

I am having issues with using my microphone on Google Chrome/Chromium. When trying to use audio/microphone apps (e.g. Google Meet) on Google Chrome or Chromium I get speaker output but not microphone input.

When using Google Chrome, Google Meet claims that "No microphone found" and "No speakers found", even though the speaker test (within Google Meet) *does* produce sound. (Microphone doesn't seem to be receiving input.)

When using Chromium, the behavior is exactly like Google Chrome (i.e. speaker test produces sound but no microphone input), but Google Meet claims that "Microphone is blocked" and "Speaker is blocked".

Both speakers and microphone works fine using Firebox.

When veiwing server status on pavucontrol, I noticed that the "Recording" entry for both Google Chrome and Chromium is missing when Google Meet is active.

I have checked that "per-site permission" in Google Chrome and Chromium were allowing Google Meet to use my speakers and microphones.

Could this hint at some sort of permission issue for Google Chrome and Chromium? What other information would be helpful for troubleshooting this?

Thanks a lot in advance.

Last edited by thehungryturnip (2020-05-28 08:54:00)

Offline

#2 2020-05-27 23:12:48

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 1,096

Re: [SOLVED] PulseAudio no Microphone for Google Chrome

Which microphone isn't working? An onboard laptop one, or a mic that's plugged in? If plugged in, how is it connected (USB, etc.)? In pavucontrol, is the mic listed under Input Devices?

Offline

#3 2020-05-28 04:46:57

thehungryturnip
Member
From: New York, NY
Registered: 2019-05-02
Posts: 15

Re: [SOLVED] PulseAudio no Microphone for Google Chrome

I have 2 microphones, both plugged in: 1 through HDMI and 1 through the motherboard I/O.

Both microphones show up in pavucontrol as "Input Devices".

When Google Meet is run in FireFox the correct "Recording" entry shows up in pavucontrol and I'm able to select either microphones from the Google Meet's interface in Firefox.

Last edited by thehungryturnip (2020-05-28 04:51:02)

Offline

#4 2020-05-28 08:53:40

thehungryturnip
Member
From: New York, NY
Registered: 2019-05-02
Posts: 15

Re: [SOLVED] PulseAudio no Microphone for Google Chrome

I was able to resolve this by completely killing all Google Chrome and Chromium processes before restarting Google Chrome or Chromium.

Upon further investigation, I noticed that if the PulseAudio daemon was started/restarted, any applications that were running prior to the start/restart can't "register" itself to the daemon to input/output sound. I don't know if there are ways to "re-register" running applications with PulseAudio, but a restart of the application allows it to input/output audio through PulseAduio again. (I'm assuming this is expected behavior but figured I would document it here for future newbies.)

I'll mark this as resolved. Thanks!

Offline

#5 2021-03-21 04:06:19

codywohlers
Member
Registered: 2012-04-21
Posts: 2

Re: [SOLVED] PulseAudio no Microphone for Google Chrome

This issue is not resolved.  Restarting the browser is a workaround.  Does anyone know why chrome will suddenly be unable to find microphones while firefox and every other program on my computer still can?

Last edited by codywohlers (2021-03-21 04:06:42)

Offline

#6 2021-03-21 09:52:26

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,956

Re: [SOLVED] PulseAudio no Microphone for Google Chrome

The issue is solved from thehungryturnip's perspective.

Make a new thread including details of your setup, and the output of

pacmd list-sources
pacmd list-source-outputs
loginctl show-session $XDG_SESSION_ID
sudo fuser -v /dev/snd/*

Closing this old thread.

Online

Board footer

Powered by FluxBB