You are not logged in.

#1 2020-05-31 06:59:12

Registered: 2020-05-31
Posts: 1

Switching Desktop Environment

Hi There, I Don't know it's a good question to ask but I was switching my de from kde to cinnamon.
I uninstalled kde by -

sudo pacman -Rns plasma kde-applications

This command and installed cinnamon packages and updated xorg-pacakages.
When I enable the gdm service it was saying there is already display-manager service running. So I disabled it .
Now when I start gdm service a black screen occurs and it stops there.
Please help with the same.


#2 2020-05-31 08:09:15

Registered: 2020-03-22
Posts: 21

Re: Switching Desktop Environment

Hi, at first, get used to use code tags:

I uninstalled kde by -

sudo pacman -Rns plasma kde-applications

Wich packages did you install in the installation?

When you've already installed KDE you've also sddm. So you need to disable (systemctl disable sddm.service) and uninstall sddm (pacman -Rc sddm). After that you can go on and uninstall all installed plasma packages, then install all cinnamon packages, and then install gdm and don't forget to enable it (systemctl enable gdm)! After that you have to reboot, and cinnamon/must must be working.

EDIT: See also:

Last edited by nick_0278 (2020-05-31 08:11:08)


#3 2020-06-16 08:47:21

Registered: 2020-06-15
Posts: 44

Re: Switching Desktop Environment

Priyanshu, are you on kernel 5.7.2 and intel graphics i915 by any chance? Quick 2 commands (uname -a and lsmod | grep i915) should confirm this. If yes, use any prior kernel which is not 5.7.2 (e.g. linux-lts). Please see if this works.

I think your issue isnt necessarily KDE or Cinnamon issue. Once you are past kernel issues (if any), booting into specific DE should be easy.

Last edited by pk.gmp (2020-06-16 08:51:19)


#4 2020-06-28 09:08:20

Registered: 2020-04-13
Posts: 38

Re: Switching Desktop Environment

seems you sddm still lauched.
maybe u need to remove it.


Board footer

Powered by FluxBB