You are not logged in.

#1 2020-05-31 12:15:22

cristatus
Member
Registered: 2014-01-04
Posts: 10

No sound from left speaker

Hi all,

Since last couple of weeks, I am facing few strange issues with my laptop speakers.

1st issue is when I unplug headphone, there is no sound coming from speaker. I checked that they are not muted, so only way is to reboot.

2nd issue is even more strange and it's random. Sometime after I start my laptop, no sound is coming form left speaker.

The issue is only with my Arch setup. To confirm, I installed Fedora 32 along with Arch and it's working perfectly fine with Fedora 32.

Can someone help me figure out the issue?

Offline

#2 2020-06-05 07:33:34

cristatus
Member
Registered: 2014-01-04
Posts: 10

Re: No sound from left speaker

I have tried many ways but unable to figure out the issue. As it's happening randomly, it's more difficult.

I tried installing linux-lts where it is working perfectly fine. So it looks like that the issue is with current kernel. However, I have tried fedora 32 too with same kernel and there is no such issue. So not sure what's wrong.

Can anyone help?

Offline

#3 2020-06-11 05:49:03

cristatus
Member
Registered: 2014-01-04
Posts: 10

Re: No sound from left speaker

This is really frustrating. I tried every possible troubleshooting. Here is what I observe:

When it happens, I boot to fedora 32 where it works fine. I reboot to arch and both speaker starts working fine.

I tried installing linux-lts and there is no such issue but I have to use latest kernel for few reasons and can't use LTS kernel.

Also sometime when I remove headphone jack, there is no sound coming from the laptop speakers. I confirmed, it's not the auto-mute issue.

Does anyone here see similar issues?

Offline

#4 2020-06-11 07:22:12

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,123

Re: No sound from left speaker

Post some actable information, three bumps in and we don't know anything about your hardware or which state it is in in [ code ] [ /code ] tags without the spaces:

aplay -l
amixer -c0 #or the index of the correct card according to aplay -l

Symptoms sound like your mixer restore table is broken, try running a

sudo alsactl init

Offline

#5 2020-06-21 05:17:47

cristatus
Member
Registered: 2014-01-04
Posts: 10

Re: No sound from left speaker

Thanks @V1del, I am still struggling with the issue. The strange thing is, it's always working with Fedora 32 and when I come back to Arch after Fedora 32 boot, it starts working.

Here are the output of the commands you suggested:

> aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: Generic Analog [Generic Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 12: HDMI 6 [HDMI 6]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
> amixer -c0

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 74
  Mono: Playback 50 [68%] [-24.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 0 [0%] [-74.00dB] [off]
  Front Right: Playback 0 [0%] [-74.00dB] [off]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 74 [100%] [0.00dB] [on]
  Front Right: Playback 74 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 254 [100%] [-0.20dB]
  Front Right: Playback 254 [100%] [-0.20dB]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 80
  Front Left: Capture 80 [100%] [6.00dB] [off]
  Front Right: Capture 80 [100%] [6.00dB] [off]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [36.00dB]
  Front Right: 3 [100%] [36.00dB]
> sudo alsactl init

alsa-lib main.c:983:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -2
Found hardware: "HDA-Intel" "Conexant Generic" "HDA:14f120d0,103c842a,00100001 HDA:8086280b,80860101,00100000" "0x103c" "0x842a"
Hardware is initialized using a generic method
alsa-lib main.c:983:(snd_use_case_mgr_open) error: failed to import hw:1 use case configuration -2
Found hardware: "HDA-Intel" "Nvidia GPU 80 HDMI/DP" "HDA:10de0080,00000000,00100100" "0x0000" "0x0000"
Hardware is initialized using a generic method

I have tried comparing dmesg output when the issue happens and when it works. I don't see any difference in the dmesg log. So this is really strange.

Earlier, I mentioned that it was working with LTS kernel but it's not. The issue happens less randomly with LTS kernel.

To check whether it's an hardware issue or not, I installed Windows 10 on a second ssd and I don't see any issue. I also ran HP Hardware diagnosis (UEFI) and speaker test is passed without any issue (both speakers worked).

Offline

#6 2020-06-21 06:40:33

cristatus
Member
Registered: 2014-01-04
Posts: 10

Re: No sound from left speaker

Here is the output from Fedora 32:

❯ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: Generic Analog [Generic Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

❯ amixer -c0

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 74
  Mono: Playback 65 [88%] [-9.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 0 [0%] [-74.00dB] [off]
  Front Right: Playback 0 [0%] [-74.00dB] [off]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 74 [100%] [0.00dB] [on]
  Front Right: Playback 74 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 254 [100%] [-0.20dB]
  Front Right: Playback 254 [100%] [-0.20dB]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 80
  Front Left: Capture 80 [100%] [6.00dB] [on]
  Front Right: Capture 80 [100%] [6.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]

❯ sudo alsactl init

alsa-lib main.c:983:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -2
Found hardware: "HDA-Intel" "Conexant Generic" "HDA:14f120d0,103c842a,00100001 HDA:8086280b,80860101,00100000" "0x103c" "0x842a"
Hardware is initialized using a generic method
alsa-lib main.c:983:(snd_use_case_mgr_open) error: failed to import hw:1 use case configuration -2
Found hardware: "HDA-Intel" "Nvidia GPU 80 HDMI/DP" "HDA:10de0080,00000000,00100100" "0x0000" "0x0000"
Hardware is initialized using a generic method

So mostly, it is same.

Offline

#7 2020-07-08 08:52:07

cristatus
Member
Registered: 2014-01-04
Posts: 10

Re: No sound from left speaker

Hi @V1del,

Would you elaborate on "mixer restore table"? I am still struggling with this issue.

Offline

#8 2020-07-29 15:48:50

cristatus
Member
Registered: 2014-01-04
Posts: 10

Re: No sound from left speaker

I am still facing this issue, quite consistently. It's really frustrating. I have tried every possible troubleshooting. Can someone help me figure out what's the issue?

Offline

#9 2020-08-03 00:13:54

cristatus
Member
Registered: 2014-01-04
Posts: 10

Re: No sound from left speaker

Hi @V1del,

Can you help? This is really strange. I have to boot to fedora and reboot to start Arch to make left speaker work again.

Offline

#10 2020-08-03 08:42:00

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,123

Re: No sound from left speaker

Please don't bump your thread that often: https://wiki.archlinux.org/index.php/Co … ct#Bumping

Is the linux-firmware package installed? That would be the only thing coming to mind that has a direct impact on that low of a level. Also are there differences in boot modes between fedora and Arch? Is Arch installed in UEFI but fedora in BIOS mode or vice-versa? Maybe also post the previously requested outputs and addiitonaly a

dmesg | grep -E 'snd|sof'

from the fedora and the Arch system for comparison

Last edited by V1del (2020-08-03 08:49:04)

Offline

#11 2020-08-03 11:35:33

cristatus
Member
Registered: 2014-01-04
Posts: 10

Re: No sound from left speaker

V1del wrote:

Please don't bump your thread that often: https://wiki.archlinux.org/index.php/Co … ct#Bumping

Sorry, I will make sure to follow the guidelines.

V1del wrote:

Is the linux-firmware package installed? That would be the only thing coming to mind that has a direct impact on that low of a level. Also are there differences in boot modes between fedora and Arch? Is Arch installed in UEFI but fedora in BIOS mode or vice-versa? Maybe also post the previously requested outputs and addiitonaly a

dmesg | grep -E 'snd|sof'

from the fedora and the Arch system for comparison

Yes linux-firmaware package is installed (version 20200721.2b823fc-1). The only difference is, on fedora I have nouveau drivers while on arch I have nvidia binary drivers (for prime offloading). Both are UEFI installations booted with systemd-boot (I configured fedora to use systemd-boot).

Here is the output of

dmesg | grep -E 'snd|sof'

from Arch:

[    4.286429] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    4.286431] software IO TLB: mapped [mem 0x69a53000-0x6da53000] (64MB)
[   42.048316] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[   42.048605] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[   42.048902] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   42.049008] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
[   42.049081] snd_hda_intel 0000:01:00.1: Disabling MSI
[   42.049094] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[   42.131745] snd_hda_codec_generic hdaudioC0D0: autoconfig for Generic: line_outs=1 (0x1d/0x0/0x0/0x0/0x0) type:speaker
[   42.131746] snd_hda_codec_generic hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   42.131748] snd_hda_codec_generic hdaudioC0D0:    hp_outs=1 (0x16/0x0/0x0/0x0/0x0)
[   42.131749] snd_hda_codec_generic hdaudioC0D0:    mono: mono_out=0x0
[   42.131750] snd_hda_codec_generic hdaudioC0D0:    inputs:
[   42.131751] snd_hda_codec_generic hdaudioC0D0:      Internal Mic=0x1a
[   42.131752] snd_hda_codec_generic hdaudioC0D0:      Mic=0x19

and from fedora:

[    4.524602] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    4.524606] software IO TLB: mapped [mem 0x69a53000-0x6da53000] (64MB)
[    4.695931] integrity: Loaded X.509 cert 'Microsoft Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53'
[    4.695945] integrity: Loaded X.509 cert 'Microsoft Corporation UEFI CA 2011: 13adbf4309bd82709c8cd54f316ed522988a1bd4'
[   18.753414] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[   18.754535] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[   18.755274] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   18.755924] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
[   18.756183] snd_hda_intel 0000:01:00.1: Disabling MSI
[   18.756188] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[   18.849654] snd_hda_codec_generic hdaudioC0D0: autoconfig for Generic: line_outs=1 (0x1d/0x0/0x0/0x0/0x0) type:speaker
[   18.849655] snd_hda_codec_generic hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   18.849656] snd_hda_codec_generic hdaudioC0D0:    hp_outs=1 (0x16/0x0/0x0/0x0/0x0)
[   18.849656] snd_hda_codec_generic hdaudioC0D0:    mono: mono_out=0x0
[   18.849657] snd_hda_codec_generic hdaudioC0D0:    inputs:
[   18.849658] snd_hda_codec_generic hdaudioC0D0:      Internal Mic=0x1a
[   18.849658] snd_hda_codec_generic hdaudioC0D0:      Mic=0x19
[   18.859264] snd_hda_intel 0000:01:00.1: bound 0000:01:00.0 (ops nv50_audio_component_bind_ops [nouveau])

Last edited by cristatus (2020-08-03 11:37:25)

Offline

Board footer

Powered by FluxBB