You are not logged in.

#1 2006-10-02 06:32:28

leviathan
Member
Registered: 2005-11-04
Posts: 26

Installation problem on 0.7.2 (busybox.......)

I've downloaded arch 0.7.2

The installation work fine, but on reboot i have this error message:

Mounting /dev/root on /new_root failed: No such device or address.
pivot_root: No such file or directory
umount: /initrd: No such file or directory
/linuxrc: 487: /sbin/busybox not found
Freeing unused kernel memory 244 k freed

BusyBox v1.01
Enter 'help' for ...

/bin/sh: can't access tty: job control turned off.

I tried the iso made by topwa but cant'boot....... now I'm on-line with ubuntu :cry:

This is my menu.lst

title Arch!
[code]root (hd0,1)
kernel /boot/vmlinuz26 root=/dev/hda2 ro
initrd /boot/initrd26.img[/code]

This is my lspci


leviathan@dragonheart:~$ lspci
00:00.0 Host bridge: Intel Corporation 945G/GZ/P/PL Express Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 945G/GZ/P/PL Express PCI Express Root Port (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) Serial ATA Storage Controller IDE (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:03.0 Mass storage controller: Integrated Technology Express, Inc. ITE 8211F Single Channel UDMA 133 (ASUS 8211 (ITE IT8212 ATA RAID Controller)) (rev 11)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 19)
04:00.0 VGA compatible controller: nVidia Corporation GeForce 6200 TurboCache(TM) (rev a1)

My portal: www.reboots.net - Developer of ZippHO: www.zippho.org

Offline

#2 2006-10-02 06:53:02

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: Installation problem on 0.7.2 (busybox.......)

Hi
you can try these installation method

http://wiki.archlinux.org/index.php/Ins … her_distro


Have you tried to turn it off and on again?

Offline

#3 2006-10-02 07:09:42

leviathan
Member
Registered: 2005-11-04
Posts: 26

Re: Installation problem on 0.7.2 (busybox.......)

fk wrote:

Hi
you can try these installation method

http://wiki.archlinux.org/index.php/Ins … her_distro


roll  roll installation work fine..... the problem is the boot from disk after install.

P.S. i tried installation form ftp but the module of my eth card wont'load  :cry:

marvell ---> sky2


My portal: www.reboots.net - Developer of ZippHO: www.zippho.org

Offline

#4 2006-10-02 07:22:19

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: Installation problem on 0.7.2 (busybox.......)

Oh I have misunderstod...sry

hm, do you have an extra /boot partition?

And initrd is gone, use mkinitcpio


Have you tried to turn it off and on again?

Offline

#5 2006-10-02 07:46:34

leviathan
Member
Registered: 2005-11-04
Posts: 26

Re: Installation problem on 0.7.2 (busybox.......)

0.7.2 iso use mkinicpio  roll

and.....

root (hd0,1)
kernel /boot/vmlinuz26 root=/dev/hda2 ro
initrd /boot/initrd26.img

My portal: www.reboots.net - Developer of ZippHO: www.zippho.org

Offline

#6 2006-10-02 07:49:32

fk
Member
From: Germany
Registered: 2006-04-29
Posts: 524

Re: Installation problem on 0.7.2 (busybox.......)

leviathan wrote:

0.7.2 iso use mkinicpio  roll

and.....

root (hd0,1)
kernel /boot/vmlinuz26 root=/dev/hda2 ro
initrd /boot/initrd26.img


then you must use kernel.26.img not initrd.img

and I mean If you have an extra /boot you must use

kernel vmlinuz26 root=/dev/hda2 ro

not

kernel /boot/vmlinuz26 root=/dev/hda2 ro

Have you tried to turn it off and on again?

Offline

#7 2006-10-12 05:46:19

once
Member
From: Taiwan
Registered: 2006-09-12
Posts: 211

Re: Installation problem on 0.7.2 (busybox.......)

change hda1 to hde1 (fstab and menu.lst)

Offline

Board footer

Powered by FluxBB