You are not logged in.

#1 2020-06-18 15:15:05

Trix213
Member
From: Germany
Registered: 2020-03-26
Posts: 19

No registered output devices for sound found in pavucontrol

Hi folks,

I installed Arch on my laptop recently and ran into sound issues, pavucontrol shows no output devices except for the 'dummy output' and I can't actually get sound out of my system. When playing videos, songs etc. which should supposedly output sound, it shows up in pavucontrol though.

Here's the information regarding my system I could gather from alsamixer, if you need anything else/more, please let me know.

/proc/asound/version

Advanced Linux Sound Architecture Driver Version k5.7.2-arch1-1.

/proc/asound/cards

0 [NVidia        ]:  HDA-Intel - HDA-NVidia
                          HDA NVidia at 0x83000000 irq  17

/proc/asound/devices

2: [ 0- 3]: digital audio playback
3: [ 0- 7]: digital audio playback
4: [ 0- 8]: digital audio playback
5: [ 0- 9]: digital audio playback
6: [ 0- 10]: digital audio playback
7: [0- 0]: hardware dependant
8: [ 0]: control
33: timer

/proc/asound/oss/devices was empty

/proc/asound/timers

G0: system timer: 3333.333us (10000000 ticks)
P0-3-0: PCM playback 0-3-0 : SLAVE
P0-7-0: PCM playback 0-7-0 : SLAVE
P0-8-0: PCM playback 0-8-0 : SLAVE
P0-9-0: PCM playback 0-9-0 : SLAVE
P0-10-0: PCM playback 0-10-0 : SLAVE 

/proc/asound/pcm

00-03: HDMI 0 : HDMI 0 : playback 1
00-07: HDMI 1 : HDMI 1 : playback 1
00-08: HDMI 2 : HDMI 2 : playback 1
00-09: HDMI 3 : HDMI 3 : playback 1
00-10: HDMI 4 : HDMI 4 : playback 1

When opening alsamixer it shows following information:
Card: HDA NVidia
Chip: NVidia GPU 80 HDMI/DP
Items: S/PDIF, S/PDIF 1-4 (all show 00 with green background)

Thanks in advance for any tips and help,
Daniel

Last edited by Trix213 (2020-06-18 16:29:29)

Offline

#2 2020-06-18 16:40:12

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,995

Re: No registered output devices for sound found in pavucontrol

What's your output for

dmesg | grep snd
lspci -k

Offline

#3 2020-06-19 08:50:24

Trix213
Member
From: Germany
Registered: 2020-03-26
Posts: 19

Re: No registered output devices for sound found in pavucontrol

[daniel@HP-Arch ~]$ dmesg | grep snd
[    2.832999] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    2.833225] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    2.833524] snd_hda_intel 0000:01:00.1: Disabling MSI
[    2.833529] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    3.291882] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    3.292059] snd_soc_skl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver

and

[daniel@HP-Arch ~]$ lspci -k
00:00.0 Host bridge: Intel Corporation 8th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: skl_uncore
lspci: Unable to load libkmod resources: error -12
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
	Kernel driver in use: pcieport
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
	DeviceName: Intel(R) UHD Graphics 630
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: i915
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 07)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: proc_thermal
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
	Subsystem: Hewlett-Packard Company Device 847b
00:12.0 Signal processing controller: Intel Corporation Cannon Lake PCH Thermal Controller (rev 10)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: intel_pch_thermal
00:14.0 USB controller: Intel Corporation Cannon Lake PCH USB 3.1 xHCI Host Controller (rev 10)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: xhci_hcd
00:14.2 RAM memory: Intel Corporation Cannon Lake PCH Shared SRAM (rev 10)
	Subsystem: Hewlett-Packard Company Device 847b
00:14.3 Network controller: Intel Corporation Wireless-AC 9560 [Jefferson Peak] (rev 10)
	DeviceName: WLAN
	Subsystem: Intel Corporation Device 0034
	Kernel driver in use: iwlwifi
00:16.0 Communication controller: Intel Corporation Cannon Lake PCH HECI Controller (rev 10)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: mei_me
00:17.0 SATA controller: Intel Corporation Cannon Lake Mobile PCH SATA AHCI Controller (rev 10)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: ahci
00:1c.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #1 (rev f0)
	Kernel driver in use: pcieport
00:1d.0 PCI bridge: Intel Corporation Cannon Lake PCH PCI Express Root Port #9 (rev f0)
	Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation Device a30e (rev 10)
	Subsystem: Hewlett-Packard Company Device 847b
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: sof-audio-pci
00:1f.4 SMBus: Intel Corporation Cannon Lake PCH SMBus Controller (rev 10)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: i801_smbus
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Lake PCH SPI Controller (rev 10)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: intel-spi
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-LM (rev 10)
	DeviceName: Intel(R) Ethernet Connection I219-LM
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: e1000e
01:00.0 VGA compatible controller: NVIDIA Corporation GP107GLM [Quadro P600 Mobile] (rev a1)
	DeviceName: NVIDIA Quadro P600
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: nvidia
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
	Kernel driver in use: snd_hda_intel
3c:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
	Subsystem: Hewlett-Packard Company Device 847b
	Kernel driver in use: rtsx_pci

Thank you for trying to help! smile

Offline

#4 2020-06-19 11:05:54

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,995

Re: No registered output devices for sound found in pavucontrol

Is sof-firmware (and for completeness sake linux-firmware) installed? If it is and it still doesn't work what's your output for

dmesg | grep -E 'sof|snd' #Sorry didn't realize that sof drivers do not necessary have a snd in their string :/

Something you can try should installing these packages and rebooting not suffice, is forcing it to use the older HDA implementation via a /etc/modprobe.d/dsp-fix.conf

options snd_intel_dspcfg dsp_driver=1

but you should only use that if it doesn't work with sof-firmware

Last edited by V1del (2020-06-19 11:11:19)

Offline

#5 2020-06-19 12:54:41

Trix213
Member
From: Germany
Registered: 2020-03-26
Posts: 19

Re: No registered output devices for sound found in pavucontrol

I had to install sof-firmware and rebooted afterwards, now this is the output I get:

[daniel@HP-Arch ~]$ dmesg | grep -E 'sof|snd'
[    0.590682] PCI-DMA: Using software bounce buffering for IO (SWIOTLB)
[    0.590684] software IO TLB: mapped [mem 0x66005000-0x6a005000] (64MB)
[    2.899610] snd_hda_intel 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    2.899839] snd_hda_intel 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    2.900069] snd_hda_intel 0000:01:00.1: Disabling MSI
[    2.900074] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client
[    3.218858] snd_soc_skl 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    3.251070] snd_soc_skl 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    3.400960] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if info 0x040380
[    3.401159] sof-audio-pci 0000:00:1f.3: Digital mics found on Skylake+ platform, using SOF driver
[    3.401377] sof-audio-pci 0000:00:1f.3: DSP detected with PCI class/subclass/prog-if 0x040380
[    3.525638] sof-audio-pci 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    3.567473] sof-audio-pci 0000:00:1f.3: use msi interrupt mode
[    3.624847] sof-audio-pci 0000:00:1f.3: hda codecs found, mask 5
[    3.624848] sof-audio-pci 0000:00:1f.3: using HDA machine driver skl_hda_dsp_generic now
[    6.723620] sof-audio-pci 0000:00:1f.3: error: cl_copy_fw: timeout HDA_DSP_SRAM_REG_ROM_STATUS read
[    6.724064] sof-audio-pci 0000:00:1f.3: error: load fw failed ret: -110
[    6.724115] sof-audio-pci 0000:00:1f.3: error: status = 0x0000002c panic = 0x00000000
[    6.724127] sof-audio-pci 0000:00:1f.3: error: failed to reset DSP
[    6.724134] sof-audio-pci 0000:00:1f.3: error: failed to boot DSP firmware -110
[    6.775274] sof-audio-pci 0000:00:1f.3: error: hda_dsp_core_reset_enter: timeout on HDA_DSP_REG_ADSPCS read
[    6.775276] sof-audio-pci 0000:00:1f.3: error: dsp core reset failed: core_mask f
[    6.775467] sof-audio-pci 0000:00:1f.3: error: sof_probe_work failed err: -110

Pavucontrol still shows no output device. I will try the work around and edit this post if it works.

Edit: The workaround worked fine. If you'd like to assist me further in making my system work without this workaround I'll gladly leave this thread open and will stick around, other wise I will mark it as closed.

Thx, Daniel

Last edited by Trix213 (2020-06-19 12:59:52)

Offline

Board footer

Powered by FluxBB